Results 1 to 3 of 3

Thread: How to enable sqlite for php apache

  1. #1
    Junior Member
    Join Date
    Dec 2014
    Posts
    5

    How to enable sqlite for php apache

    Hello,

    when i try to install php-sqltie i get the following error. I have donloaded and installed the knoppix dvd to a flash drive and every thing is working as expected except a minor glitch i can't run php-sqlite on the apace server when i tried to install it i get the following error:

    apt-get install php5-sqlite
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     php5-sqlite : Depends: phpapi-20100525+lfs
                   Depends: php5-common (= 5.4.35-0+deb7u2) but 5.6.4+dfsg-1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    i even tried updating through synaptic but it isn't working out.
    Kindly help me out i am lost about what to do next.

    Thank you.

    CMG

  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    Knoppix is a mix of stable, testing , unstable and Knoppix own scripts.

    You can use the 2nd suggestion of
    Code:
    su
    aptitude update
    aptitude -s install -t unstable php5-sqlite
    If you really want to install omit "-s" (simulate).

    I hope, you will not use apache server outside of your LAN.

  3. #3
    Junior Member
    Join Date
    Dec 2014
    Posts
    5
    Thank u,

    it works like a charm.

    I am using it for development purposes only and not as a production server.

    with best regards


    CMG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •