Results 1 to 4 of 4

Thread: Install Racket?

  1. #1
    Junior Member
    Join Date
    Nov 2006
    Posts
    7

    Install Racket?

    Golly, wouldn't it be great if everything worked the way it's supposed to?

    I just loaded Racket (Dr. Racket) from the .sh for Debian Squeeze. Although it says it installed OK, when I tried to run it, I got an exec error. Has anyone else had a problem or maybe a fix?

    I'm running Knoppix on a Gateway LT4010u with an Atom N2600. I've tried other Linux distros on this system and Knoppix has been the best in performance and ease...until I tried to run Racket.

    Thanks, Mike

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    Hello Mike,

    you forgot to tell us which Knoppix version you used.

    Have you already tried the package(s) from the Debian repository?

  3. #3
    Junior Member
    Join Date
    Nov 2006
    Posts
    7
    Sorry- I am running 7.4. I just assumed that would be obvious from a new installation, but considering that I probably have 12 or 13 older versions in my CD cart I should have been more specific.

    Now it's funny you should mention the repositories....
    Earlier this evening I installed lots of LISP-related packages, both from the command line apt-get and from synaptic package manager. For about an hour now, all installations attempts have been met with failure. The error being "size mismatch." Since this only happened when I started to install Scheme-related packages I have no way of telling whether the problem is upstream or where.

    BTW, the "exec format error" is on line 96 of the drracket script, but I couldn't determine the source of the problem so I opted to remove the whole /usr/racket directory and try to install from the repositories.

    I'm a little under the gun timewise, and I really didn't expect this many problems. I may have to postpone the Scheme project for a week or so, but if the repositories don't work I will need to fix the .sh installation.

    Thanks for responding,
    Mike

  4. #4
    Junior Member
    Join Date
    Nov 2006
    Posts
    7
    Ok, it may have been a network problem, or apt may have glitched. I rebooted and re-connected and racket installed fine from the repositories through synaptic. It looks like guile is also going to be successful.

    While I was having the problem I noticed that apt didn't recognize -f or --fix-missing options. This is what made me wonder if apt glitched.

    Thank you all for your help. One last question: How do I mark this problem SOLVED?

    Mike

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •