Results 1 to 3 of 3

Thread: No gateway for Termnial Server PXE client

  1. #1
    Junior Member
    Join Date
    Jan 2015
    Posts
    2

    No gateway for Termnial Server PXE client

    Hi,

    using latest 7.4.2 DVD.
    Terminal Server works great after fixing /etc/init.d/knoppix-terminalserver init=/etc/init --> init=/sbin/init.

    I can boot any client over PXE, it's just amazing. But I my client don't get a network gateway for some reason.
    Everything works well on the server side. It's booted under a bridged VirtualBox on Windows 7

    And I cannot add the route manually on clients since I can't get past any su -, sudo or passwd.
    I couldn't figure the password. hahem, sounds stupid but I couldn't find it on Google or this forum.
    Works fine without any password on server though.

    Additionally, I have some device on the LAN that get confused with the terminal server DHCPD: they get IP from its range instead of from the router. Is there a way to avoid this ?

    cheers

  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    I couldn't figure the password.
    Deactivate the option "secure" within the terminalserver setup, if you want root-access.

  3. #3
    Junior Member
    Join Date
    Jan 2015
    Posts
    2
    Quote Originally Posted by Werner P. Schulz View Post
    Deactivate the option "secure" within the terminalserver setup, if you want root-access.
    thanks, i missed this one, works well now, I can sudo and manually add the gateway and get internet.

    But why isn't the default route set??
    I activated the 3 other options: masq, dns, squid

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •