Results 1 to 6 of 6

Thread: virtual box not running giving error

  1. #1
    Junior Member
    Join Date
    Jan 2015

    virtual box not running giving error


    I am trying to run virtual box but after creating a simple machine when i start it i get the following message:

    RTR3InitEx failed with rc=-1912 (rc=-1912)
    The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing
    '/etc/init.d/vboxdrv setup'
    may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.
    i tried using original update 4.3 one from virtual box website- not working same error.
    i tried using repositary given on their website - not working same error.
    i tried uninstalling it and then updating it -not working same error.

    I am try not to select the ose version even then it dosen't work.

    what am i missing here. Is there a solution.

    Thank you


  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Germany/ Dietzenbach
    The only solution for me has been: purge all of VirtualBox within Knoppix 7.4.2 and install the latest version from Virtualbox website.

  3. #3

    A Quick Fix

    Hi, guys:

    While peeking around the /etc/init.d/vboxdrv available exclusively from Oracle's VBox package, I stumbled upon a quick but dirty fix for this particular error seen on KNOPPIX 7.4.2 which is to delete the device, /dev/vboxdrv , before launching the program by either executing startvirtualbox in terminal or clicking the entry in Start Menu > System Tools > VirtualBox. After digging a bit, this device seems to originate from /KNOPPIX/lib/udev/devices/vboxdrv created by the early version of virtualbox (2009).
    knoppix@Microknoppix:~$ ls -l /KNOPPIX/lib/udev/devices/vb*
    crw-rw---- 1 root avahi 10, 59 Feb  7  2009 /KNOPPIX/lib/udev/devices/vboxdrv
    For some reason, VirtualBox 4.3.14 plays well with this existing device on KNOPPIX 7.2 but gets indigestion on 7.4.2. It may be more ideal to delete this stub once and for all and let the vboxdrv module create the needed device by itself during loading.

    Just for a side note, the name of virtualbox has been changed from virtualbox to VirtualBox, so Line 5 of startvirtualbox script probably needs to be amended accordingly in order to avoid killing the already running vbox-related modules by accident.

    The vbox-related scripts from Oracle's package (version 4.2.6) are attached in case it is of interest.

    Attached Files Attached Files

  4. #4

    Update -- 14/OCT

    Sorry to bump up this stone-cold thread, but I just got trapped by the same error message again while transplanting the KNOPPIX 7.4.2 to a bit newer laptop yesterday. After messing around for a while, I just realised that, apart from the existence of the old /dev/vboxdrv, running with 64-bit kernel was also another cause for the error.

  5. #5
    Junior Member registered user
    Join Date
    Aug 2008
    Here is the error I am getting any tips I would be grateful!...

    The virtual machine 'Windows XP' has terminated unexpectedly during startup with exit code 1 (0x1).
    Result Code: NS_ERROR_FAILURE (0x80004005)
    Component: MachineWrap
    Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}
    Here is the content of my vboxconfig file...

    # Oracle VM VirtualBox
    # VirtualBox Linux post-installer common portions
    # Copyright (C) 2015 Oracle Corporation
    # This file is part of VirtualBox Open Source Edition (OSE), as
    # available from This file is free software;
    # you can redistribute it and/or modify it under the terms of the GNU
    # General Public License (GPL) as published by the Free Software
    # Foundation, in version 2 as it comes in the "COPYING" file of the
    # VirtualBox OSE distribution. VirtualBox OSE is distributed in the
    # hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
    # Put bits of the post-installation here which should work the same for all of
    # the Linux installers.  We do not use special helpers (e.g. dh_* on Debian),
    # but that should not matter, as we know what those helpers actually do, and we
    # have to work on those systems anyway when installed using the all
    # distributions installer.
    # We assume that all required files are in the same folder as this script
    # (e.g. /opt/VirtualBox, /usr/lib/VirtualBox, the build output directory).
    # This is GNU-specific, sorry Solaris.  It fails on directories ending in '\n'.
    MY_PATH="$(dirname $(readlink -f -- "${0}"))"
    cd "${MY_PATH}"
    . "./"
    while test -n "${1}"; do
     case "${1}" in
                echo "Bad argument ${1}" >&2
                exit 1
    # Install runlevel scripts and systemd unit files
    install_init_script "${TARGET}/" vboxdrv
    install_init_script "${TARGET}/" vboxballoonctrl-service
    install_init_script "${TARGET}/" vboxautostart-service
    install_init_script "${TARGET}/" vboxweb-service
    delrunlevel vboxdrv
    addrunlevel vboxdrv
    delrunlevel vboxballoonctrl-service
    addrunlevel vboxballoonctrl-service
    delrunlevel vboxautostart-service
    addrunlevel vboxautostart-service
    delrunlevel vboxweb-service
    addrunlevel vboxweb-service
    ln -sf "${MY_PATH}/" /sbin/vboxconfig
    test -n "${START}" &&
        start_init_script vboxdrv
    Last edited by tulsamike3434; 10-27-2015 at 05:14 PM.

  6. #6
    Just did a quick trial run to boot up a Win2K virtual machine using VirtualBox 5.0.8 (built for wheezy, downloaded from Oracle) on KNOPPIX 7.4.2 (Live Mode), and got a similar error message when the modules of vboxdrv, vboxnetadp, vboxnetflt and vboxpci had not been loaded in advance. By any chance, was there an error message of " Kernel driver not installed ( rc=-1908 )" popping up while booting up the virtual machine? If it's the case, a quick fix could be to start the VirtuaBox using the terminal command of startvirtualbox or the menu entry of Start Menu > System Tools > VirtualBox. By the way, the original shell script of startvirtualbox doesn't load the vboxpci module, so you may need to take that into account if there is still no joy.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Lenovo Thinkpad Yoga Touchscreen Laptop Computer Windows 10 4GB 128GB SSD HDMI picture

Lenovo Thinkpad Yoga Touchscreen Laptop Computer Windows 10 4GB 128GB SSD HDMI


Lenovo IdeaPad 3 15 Laptop, 15.6

Lenovo IdeaPad 3 15 Laptop, 15.6" FHD, Ryzen 5 5625U, 16GB, 512 GB SSD


Lenovo N23 Yoga 2.1 GHz 32GB eMMC - 4GB ( Flip design ) picture

Lenovo N23 Yoga 2.1 GHz 32GB eMMC - 4GB ( Flip design )


Lenovo ThinkPad 11e Chromebook 11.6

Lenovo ThinkPad 11e Chromebook 11.6" Laptop | 16GB SSD | Chrome OS


Lenovo - Chromebook 3 11.6

Lenovo - Chromebook 3 11.6" HD Laptop - Celeron N4020 - 4GB Memory - 64GB eMM...


Lenovo Legion 5 15.6

Lenovo Legion 5 15.6" 120Hz Laptop AMD R5-4600H 8GB RAM 512GB SSD GTX 1650Ti


Lenovo Legion 5 Pro 16 165Hz QHD IPS G-Sync Ryzen 7 16GB RAM 1TB SSD RTX 3070 picture

Lenovo Legion 5 Pro 16 165Hz QHD IPS G-Sync Ryzen 7 16GB RAM 1TB SSD RTX 3070


Lenovo IdeaPad Gaming 3 15.6

Lenovo IdeaPad Gaming 3 15.6" 120Hz i5-11300H 8GB RAM 512GB SSD GTX 1650


Lenovo ThinkPad Yoga 12.5

Lenovo ThinkPad Yoga 12.5" Core i3 4GB 128GB SSD Windows 10 2-in-1 Laptop/Tablet


Lenovo ThinkPad x131e Chromebook 11.6

Lenovo ThinkPad x131e Chromebook 11.6" 1.5GHz 2GB RAM 16GB SSD WEBCAM FAST