I've encountered a problem with Knoppix which may be due to my use of a 2 tb USB hard drive. I would appreciate any suggestions.

Background I have been backing up my desktop and my wife's desktop WINXP computers using portable USB hard drives and Knoppix file utilities. Things have been working well. USB port is USB 2, and some of the 500 gb and 1 tb drives are USB 2 and some USB 3. File system is NTFS on the source computers and the target drives. I use "Copy" on the source files and "Paste" on the target drives. Transfer takes about four hours for 80 to 90 gb.

I got a couple of larger drives (2 tb) and cannot get the backups to record. The drives are recognized and the backup starts, but fails with no error message after about two or three folders. Problem is the same on either drive (Seagate expansion portable drive). I have tried partitioning the 2 tb drives to 2 one tb partitions to no avail. Same result.

I have tried using the 2 tb drives directly on windows and have copied large volumes of files directly, so it appears the drives are not at fault.

I would like to continue to use Knoppix to do the transfer, however, because it does not have the problem with long windows filenames nor distress at copying windows system files .

Request Does anybody have any idea of what might account for this difference, or any tests I might run to help diagnose what may be causing the difference?