Results 1 to 6 of 6

Thread: Language Pack for Libreoffice problem

  1. #1
    Junior Member
    Join Date
    Feb 2015
    Posts
    3

    Post Language Pack for Libreoffice problem

    Hello.

    Has someone had a problem while installing an additional language pack for Libreoffice on Knoppix, while using Synaptics Package Manager?

    My problem is, when I'm trying to install for example, the Spanish translation for Libreoffice, Synaptics requires to "Uninstall" some things and update others,
    while is actually, uninstalling the whole Libreoffice suite. But the language pack install succesfully, but it leaves me broken packages of Libreoffice that are unable
    to repair.

    Note: I have Knoppix 7.4.2 installed on a Kingston DT SE9 32GB, with persistent image

    Please note i have re-installed the whole system 5 times and the same error continues. Please avoid telling that the persistent image is corrupt, Knoppix installation is
    corrupt, since it has fresh untouched settings or your system is obsolete.

  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    Spanish translation for Libreoffice
    What is the exact name of this tool you've found within Synaptic?

    Normally you don't need Synaptic to install additional tools for LibreOffice. Have a look for example at this website and especially at this PDF.

  3. #3
    Not sure if this thread will help

    http://knoppix.net/forum/threads/296...or-LibreOffice

    It did help me install myspell-en-gb successfully.

  4. #4
    Junior Member
    Join Date
    Feb 2015
    Posts
    3
    Sorry about the long time since thread was with no activity

    Werner, you can find it like "libreoffice-l10n-es" under Synaptics, this is the official LibreOffice Spanish Translation Pack, it translates al the programs GUI text in the language anyone desires. Im not trying to install extensions, since that is another subject. Have tried again with no succes, instead, it needs to uninstall LibreOffice, and install the LP, .....strange.

  5. #5
    Junior Member
    Join Date
    Feb 2015
    Posts
    3
    SOLVED Thanks Superman. Credits to him.The key is NOT DEPENDING FROM SYNAPICS INSTALLER.1.- First identifie your LibreOffice build. Knoppix 7.4.2 is 4.3.2.2, for Debian Wheezy / Stable (Keep this in mind)2.- Download your LibreOffice Language pack of your choice from this page https://packages.debian.org/wheezy/localization/ (This is Debian's package source for every Debian-based build like Knoppix)3.- After you download it , right click on the .debs package and open it with GDebi Package Installer4.- GDebi will recognize the package showing "all dependencies are satisfactory"5.- Press install button6.- Once installed, close, and enjoy LibreOffice in your language.Note: This is not for installing a dictionary for correction. This is to change the GUI's language. Thanks to everyone and use Linux.

  6. #6
    @ pixtun

    Glad the link helped. All credit to klaus2008!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •