I'm back again with similar issues and I'll try to dispense with the "bloated writing". I finally did get Knoppix 7.4 to work and enjoyed it along with 7.2 for a few years before 7.4 started acting up (on USB stick) and became unbootable. I then went back to 7.2 and was able to see, copy and edit files on the 7.4 stick and I've been putting up with that for a while until I found Knoppix 8.1. I've been trying to get that to work for about 5 months with limited luck. After about 40 attempts to get 8.1 on a 16 gb stick using UNetbootin-Universal Netboot Installer version and Universal USB Installer version (Pendrivelinux) I finally got one to work but not just right. Once I got one to boot (I forget which installer did it right) but not very well. I've since been working with two sticks using one that worked the best to keep trying to get one to work better. During one attempt I was offered to make the persistant overlay. The max was 10559mb but I was never able to move the slider to select a lesser amount until today. After about 10 attempts I now have one with a 4024 mb partition but the partition shows unknown file system. In all of the previous attempts I used gparted to format that partition as fat 32 but that would cause me to lose settings (like background image) between boots. I also decided to encrypt that section with a password but after formatting that partition I have to enter the password 3 times before it works. The current version I have now has /dev/sda1 fat32 /mnt-system KNOPPIX 10.50 GiB 4.23 GiB used 6.27 GB un boot and /dev/sda2 unknown (fs) 4.44 GiB
Because I haven't formatted the unknown partition like before I only have to enter the password once when booting. If I'm in file manager and select sda2 to try to get into that partion (with the unknown file system) I get "mount: /dev/sda2 is already mounted or /media/sda2 busy" . After most of the attempts I've made I'm able to see the wireless network I want to connect to and everything seems right it never is able to connect and just pops up with the password screen again. Some of the attempts worked with no problems for the wireless but nothing else worked right.

With Knoppix 7.2 and 7.4 when they were working were just what I wanted but I would really like to get a working version of 8.1 I don't understand why I can get a working version.