Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Language

  1. #11
    Junior Member
    Join Date
    Oct 2015
    Posts
    5
    Thanks for all the suggestions guys, but, still have the problem.
    I have been to mnt-system/boot/syslinux/syslinux.cfg file as superman suggested and the file there looks just like the one I posted earlier i.e.
    DEFAULT loadconfig

    LABEL loadconfig
    CONFIG /boot/isolinux/isolinux.cfg
    APPEND /boot/isolinux

    Anyhow I have added the line LANG=UK and have even tried LANG=EN
    but still no change.
    Funnily enough when I edit the syslinux.cfg file I get the = sign on the right key so it must be working ion that part of the system, howver when I go into Libre Office Writer the keyboard is the US layout.
    I was initially very impressed with Knoppix but I have to say that a choice of keyboards would seem to be the basic tweak and should be easier to implement.
    I have about 30 years of experience with computers and even I am struggling here, goodness knows what a complete tyro would make of it.
    I think I will wait and see if a new release fixes the problem.

  2. #12
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    You are using a wrong file! Either you or another person deleted the origin. The origin looks like this example (from 7.4.0 / german version):
    Code:
    # KNOPPIX 7.4 isolinux/syslinux boot config
    
    DEFAULT auto
    APPEND lang=de apm=power-off initrd=minirt.gz nomce libata.force=noncq hpsa.hpsa_allow_any=1 loglevel=1
    
    TIMEOUT 100
    KBDMAP german.kbd
    PROMPT 1
    F1 boot.msg
    F2 f2
    F3 f3
    DISPLAY boot.msg
    
    LABEL auto
    KERNEL ifcpu64.c32
    APPEND knoppix64 -- knoppix
    
    LABEL knoppix
    KERNEL linux
    APPEND lang=de apm=power-off initrd=minirt.gz nomce libata.force=noncq hpsa.hpsa_allow_any=1 loglevel=1
    
    LABEL adriane
    KERNEL linux
    APPEND lang=de apm=power-off video=640x480 initrd=minirt.gz nomce libata.force=noncq hpsa.hpsa_allow_any=1 loglevel=1 adriane
    
    LABEL knoppix64
    KERNEL linux64
    APPEND lang=de apm=power-off initrd=minirt.gz nomce libata.force=noncq hpsa.hpsa_allow_any=1 loglevel=1
    
    LABEL adriane64
    KERNEL linux64
    APPEND lang=de apm=power-off video=640x480 initrd=minirt.gz nomce libata.force=noncq hpsa.hpsa_allow_any=1 loglevel=1 adriane
    ...
    ...
    Last edited by Werner P. Schulz; 10-04-2015 at 05:19 PM.

  3. #13
    Junior Member
    Join Date
    Nov 2015
    Posts
    3

    Cool German keyboard not load in desktop with cheat code knoppix

    I'm facing similar problem. I installed Knoppix on USB stick. When I start with the Adriane menu keyboard is set to German. Also desktop keyboard is German when use the menu option or start from the shell via startx.
    If I use knoppix in the config file or as cheat code the desktop always has english keyboard. I tried with option lang=de but it doesn't work. I'm fine to use the start menu but I would like to disable the text to speech. Does anyone know the correct cheat? I don't want to use knoppix because that starts the desktop.

    Thanks Olaf

  4. #14
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    Have a look at http://knoppix.net/wiki/Cheat_Codes → ### Language/Country ###

  5. #15
    Junior Member
    Join Date
    Nov 2015
    Posts
    3
    Hi Werner, thanks for the reply. As I said I tried with the cheat code but the keyboard doesn't change to German when I use knoppix lang=de at the boot prompt or in the conf file. If I used the Adriane menu and start desktop with the menu item it is set to German. Same when I use startx from shell. I can change the layout with "setxkbmap de" via console. Seems to me that cheatcode for lang doesn't have any affect when started with knoppix option. Maybe I'm doing something wrong here? Thanks Olaf

  6. #16
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    Did you also use "knoppix keyboard=de xkeyboard=de"?

  7. #17
    Is is a great problem to you if you use what I wrote in my previous answer (number 10), changing to "de"?

  8. #18
    Junior Member
    Join Date
    Nov 2015
    Posts
    3
    Hi Werner I figured the problem is my external cordless keyboard. The keyboard of my laptop works but the external keyboard has US layout in the desktop. @joselb: Running "setxkbmap de" works and change the keyboard to German. I would like to automate as my kids will use the machine, too. Maybe you or Werner know how I can run it during startup of desktop? Thanks Olaf

  9. #19
    I don't know exactly why some computers don't work with the language in boot. I don't know how to fix it but maybe you can make that command to execute as a text file in your desktop, it could be easier.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •