Results 1 to 2 of 2

Thread: Formatting a SDXC Card for use with Knoppix.

  1. #1

    Formatting a SDXC Card for use with Knoppix.

    Not a knoppix-specific issue, but I recently bought a 64GB SDxC card and attempted to format as ext2. Using fdisk to create a blank partition table and parted to create an ext2 partition using the entire card seemed to work, but both mount and pmount fail to mount the new partition, and my android-powered portable media player doesn't recognize that an SD card has been inserted. As mount suggested, I ran dmesg | tail the output of which is below: [ 244.604081] XFS (sdb1): Invalid superblock magic number [ 244.616517] XFS (sdb1): Invalid superblock magic number [ 244.641057] omfs: Invalid superblock (0) [ 244.649926] omfs: Invalid superblock (0) [ 244.659674] ntfs: (device sdb1): read_ntfs_boot_sector(): Primary boot sector is invalid. [ 244.659694] ntfs: (device sdb1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover. [ 244.659708] ntfs: (device sdb1): ntfs_fill_super(): Not an NTFS volume. [ 244.668917] ntfs: (device sdb1): read_ntfs_boot_sector(): Primary boot sector is invalid. [ 244.668938] ntfs: (device sdb1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover. [ 244.668951] ntfs: (device sdb1): ntfs_fill_super(): Not an NTFS volume. And I have no idea what that means. Any suggestions on how to resolve this? If it matters, the card is a PNY-brand and is identified as a generic mass storage device by fdisk and parted.

  2. #2
    Still have no idea what went wrong before(never had any trouble using parted to format external harddrives), but after figuring out what command to use to make a new empty partition in fdisk, I was able to use mkfs.vfat to format the card and now it's working in both my laptop's SD slot and my PMP's SD slot. So, problem solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •