Results 1 to 8 of 8

Thread: 7.6 doesn't mount CDs

  1. #1
    Junior Member
    Join Date
    May 2010
    Posts
    13

    7.6 doesn't mount CDs

    Unlike all previous versions, 7.6 doesn't automatically mount CDs. I have to type "mount /media/sr0".

  2. #2
    Senior Member
    Join Date
    Dec 2012
    Posts
    129
    Did you try the options in:

    File Manager PCManFM > Edit > Preferences > Volume Management > Auto-mount

  3. #3
    Junior Member
    Join Date
    May 2010
    Posts
    13
    That doesn't help.

  4. #4
    Junior Member
    Join Date
    May 2010
    Posts
    13
    Ok, found the problem. You have to add kernel option:
    block.events_dfl_poll_msecs=1000

  5. #5
    Senior Member
    Join Date
    Dec 2012
    Posts
    129
    Looks like a strange command to me but if it works ...

  6. #6
    Administrator Site Admin-
    Join Date
    Apr 2003
    Location
    USA
    Posts
    5,441
    Looks to me like more Linux gibberish. Sure, Linux experts enjoy saying to noobs "you just have to add a kernel option". It certainly demonstrates their superiority and better understanding. But many average users have no idea exactly how you "add a kernel option". It isn't hard to understand why Linux is still marginalized on the desktop.
    ---
    Verifying of md5 checksum and burning a CD at slow speed are important.

  7. #7
    Junior Member
    Join Date
    May 2010
    Posts
    13
    At least it's an easy fix, just add it to syslinux.cfg (assuming your knoppix is on a USB stick).

  8. #8
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,629
    Quote Originally Posted by Luke M View Post
    Unlike all previous versions, 7.6 doesn't automatically mount CDs. I have to type "mount /media/sr0".

    My Knoppix 7.7.0 is a LiveUSB on a Dell Inspiron which has a r/w cd/dvd drive in it.
    This implies legacy boot and a remote possibility of systemd messing with things.

    I was surprised that cds were not always being recognized, along with other media.
    However, I finally noted that, for my set-up anyway, a cd physically in place
    in the cd drive reader during boot will be recognized, whereas a cd added after boot
    will not be recognized.

    So, one work-around for Knoppix 7.7.0 LiveUSB legacy boot users is simply just to
    re-boot with the cd in place. I would not be surprised that this problem and work-
    around might apply to earlier Knoppix LiveUSBs as well, but I haven't checked this out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •