Results 1 to 4 of 4

Thread: xbacklight and Knoppix 7.7.1

  1. #1
    Senior Member
    Join Date
    Dec 2012
    Posts
    129

    xbacklight and Knoppix 7.7.1

    ON the same computer, xbacklight was working well with Knoppix 7.4 and 7.6.

    It is not working for Knoppix 7.7.1. The command:

    Code:
    xbacklight -get
    returns:

    Code:
    No outputs have backlight property

  2. #2
    Senior Member
    Join Date
    Dec 2012
    Posts
    129
    As a followup, using the function keys for brightness (in my case: fn+Alt+F5 or F6) seems to be remembered. So, at least for me, there is a workaround.

  3. #3
    Senior Member
    Join Date
    Dec 2012
    Posts
    129
    The "No outputs have backlight property" error is apparently because xbacklight does not choose the right directory in /sys/class/backlight. Running:

    Code:
    ls /sys/class/backlight
    shows that directory is named intel_backlight.

    We should then be able to specify the directory by setting the Backlight option of the device in xorg.conf, configuring the section "Device" as follows:

    Code:
    /etc/X11/xorg.conf
    
    Section "Device"
        Identifier  "Card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
    EndSection
    Last edited by philo; 11-03-2016 at 08:20 PM.

  4. #4
    Senior Member
    Join Date
    Dec 2012
    Posts
    129
    Actually only these 2 lines need to be inserted:

    Code:
     
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    Should also have mentioned the link for the solution to that issue:

    https://wiki.archlinux.org/index.php...ght#xbacklight
    Last edited by philo; 11-13-2016 at 02:09 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •