Results 1 to 6 of 6

Thread: knoppix 7.7.1: No way to disable networking from the GUI icon ...

  1. #1
    Senior Member registered user
    Join Date
    Dec 2004
    Posts
    167

    knoppix 7.7.1: No way to disable networking from the GUI icon ...

    You must go:

    # ifconfig eth0 down

    Or actually physically disconnect the cable

    Why was this change made?

    The icon option is grayed out, unreachable using the keyboard or mouse

    lbrtchx
    Last edited by Albretch; 12-10-2016 at 08:47 AM.

  2. #2
    Senior Member registered user
    Join Date
    Dec 2004
    Posts
    167
    Also, I just noticed that even though you use ifconfig to disconnect yourself from the Internet, when you restart your session, 7.7.1 automatically connects to the Internet.

    Assuming that someone wants to be connected to the Internet, making knoppix automatically connect I find preposterous in these times in which the Internet is a vast surveillance miasm.

    Is the other only safe option left disconnecting the cable physically?

    lbrtchx

  3. #3
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    The icon option is grayed out, unreachable using the keyboard or mouse
    Now you can use left mouseclick → "Disconnect" below your existing connection.
    .. when you restart your session, 7.7.1 automatically connects to the Internet.
    Use "Edit connections.." from nm-applet → "Edit" your connection → "General" → disable "Automatically ..".

  4. #4
    Senior Member registered user
    Join Date
    Dec 2004
    Posts
    167
    $ which nm-applet
    /usr/bin/nm-applet


    $ nm-applet --version


    (nm-applet:12575): Gtk-WARNING **: GTK+ module libgail.so cannot be loaded.
    GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.


    $ nm-applet


    (nm-applet:12579): Gtk-WARNING **: GTK+ module libgail.so cannot be loaded.
    GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.


    $


    so, I could not run the nm-applet


    I think the "Automatically" option should be left disabled by default as it was before. I could also see other (probably most?) people may not think like me. They may also be the same ones who don't know/want to know how all computers are being routinely hacked into and mapped by the NSA ...


    lbrtchx

  5. #5
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    The nm-applet is already active → the icon on the right side of the panel.

  6. #6
    Senior Member registered user
    Join Date
    Dec 2004
    Posts
    167
    Yes. This is what I am talking about but I can't easily take a screenshot of it because ksnapshopt was taken off .

    You can't access (they look grayed out) the last two options of the icon on the right side of the panel which look like the plug to a CAT5 cable:

    Enable Networking
    Enable Wi-Fi

    The first one
    Enable Networking looks perpetually checked even if you physically unplug the cable

    lbrtchx

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •