Results 1 to 10 of 10

Thread: Mounting self-made cloop file - how?

Threaded View

  1. #1
    Member registered user
    Join Date
    Sep 2005
    Posts
    36

    Mounting self-made cloop file - how?

    I create a cloop file using the following commands:\n XXX\nYYY I

    root@Microknoppix:/media/sdc2# ddrescue /dev/sda1 /media/sdc2/sda1_2017-03-04.img ... root@Microknoppix:/media/sdc2# create_compressed_fs -L -1 sda1_2017-03-04.img /media/sdc2/sda1_2017-03-04.cloop ... root@Microknoppix:/media/sdc2# ls -l sda1_2017-03-04.* -rwxrwxrwx 1 knoppix knoppix 266178504 Mär 4 21:35 sda1_2017-03-04.cloop -rwxrwxrwx 1 knoppix knoppix 314572800 Mär 4 21:31 sda1_2017-03-04.img Looks OK. Now I can mount the uncompressed image: root@Microknoppix:/media/sdc2# mkdir /media/img-test /media/cloop-test root@Microknoppix:/media/sdc2# mount -r -o,loop -t ntfs /media/sdc2/sda1_2017-03-01.img /media/img-test/ root@Microknoppix:/media/sdc2# df | grep test /dev/loop0 307196 233384 73812 76% /media/img-test OK. Then I wanted to mount the cloop file... The file itself contains the following lines of script: #!/bin/sh #V2.0 Format modprobe cloop file=$0 && mount -r -t iso9660 /dev/cloop $1 exit $? So I tried: root@Microknoppix:/media/sdc2# modprobe -v cloop file=/media/sdc2/sda1_2017-03-04.cloop which outputs nothing. Did it work so far? No idea. Trying anyway: root@Microknoppix:/media/sdc2# mount -r -t ntfs /dev/cloop /media/cloop-test NTFS signature is missing. Failed to mount '/dev/cloop0': Das Argument ist ungültig The device '/dev/cloop0' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around? hmmm... root@Microknoppix:/media/sdc2# mount | grep cloop /dev/cloop0 on /KNOPPIX type iso9660 (ro,relatime) /dev/cloop1 on /KNOPPIX1 type iso9660 (ro,relatime) So /dev/cloop0 and /dev/cloop1 are in use (telling me that KNOPPIX itself managed to mount its files just fine. Trying /dev/cloop2 instead: root@Microknoppix:/media/sdc2# mount -r -t ntfs /dev/cloop2 /media/cloop-test Failed to read bootsector (size=0) Failed to mount '/dev/cloop2': Das Argument ist ungültig The device '/dev/cloop2' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around? This might suggest that the modprobe command silently failed. Trying the losetup method, mentioned in /usr/share/doc/cloop-utils/README: root@Microknoppix:/media/sdc2# losetup /dev/cloop3 /media/sdc2/sda1_2017-03-04.cloop losetup: /dev/cloop3: Loop-Gerät konnte nicht eingerichtet werden: Das Dateisystem ist nur lesbar (Translation: Loop device could not get created. The filesystem is readonly.) Hmmm... root@Microknoppix:/media/sdc2# ls -l /dev/cloop* lrwxrwxrwx 1 root root 6 Mär 4 20:38 /dev/cloop -> cloop0 brw-rw---- 1 root disk 240, 0 Mär 4 20:38 /dev/cloop0 brw-rw---- 1 root disk 240, 1 Mär 4 20:38 /dev/cloop1 brw-rw---- 1 root disk 240, 2 Mär 4 20:38 /dev/cloop2 brw-rw---- 1 root disk 240, 3 Mär 4 20:38 /dev/cloop3 brw-rw---- 1 root disk 240, 4 Mär 4 20:38 /dev/cloop4 brw-rw---- 1 root disk 240, 5 Mär 4 20:38 /dev/cloop5 brw-rw---- 1 root disk 240, 6 Mär 4 20:38 /dev/cloop6 brw-rw---- 1 root disk 240, 7 Mär 4 20:38 /dev/cloop7 root@Microknoppix:/media/sdc2# rm -f /dev/cloop6 root@Microknoppix:/media/sdc2# ll /dev/cloop* lrwxrwxrwx 1 root root 6 Mär 4 20:38 /dev/cloop -> cloop0 brw-rw---- 1 root disk 240, 0 Mär 4 20:38 /dev/cloop0 brw-rw---- 1 root disk 240, 1 Mär 4 20:38 /dev/cloop1 brw-rw---- 1 root disk 240, 2 Mär 4 20:38 /dev/cloop2 brw-rw---- 1 root disk 240, 3 Mär 4 20:38 /dev/cloop3 brw-rw---- 1 root disk 240, 4 Mär 4 20:38 /dev/cloop4 brw-rw---- 1 root disk 240, 5 Mär 4 20:38 /dev/cloop5 root@Microknoppix:/media/sdc2# losetup /dev/cloop6 /media/sdc2/sda1_2017-03-04.cloop losetup: /dev/cloop6: Loop-Gerät konnte nicht eingerichtet werden: Datei oder Verzeichnis nicht gefunden (Translation: Loop device could not get created. File or directory not found.) root@Microknoppix:/media/sdc2# losetup -f /dev/loop0 Why /dev/loop0, that one should be in use! How can I do this? What am I overlooking? It it impossible to do with a poor-man's-installation of Knoppix? Has anyone managed to do this using Knoppix 7.7.1? Please help!
    Last edited by DirkS; 03-04-2017 at 10:53 PM. Reason: Formatting is totally f'ed up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Seagate ST6000NM0044 6TB 128MB Cache 7200RPM SATA 6Gb/s 3.5

Seagate ST6000NM0044 6TB 128MB Cache 7200RPM SATA 6Gb/s 3.5" Internal Hard Drive

$69.99



WD My Passport 2TB Certified Refurbished Portable Hard Drive Red picture

WD My Passport 2TB Certified Refurbished Portable Hard Drive Red

$34.99



ST16000NM001G Seagate Exos 16TB X16 512e 6Gb 3.5 SATA Enterprise Hard Drive New picture

ST16000NM001G Seagate Exos 16TB X16 512e 6Gb 3.5 SATA Enterprise Hard Drive New

$198.36



1TB HDD/SSD 2.5

1TB HDD/SSD 2.5" SATA Hard Drive Laptop with Windows 10 Pro / Home Legacy 64

$67.59



WL 4TB 64MB Cache 7200RPM (Enterprise Grade) SATA 6Gb/s 3.5

WL 4TB 64MB Cache 7200RPM (Enterprise Grade) SATA 6Gb/s 3.5" Internal Hard Drive

$48.88



500 GB SATA 3.5

500 GB SATA 3.5" Desktop Hard Drives MIXED BRANDS Tested (6A4)

$10.25



USED 500GB Laptop Hard Drive HDD WIPED - TESTED AND WORKING - VARIOUS BRANDS picture

USED 500GB Laptop Hard Drive HDD WIPED - TESTED AND WORKING - VARIOUS BRANDS

$8.44



Seagate NAS HDD ST4000VN000 4TB 3.5

Seagate NAS HDD ST4000VN000 4TB 3.5" 5.9K SATA 6Gbps 64MB (512e) Hard Drive HDD

$40.00



HUH721010AL4200/42C0 HGST Ultrastar He10 10TB 7200RPM SAS 12Gbps 256MB 2018 picture

HUH721010AL4200/42C0 HGST Ultrastar He10 10TB 7200RPM SAS 12Gbps 256MB 2018

$99.95



WD Elements 1TB Certified Refurbished Portable Hard Drive Black picture

WD Elements 1TB Certified Refurbished Portable Hard Drive Black

$24.99