I replaced my original graphic card (ASUS EAH3850 512 MB DDR3) with a new (ASUS TURBO GTX1060 6GB) in my desktop.
Probably, this HW replacement caused my problem.

Start of Knoppix looks correctly. There are no errors / warnings in console.
But, after starting a graphical interface, there is a black screen, and monitor shows only a message:
"The current input timing is not supported by monitor display. Please change your input timing to 1920x1200@60Hz".

Probably the resolution or the frequency are outside from monitor range. Or there is a bad/incompatible driver for my graphic card.

So I tried to test a new version of Knoppix (version 7.7.1), - Booting from USB, but there is a same problem.
I tested "CTRL"+"DEL"+"-" , but without responds.

Also, I tried F2 and starts the knoppix with several parameters many times (always with a same negative result).

Fox example, I tested these parameters:

knoppix screen=1280x1024
knoppix64 norandr
knoppix64 xmodule=nv screen=1280x1024
knoppix xserver=XFree86 xmodule=vesa
knoppix screen=1280x1024 vsync=60 xmodule=svga
knoppix screen=1280x1024 vsync=60 hsync=60
knoppix screen=1920x1200 vsync=60 hsync=60

I am using a desktop pc with this hardware:
Processor AMD FX-8300, MotherBoard ASUS M5A97 LE R2.0, 16 GB RAM
!! Graphic Card ASUS TURBO GTX1060 6GB
!! monitor DELL U2412M (maximal res. 1920x1200 @ 60 Hz)

I will happy for any suggestions, because this is frustrating for me (I haven't got my original Graphic card yet).
Or, maybe some update of driver package in new version of Knoppix could helps.
Thank you.