Results 1 to 6 of 6

Thread: Firefox and pulseaudio

  1. #1
    Senior Member
    Join Date
    Dec 2012
    Posts
    144

    Firefox and pulseaudio

    Still running Knoppix 7.7.1 but wanted to test that so-called 'bug' of FF.

    I reloaded Synaptic, installed pulseaudio, pluseaudio-utils 10.0.-1 and pavucontrol 3.0.3-1. then upgraded Firefox to version 56.0-2 (not a recommended action).

    The entry made by pulseaudio in /etc/xdg/lxsession/LXDE/autostart does not seem to be enough for pulseaudio to start roperly.

    Adding the line:

    Code:
    @pulseaudio -D
    in /home/knoppix/.config/lxsession/LXDE/autostart

    fixed the playback sound problem.

  2. #2
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Many thanks, philo.
    This also works with Knoppix 8.1 and its FF 55,
    using the similar ingredients of 8.1 and its current synaptic contents.

  3. #3
    Junior Member registered user
    Join Date
    Dec 2002
    Location
    Germany
    Posts
    22
    Hello philio,

    Thanks for explaining how to start pulseaudio as a daemon in the startup files (starting it in /etc/rc.local would have been possible as well). I am well aware of this. Sorry I wasn't verbose enough in my statement about "installing pulseaudio not being a solution". I'm trying to be more elaborate now.

    The pulseaudio system consists of a client part, which can be configured to work with ALSA directly, or sending sound (with some latency) to a local or remote damon. Most programs linked with the pulseaudio client library are well capable to still work with local ALSA output.

    This is not the case for Firefox. Firefox insists to ONLY sending sound to a running pulseaudio daemon. This is, in my understanding of the statements of Mozillas developers, a part of the security concept of sandboxes avoiding to open local files (like the standard audio device through the client libraries). Instead of playing sound directly to the sound device, they insist on opening ONLY sockets (which means, a pulseaudio daemon has to be run that redirects sound to, well, in most cases the local ALSA devices again, so it's really not making sense in my opinion, not even as a security concept... Uhm...).

    Again, Firefox is the only program in Knoppix - to my knowledge - that insists on the pulseaudio daemon running for being able to play sound

    I do NOT want to start pulseaudio as a daemon by default on Knoppix for a reason. The pulseaudio daemon is known, and I have experienced this many times by myself, to block the ALSA devices. This means that other programs trying to access the soundcard, are locking up indefinitely until the pulseaudio daemon "decides" it's time to release the sound device to other programs. Which may or may not happen, depending on the application.

    In terms of accessibility, where a blind person needs to have IMMEDIATE sound feedback with NO LATENCY, this is an absolute no-go. Losing speech output and audio feedback with no means of graphical access to the desktop, cuts off access to your OS until reboot, just because ONE daemon/program blocks the audio device.

    Redirecting the screenreader to the pulseaudio daemon, does not help, since pulseaudio will still lock up the screenreader as soon as another program (or website in Firefox) demands the same "exclusive" priority for accessing sound, and does not voluntarily release the device.

    So, Mozilla decided to only support pulseaudio DAEMON sound support. I decided - long before - to NOT start the pulseaudio daemon in Knoppix by default, because of the problems that I personally experienced with it. So count it as a bug on my (Knoppix) side instead of a "Firefox bug" (which I basically did in the release notes, it's a "Knoppix bug" to not support Firefox'es "new way of supporting sound via pulseaudio daemon only").

    I hope this clarifies the situation a bit. It's really just me (and some other distros as well) - who prefers rather cooperative non-pulseaudio-daemon sound working in virtually every program except Firefox, than risking to lose sound in critical situations like accessibility functions because of firefox demanding the PA daemon.Your workaround is always possible, but I won't implement it as default, just because I'm an overcautious person.

    With kind regards
    -Klaus Knopper

    Quote Originally Posted by philo View Post
    Still running Knoppix 7.7.1 but wanted to test that so-called 'bug' of FF.

    I reloaded Synaptic, installed pulseaudio, pluseaudio-utils 10.0.-1 and pavucontrol 3.0.3-1. then upgraded Firefox to version 56.0-2 (not a recommended action).

    The entry made by pulseaudio in /etc/xdg/lxsession/LXDE/autostart does not seem to be enough for pulseaudio to start roperly.

    Adding the line:

    Code:
    @pulseaudio -D
    in /home/knoppix/.config/lxsession/LXDE/autostart

    fixed the playback sound problem.

  4. #4
    Senior Member registered user
    Join Date
    May 2006
    Location
    Columbia, Maryland USA
    Posts
    1,631
    Thanks to both Klaus K and philo.

    I'm pleased that Klaus K has taken the time to inform us about his rationale
    in Knoppix 8.1 to work around a new feature of Firefoxes 55 and beyond which
    would interfere with Adriane and other client users of ALSA in Knoppix.

    philo's work-around may not suffice to meet Klaus K's design requirements,
    but for my own undemanding needs of a Knoppix browser with sound, Chromium
    is a clumsy alternative inconvenience to Firefox 55. To my knowledge, there
    are no uses of ALSA other than Adriane that I might likely employ.

    I plan to continue using the philo work-around while I try to understand the
    new LiveUSB remastering feature.

  5. #5
    Senior Member
    Join Date
    Dec 2012
    Posts
    144
    It is then a feature, not a bug, in both Knoppix and Firefox.

    A feature does not need a "workaround", like the Release Notes for version 8.1 suggest. Chrome is just an alternative browser for Adriane users and all those who refuse or ditsrust pulseaudio. Firefox ESR would probably also do, at least for some time.

  6. #6
    Senior Member
    Join Date
    Dec 2012
    Posts
    144
    The Release Notes should clearly say that this a default setting for pluseaudio in Knoppix and suggest the various methods to change that setting. Not using the new Firefox is only one such method.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •