Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Knoppix 8.1 USB-stick installation

  1. #21
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157
    There is a ntp.conf file in /etc but I'm not knowledgeable enough to know how to configure that file to my needs.

    # /etc/ntp.conf,configuration for ntpd; see ntp.conf(5) for help


    driftfile/var/lib/ntp/ntp.drift


    # Enable this if youwant statistics to be logged.
    #statsdir/var/log/ntpstats/statistics loopstats peerstats clockstats
    filegen loopstatsfile loopstats type day enable
    filegen peerstatsfile peerstats type day enable
    filegen clockstatsfile clockstats type day enable


    # You do need totalk to an NTP server or two (or three).
    #serverntp.your-provider.example
    # pool.ntp.org mapsto about 1000 low-stratum NTP servers. Your server will
    # pick a differentset every time it starts up. Please consider joining the
    # pool:<http://www.pool.ntp.org/join.html>
    pool0.debian.pool.ntp.org iburst
    pool1.debian.pool.ntp.org iburst
    pool2.debian.pool.ntp.org iburst
    pool3.debian.pool.ntp.org iburst


    # Access controlconfiguration; see /usr/share/doc/ntp-doc/html/accopt.html for
    # details. The webpage <http://support.ntp.org/bin/view/Support/AccessRestrictions>
    # might also behelpful.
    # Note that"restrict" applies to both servers and clients, so aconfiguration
    # that might beintended to block requests from certain clients could also end
    # up blockingreplies from your own upstream servers.
    # By default,exchange time with everybody, but don't allow configuration.
    restrict -4 defaultkod notrap nomodify nopeer noquery limited
    restrict -6 defaultkod notrap nomodify nopeer noquery limited


    # Local users mayinterrogate the ntp server more closely.
    restrict 127.0.0.1
    restrict ::1


    # Needed for addingpool entries
    restrict sourcenotrap nomodify noquery


    # Clients from this(example!) subnet have unlimited access, but only if
    # cryptographicallyauthenticated.
    #restrict192.168.123.0 mask 255.255.255.0 notrust
    # If you want toprovide time to your local subnet, change the next line.
    # (Again, theaddress is an example only.)
    #broadcast192.168.123.255
    # If you want tolisten to time broadcasts on your local subnet, de-comment the
    # next lines. Please do this only if you trust everybody on the network!
    #disable auth
    #broadcastclient

  2. #22
    Senior Member
    Join Date
    Dec 2012
    Posts
    144
    'Google is your friend', e.g. :

    https://wiki.debian.org/NTP
    https://wiki.debian.org/DateTime
    https://linuxconfig.org/how-to-setup...-stretch-linux

    et alii.

    The ntpdate package is not necessary if you have ntp.
    Last edited by philo; 10-15-2017 at 09:45 AM.

  3. #23
    Senior Member
    Join Date
    Dec 2012
    Posts
    144
    No doubt you read in:
    http://knoppix.net/wiki/Cheat_Codes#Micro-Remastering

    .....
    To change other boot options, look within the file 'syslinux.cfg' for the LABEL line of the way you always start with Knoppix. If you for example always use "knoppix" (and not "knoppix64") then look for "LABEL knoppix". Don't change the following KERNEL line but insert additional or change existent cheatcodes within the APPEND line.
    LABEL knoppix
    KERNEL linux
    APPEND ramdisk_size=100000 lang=en keyboard=es xkeyboard=es apm=power-off ...

    Note: If you are using Knoppix 64 bit, you have also to change the settings within '/mnt-system/boot/syslinux/syslnx32.cfg' and '/mnt-system/boot/syslinux/syslnx64.cfg'

  4. #24
    Senior Member
    Join Date
    Dec 2012
    Posts
    144
    Your /etc/ntp.conf file is the same as mine. Your problem must be elsewhere.

  5. #25
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157
    I guess my problem is the Date and Time entered in the BIOS.
    Right now it seems to be + 7 hours Pacific Standard Time and
    I'm not able to change Date and Time in BIOS, still working on it.

  6. #26

  7. #27
    Member registered user
    Join Date
    Dec 2006
    Posts
    38
    To start the ntp service at boot you must edit /etc/rc.local and replace SERVICES="cups" with SERVICES="cups ntp"

  8. #28
    Senior Member Karibu's Avatar
    Join Date
    Feb 2012
    Location
    Kelowna, BC Canada
    Posts
    157
    Time issue is solved finally. What I had to do in my case:

    1) As philo recommended earlier:
    Check
    1) BIOS time (hardware clock) --> UTC
    2) /etc/adjtime --> UTC [instaead of LOCAL]
    3) /etc/timezone ---> America/Vancouver

    4) and maybe in :
    /media/sd__/boot/syslinux/syslinux.cfg
    LABEL knoppix,
    LABEL knoppix64
    add inside APPEND: --> tz=America/Vancouver
    The path for syslinux.cfg is '/mnt-system/boot/syslinux'.

    I also changed - as philo recommended -
    '/mnt-system/boot/syslinux/syslnx32.cfg' and
    '/mnt-system/boot/syslinux/syslnx64.cfg'
    and added inside APPEND: --> tz=America/Vancouver

    Thanks for the help!

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •