I Installed Knoppix 8.1 on Hard drive.
There is an issue with the Time setting.

Here is what I found out so far:

a) The BIOS of my MSI motherboard is set to universal time UTC.

b) In /etc/adjtime I find
'0.000000 1177000000 0.000000

c) After setting my time zone via ---> Preferences ---> Date and Time to 'America/Vancouver
I checked /etc/timezone and found the right entry - America/Vancouver - and the right time appears in the panel.

After each restart/reboot of the computer, /etc/timezone is overwritten with 'localtime'
and I have to set the timezone new as I did before.

What can I do to have the /etc/timezone entry permanent?