Results 1 to 2 of 2

Thread: How do I make my Seagate 2Tb usb hdd work in Knoppix?

  1. #1

    How do I make my Seagate 2Tb usb hdd work in Knoppix?

    Summary:

    I've just bought a Seagate 2Tb "expansion portable drive", model STEA2000400,
    with USB 3 connection, formatted as ntfs. The documentation says "System
    requirements: Windows 7 or 8" but I assume it should work with Linux/Knoppix (I really
    like the neat design of the drive).

    My system is Live Knoppix 7.0.2 installed on hard drive, with kernel 3.3.7.

    So far, the Seagate drive has only worked once, when I first plugged it in* (usb
    3 slot). (*After boot). It automounted, and its files were displayed in the
    pcmanfm file manager. By automount, I mean when the small window appears and
    says something like "Do you want to open this device in file manager".

    But since then, each time I plug it in, it doesn't work (it works OK in Windows
    7). When I plug it in, sometimes it gets mounted by the system (even if the
    automount dialogue doesn't appear), and sometimes it doesn't get mounted.

    When it's not mounted, the dmesg command says

    Code:
    [ 9134.211695] sd 8:0:0:0: sense urb submission failure
    and the message repeats continuously (with different "[...]" nos.) and repeats
    across subsequent dmesgs and across logging out and in.

    When I plug the drive in BEFORE booting, the system mounts the drive, and dmesg
    gives the following message continuously (it gave the same continuous message
    when I repeated the dmesg command):

    Code:
    [ 105.827668] sd 8:0:0:0: rejecting I/O to offline device
    My humble questions are:

    Could you tell me why the drive isn't working in Knoppix, and what I need to do
    to get it working? I really like the neat design of the drive and would very
    much like to keep it and get it working.

    Should I look for another usb hdd that specifically says it works with Linux?


    Full Details:

    When the drive worked that first time, and its files were displayed in pcmanfm,
    the mount command showed

    Code:
    /dev/sdb1 on /media/sdb1 type fuseblk (rw,nosuid,nodev,relatime,user_id=
    1000,group_id=0,allow_other,blksize=4096)
    AND dmesg showed

    Code:
    [ 3104.772532] usb 4-2: new SuperSpeed USB device number 2 using xhci_hcd
    [ 3104.789326] usb 4-2: New USB device found, idVendor=0bc2, idProduct=231a
    [ 3104.789336] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 3104.789342] usb 4-2: Product: Expansion
    [ 3104.789347] usb 4-2: Manufacturer: Seagate
    [ 3104.789351] usb 4-2: SerialNumber: NA8PEPNV
    [ 3104.791381] scsi8 : uas
    [ 3104.793020] scsi 8:0:0:0: Direct-Access     Seagate  Expansion        0708
    PQ: 0 ANSI: 6
    [ 3104.793363] sd 8:0:0:0: Attached scsi generic sg2 type 0
    Also when the drive worked that first time, and its files were displayed
    in pcmnfm; about 15 minutes later, when I reselected the drive in pcmanfm, no
    files were displayed, and pcmanfm said

    "The specified directory is not valid".

    I then opened the nautilus file manager, and when I selected the drive, nautilus
    said

    "Could not display /media/sdb1. Error: Error when getting information for file
    /media/sdb1: Input/output error. Please select another viewer and try again."

    On the occasion when I plugged the drive in BEFORE booting, and the system
    mounted it, I can't remember if the automount dialogue appeared or not.

  2. #2
    Senior Member
    Join Date
    Jan 2012
    Posts
    110
    Hi winger9

    Perhapstoo late for you ?

    Suggestions of a very newbie:

    1- Verify your "bios" to authorize "automatic hdd

    recognition"

    2- Perhaps your "2To_HDD" is too big (depending

    on the version of the processor)

    3- In that case you may split he HDD in 2 (or more)

    partitions.

    4- In my case it was (and is yet!) a "processor problem"

    for a "1To_HDD" (but ONLY FOR BOOTING the PC!

    Hope for you !

    knp
    Last edited by knp; 10-10-2018 at 07:16 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Grandstream GS-HT802 2 Port Analog Telephone Adapter VoIP Phone & Device, Black picture

Grandstream GS-HT802 2 Port Analog Telephone Adapter VoIP Phone & Device, Black

$32.00



MagicJack - HOME VoIP Telephone Adapter 12 Months of Service - Black New Sealed picture

MagicJack - HOME VoIP Telephone Adapter 12 Months of Service - Black New Sealed

$39.99



Grandstream GS-GXP2135 8 Lines 4 SIP Counts Bluetooth Enterprise IP VoIP Phone picture

Grandstream GS-GXP2135 8 Lines 4 SIP Counts Bluetooth Enterprise IP VoIP Phone

$30.71



Cisco CP-8841 VoIP Phone - Black picture

Cisco CP-8841 VoIP Phone - Black

$20.00



Cisco/Linksys SPA2102 VoIP Phone Adapter Router 2FXS (Unlocked) picture

Cisco/Linksys SPA2102 VoIP Phone Adapter Router 2FXS (Unlocked)

$16.99



Cisco CP-7945G VOIP Phone With Stand & Handset Business IP Phone 7945 picture

Cisco CP-7945G VOIP Phone With Stand & Handset Business IP Phone 7945

$3.00



Unlocked Cisco / Linksys SPA2102 VoIP 2FXS Phone Adapter with Router picture

Unlocked Cisco / Linksys SPA2102 VoIP 2FXS Phone Adapter with Router

$17.99



New Cisco 7945G IP VoIP Gigabit GIGE Telephone Phone CP-7945G -  picture

New Cisco 7945G IP VoIP Gigabit GIGE Telephone Phone CP-7945G -

$24.95



REF A-STOCK - Polycom 2200-48450-025 VVX 411 IP VOIP POE Gigabit Telephone picture

REF A-STOCK - Polycom 2200-48450-025 VVX 411 IP VOIP POE Gigabit Telephone

$38.68



UBIQUITI UVP Executive Unifi VoIP Phone - 7

UBIQUITI UVP Executive Unifi VoIP Phone - 7" HD touchscreen #003

$120.00