Results 1 to 2 of 2

Thread: How do I make my Seagate 2Tb usb hdd work in Knoppix?

  1. #1

    How do I make my Seagate 2Tb usb hdd work in Knoppix?

    Summary:

    I've just bought a Seagate 2Tb "expansion portable drive", model STEA2000400,
    with USB 3 connection, formatted as ntfs. The documentation says "System
    requirements: Windows 7 or 8" but I assume it should work with Linux/Knoppix (I really
    like the neat design of the drive).

    My system is Live Knoppix 7.0.2 installed on hard drive, with kernel 3.3.7.

    So far, the Seagate drive has only worked once, when I first plugged it in* (usb
    3 slot). (*After boot). It automounted, and its files were displayed in the
    pcmanfm file manager. By automount, I mean when the small window appears and
    says something like "Do you want to open this device in file manager".

    But since then, each time I plug it in, it doesn't work (it works OK in Windows
    7). When I plug it in, sometimes it gets mounted by the system (even if the
    automount dialogue doesn't appear), and sometimes it doesn't get mounted.

    When it's not mounted, the dmesg command says

    Code:
    [ 9134.211695] sd 8:0:0:0: sense urb submission failure
    and the message repeats continuously (with different "[...]" nos.) and repeats
    across subsequent dmesgs and across logging out and in.

    When I plug the drive in BEFORE booting, the system mounts the drive, and dmesg
    gives the following message continuously (it gave the same continuous message
    when I repeated the dmesg command):

    Code:
    [ 105.827668] sd 8:0:0:0: rejecting I/O to offline device
    My humble questions are:

    Could you tell me why the drive isn't working in Knoppix, and what I need to do
    to get it working? I really like the neat design of the drive and would very
    much like to keep it and get it working.

    Should I look for another usb hdd that specifically says it works with Linux?


    Full Details:

    When the drive worked that first time, and its files were displayed in pcmanfm,
    the mount command showed

    Code:
    /dev/sdb1 on /media/sdb1 type fuseblk (rw,nosuid,nodev,relatime,user_id=
    1000,group_id=0,allow_other,blksize=4096)
    AND dmesg showed

    Code:
    [ 3104.772532] usb 4-2: new SuperSpeed USB device number 2 using xhci_hcd
    [ 3104.789326] usb 4-2: New USB device found, idVendor=0bc2, idProduct=231a
    [ 3104.789336] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 3104.789342] usb 4-2: Product: Expansion
    [ 3104.789347] usb 4-2: Manufacturer: Seagate
    [ 3104.789351] usb 4-2: SerialNumber: NA8PEPNV
    [ 3104.791381] scsi8 : uas
    [ 3104.793020] scsi 8:0:0:0: Direct-Access     Seagate  Expansion        0708
    PQ: 0 ANSI: 6
    [ 3104.793363] sd 8:0:0:0: Attached scsi generic sg2 type 0
    Also when the drive worked that first time, and its files were displayed
    in pcmnfm; about 15 minutes later, when I reselected the drive in pcmanfm, no
    files were displayed, and pcmanfm said

    "The specified directory is not valid".

    I then opened the nautilus file manager, and when I selected the drive, nautilus
    said

    "Could not display /media/sdb1. Error: Error when getting information for file
    /media/sdb1: Input/output error. Please select another viewer and try again."

    On the occasion when I plugged the drive in BEFORE booting, and the system
    mounted it, I can't remember if the automount dialogue appeared or not.

  2. #2
    Senior Member
    Join Date
    Jan 2012
    Posts
    110
    Hi winger9

    Perhapstoo late for you ?

    Suggestions of a very newbie:

    1- Verify your "bios" to authorize "automatic hdd

    recognition"

    2- Perhaps your "2To_HDD" is too big (depending

    on the version of the processor)

    3- In that case you may split he HDD in 2 (or more)

    partitions.

    4- In my case it was (and is yet!) a "processor problem"

    for a "1To_HDD" (but ONLY FOR BOOTING the PC!

    Hope for you !

    knp
    Last edited by knp; 10-10-2018 at 07:16 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


ATTO R608 8-Port 6Gb/s SAS RAID Controller picture

ATTO R608 8-Port 6Gb/s SAS RAID Controller

$33.99



Dell UCSA-901 0101A6100-000-G SAS PCI-E Raid Controller Card picture

Dell UCSA-901 0101A6100-000-G SAS PCI-E Raid Controller Card

$37.50



LSI 9305-16i SATA SAS 12Gbs RAID Controller PCIe 3.0 x8 IT-Mode 4* 8643 SATA picture

LSI 9305-16i SATA SAS 12Gbs RAID Controller PCIe 3.0 x8 IT-Mode 4* 8643 SATA

$229.99



Dell  PowerEdge R730 12Gb/s SAS Mini Mono RAID Controller 2GB Cache 07H4CN 7H4CN picture

Dell PowerEdge R730 12Gb/s SAS Mini Mono RAID Controller 2GB Cache 07H4CN 7H4CN

$49.99



Inspur LSI 9300-8i Raid Card 12Gbps HBA HDD Controller High Profile IT MODE picture

Inspur LSI 9300-8i Raid Card 12Gbps HBA HDD Controller High Profile IT MODE

$15.98



LSI MegaRAID 9361-8i 12Gb PCIe 8-Port SAS/SATA RAID 1Gb w/BBU/CacheVault/License picture

LSI MegaRAID 9361-8i 12Gb PCIe 8-Port SAS/SATA RAID 1Gb w/BBU/CacheVault/License

$39.95



Dell PowerEdge RAID Controller HBA330 12Gbs PCIe 3.0 SAS SATA J7TNV Low Profile picture

Dell PowerEdge RAID Controller HBA330 12Gbs PCIe 3.0 SAS SATA J7TNV Low Profile

$29.00



ORICO Multi Bay RAID Hard Drive Enclosure USB 3.0/ Type-C For 2.5/3.5'' HDD SSDs picture

ORICO Multi Bay RAID Hard Drive Enclosure USB 3.0/ Type-C For 2.5/3.5'' HDD SSDs

$87.99



4 Bay RAID External Hard Drive Enclosure for 2.5/3.5

4 Bay RAID External Hard Drive Enclosure for 2.5/3.5" SATA HDD/SSD

$79.99



G TECHNOLOGY G RAID 0G04228 2-Bay Thunderbolt 2 RAID Array W/Power Supply picture

G TECHNOLOGY G RAID 0G04228 2-Bay Thunderbolt 2 RAID Array W/Power Supply

$99.99