Results 1 to 2 of 2

Thread: How do I make my Seagate 2Tb usb hdd work in Knoppix?

  1. #1

    How do I make my Seagate 2Tb usb hdd work in Knoppix?

    Summary:

    I've just bought a Seagate 2Tb "expansion portable drive", model STEA2000400,
    with USB 3 connection, formatted as ntfs. The documentation says "System
    requirements: Windows 7 or 8" but I assume it should work with Linux/Knoppix (I really
    like the neat design of the drive).

    My system is Live Knoppix 7.0.2 installed on hard drive, with kernel 3.3.7.

    So far, the Seagate drive has only worked once, when I first plugged it in* (usb
    3 slot). (*After boot). It automounted, and its files were displayed in the
    pcmanfm file manager. By automount, I mean when the small window appears and
    says something like "Do you want to open this device in file manager".

    But since then, each time I plug it in, it doesn't work (it works OK in Windows
    7). When I plug it in, sometimes it gets mounted by the system (even if the
    automount dialogue doesn't appear), and sometimes it doesn't get mounted.

    When it's not mounted, the dmesg command says

    Code:
    [ 9134.211695] sd 8:0:0:0: sense urb submission failure
    and the message repeats continuously (with different "[...]" nos.) and repeats
    across subsequent dmesgs and across logging out and in.

    When I plug the drive in BEFORE booting, the system mounts the drive, and dmesg
    gives the following message continuously (it gave the same continuous message
    when I repeated the dmesg command):

    Code:
    [ 105.827668] sd 8:0:0:0: rejecting I/O to offline device
    My humble questions are:

    Could you tell me why the drive isn't working in Knoppix, and what I need to do
    to get it working? I really like the neat design of the drive and would very
    much like to keep it and get it working.

    Should I look for another usb hdd that specifically says it works with Linux?


    Full Details:

    When the drive worked that first time, and its files were displayed in pcmanfm,
    the mount command showed

    Code:
    /dev/sdb1 on /media/sdb1 type fuseblk (rw,nosuid,nodev,relatime,user_id=
    1000,group_id=0,allow_other,blksize=4096)
    AND dmesg showed

    Code:
    [ 3104.772532] usb 4-2: new SuperSpeed USB device number 2 using xhci_hcd
    [ 3104.789326] usb 4-2: New USB device found, idVendor=0bc2, idProduct=231a
    [ 3104.789336] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 3104.789342] usb 4-2: Product: Expansion
    [ 3104.789347] usb 4-2: Manufacturer: Seagate
    [ 3104.789351] usb 4-2: SerialNumber: NA8PEPNV
    [ 3104.791381] scsi8 : uas
    [ 3104.793020] scsi 8:0:0:0: Direct-Access     Seagate  Expansion        0708
    PQ: 0 ANSI: 6
    [ 3104.793363] sd 8:0:0:0: Attached scsi generic sg2 type 0
    Also when the drive worked that first time, and its files were displayed
    in pcmnfm; about 15 minutes later, when I reselected the drive in pcmanfm, no
    files were displayed, and pcmanfm said

    "The specified directory is not valid".

    I then opened the nautilus file manager, and when I selected the drive, nautilus
    said

    "Could not display /media/sdb1. Error: Error when getting information for file
    /media/sdb1: Input/output error. Please select another viewer and try again."

    On the occasion when I plugged the drive in BEFORE booting, and the system
    mounted it, I can't remember if the automount dialogue appeared or not.

  2. #2
    Senior Member
    Join Date
    Jan 2012
    Posts
    107
    Hi winger9

    Perhapstoo late for you ?

    Suggestions of a very newbie:

    1- Verify your "bios" to authorize "automatic hdd

    recognition"

    2- Perhaps your "2To_HDD" is too big (depending

    on the version of the processor)

    3- In that case you may split he HDD in 2 (or more)

    partitions.

    4- In my case it was (and is yet!) a "processor problem"

    for a "1To_HDD" (but ONLY FOR BOOTING the PC!

    Hope for you !

    knp
    Last edited by knp; 10-10-2018 at 07:16 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Tenda SG105 5-Port 10/100/1000Mbps Gigabit Desktop Switch Ethernet Splitter Hub picture

Tenda SG105 5-Port 10/100/1000Mbps Gigabit Desktop Switch Ethernet Splitter Hub

$13.99



Tenda 8/5 Port Gigabit Ethernet Splitter Network Switch SG108 / SG105 Unmanaged picture

Tenda 8/5 Port Gigabit Ethernet Splitter Network Switch SG108 / SG105 Unmanaged

$13.99



Tenda SG108 Network Gigabit Switch 8 Port 10/100/1000Mbps Wired Ethernet Lan Hub picture

Tenda SG108 Network Gigabit Switch 8 Port 10/100/1000Mbps Wired Ethernet Lan Hub

$19.99



Cisco Catalyst WS-C2960-24TC-S 24-Port Managed Ethernet Switch picture

Cisco Catalyst WS-C2960-24TC-S 24-Port Managed Ethernet Switch

$15.00



TP-Link 5 Port Gigabit Ethernet Network Switch TL-SG1005D Brand New unopened picture

TP-Link 5 Port Gigabit Ethernet Network Switch TL-SG1005D Brand New unopened

$12.99



Cisco SG100-16 Gigabit Ethernet 16-Port Unmanaged Network Switch picture

Cisco SG100-16 Gigabit Ethernet 16-Port Unmanaged Network Switch

$39.99



NETGEAR 8-Port Gigabit Ethernet Unmanaged Switch (GS308) Home/Office Network Hub picture

NETGEAR 8-Port Gigabit Ethernet Unmanaged Switch (GS308) Home/Office Network Hub

$27.99



New 10/100 Mbps 8 Ports Fast Ethernet LAN Desktop RJ45 Network Switch Hub picture

New 10/100 Mbps 8 Ports Fast Ethernet LAN Desktop RJ45 Network Switch Hub

$10.99



Cisco WS-C3560-24PS-S Catalyst 24-Port 10/100 Fast Ethernet Network Switch picture

Cisco WS-C3560-24PS-S Catalyst 24-Port 10/100 Fast Ethernet Network Switch

$32.99



8 Port PoE Switch With 2 Uplink 120W Extend to 250Meter Unmanaged 803.af/at picture

8 Port PoE Switch With 2 Uplink 120W Extend to 250Meter Unmanaged 803.af/at

$39.99