Results 1 to 5 of 5

Thread: How do you Install OpenCL Runtime for Intel Core and Intel Xeon Processors

  1. #1
    Junior Member
    Join Date
    Jan 2013
    Posts
    14

    Question How do you Install OpenCL Runtime for Intel Core and Intel Xeon Processors

    Hello guys

    (Knoppix 8.1 with 20 Gig persistence -- Running in 64 bit)

    I installed "Hashcat" normally, & saw nothing out of the ordinary while installing, until I tried to run HashCat, & got a message in response saying:

    Code:
    root@Microknoppix:/home/knoppix# hashcat -a 3  -D 1 -m 2500 /hashcat-4.1.0/HASH.hccapx ?a?a?a?a?a?a?a?a
    hashcat (v4.1.0) starting...
    
    Cannot find an OpenCL ICD loader library.
    
    You are probably missing the native OpenCL runtime or driver for your platform.
    
    * AMD GPUs on Linux require this runtime and/or driver:
      "RadeonOpenCompute (ROCm)" Software Platform (1.6.180 or later)
    * Intel CPUs require this runtime and/or driver:
      "OpenCL Runtime for Intel Core and Intel Xeon Processors" (16.1.1 or later)
    * Intel GPUs on Linux require this runtime and/or driver:
      "OpenCL 2.0 GPU Driver Package for Linux" (2.0 or later)
    * NVIDIA GPUs require this runtime and/or driver:
      "NVIDIA Driver" (367.x or later)
    
    Started: Wed May 23 15:36:54 2018
    Stopped: Wed May 23 15:36:54 2018
    root@Microknoppix:/home/knoppix# 
    I have an old AMD Radeon HD 6450 graphics card installed, & also an Intel Core 2 Duo CPU.
    I'm not sure how to go about installing the Drivers to activate OpenCL functionality.

    I went to AMD's, & Intel's website, & read up a little on the issue, & they are saying that I need to install OpenCL Runtime for Intel Core and Intel Xeon Processors for the CPU... also RadeonOpenCompute (ROCm) for the AMD GPU.

    Right now, I only want the CPU to work (Just to have something working), but if possible, both CPU, & GPU would be awesome if they both began working.


    Here's the link to the Intel Core 2 Duo CPU drivers:

    OpenCL™ Drivers and Runtimes for Intel Architecture

    Hashcat says it has to be version 6.1.1 or Later.

    I scrolled down Intel's Driver page, but have no idea which one of the downloads is the right one to get for Knoppix. They have:

    Windows
    SLES
    Linux
    Red Hat
    Ubuntu

    I downloaded Ubuntu's version, & extracted it, but saw a bunch of .rpm files, & I have no idea how to install those, so now I'm here wondering if you guys have an easy fix.

    Thanks in advance guys... i'm patiently staring at the screen, waiting for your awesome replies.
    Last edited by DTeCH; 05-23-2018 at 11:47 PM.

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    Hi!

    There are Debian packages hashcat and pocl-opencl-icd. They could be installed with
    Code:
    sudo apt-get update
    sudo apt-get -t sid install hashcat pocl-opencl-icd
    Maybe this helps solving the issue.

    If the program does not run on Knoppix 8.1 you could try Knoppix 8.2.

  3. #3
    Junior Member
    Join Date
    Jan 2013
    Posts
    14
    Thanks for the info klaus2008

    The install codes you suggested installed without any issues, & started, but they are still complaining about the drivers not being the right ones. From the root Terminal, this is what i get:

    Code:
    root@Microknoppix:/home/knoppix# hashcat -a 0 -d 2 -m 2500 /home/knoppix/Downloads/HASHES/HASH.hccapx /home/knoppix/password.lsthashcat (v4.1.0) starting...
    
    
    Mesa (Gallium) OpenCL platform detected!
    
    
    The Mesa platform can cause errors that are often mistaken for bugs in hashcat.
    You are STRONGLY encouraged to use the drivers listed in docs/readme.txt.
    You can use --force to override this, but do not report related errors.
    You can also use --opencl-platforms to skip the Mesa platform(s).
    
    
    Started: Fri Jun  1 22:22:39 2018
    Stopped: Fri Jun  1 22:22:39 2018
    root@Microknoppix:/home/knoppix#
    When I use --force, this is what I get:

    Code:
    root@Microknoppix:/home/knoppix# hashcat --force -a 0 -d 2 -m 2500 /home/knoppix/Downloads/HASHES/HASH.hccapx /home/knoppix/password.lst
    hashcat (v4.1.0) starting...
    
    
    No devices found/left.
    
    
    Started: Fri Jun  1 22:21:08 2018
    Stopped: Fri Jun  1 22:21:10 2018
    root@Microknoppix:/home/knoppix#
    ...and when I use --opencl-platforms, this is what I get:

    Code:
    root@Microknoppix:/home/knoppix# hashcat --opencl-platforms -a 0 -d 2 -m 2500 /home/knoppix/Downloads/HASHES/HASH.hccapx /home/knoppix/password.lst
    hashcat (v4.1.0) starting...
    
    
    Invalid OpenCL platform 0 specified.
    
    
    Started: Fri Jun  1 22:32:08 2018
    Stopped: Fri Jun  1 22:32:08 2018
    root@Microknoppix:/home/knoppix#
    Just for the hell of it, I also tried them both together... --opencl-platforms AND --force:

    Code:
    root@Microknoppix:/home/knoppix# hashcat --force --opencl-platforms -a 0 -d 2 -m 2500 /home/knoppix/Downloads/HASHES/HASH.hccapx /home/knoppix/password.lst
    hashcat (v4.1.0) starting...
    
    
    Invalid OpenCL platform 0 specified.
    
    
    Started: Fri Jun  1 22:38:49 2018
    Stopped: Fri Jun  1 22:38:49 2018
    root@Microknoppix:/home/knoppix#
    So... I think that because the video card is so old (AMD Radeon HD 6450), & also the CPU (Intel Core 2 Duo), that they need the exact driver that they suggest, because newer technology was implemented into Video Cards, & CPUs a few years after they were made, & does not work with older stuff.

    I downloaded Knoppix 8.2, & will try it on that as well. I was going to try to get Knoppix 8.1 to match my Kali USB environment, but decided not to, because Kali is not smooth, & stable like Knoppix is, & it hangs all the time... not for long, but it hangs alot. Also, Knoppix is perfectly hacked together from multiple Distro styles, & upgrading any part of it, would most likely break other parts. Knoppix is still "King of The Hill" in my eyes.

    I will let you know the results of testing on Knoppix 8.2.

    Thanks again.
    Last edited by DTeCH; 06-02-2018 at 06:09 AM.

  4. #4
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    508
    Hi DTeCH!
    Mesa (Gallium) OpenCL platform detected!
    How about
    Code:
    sudo apt-get update
    sudo apt-get -t sid install hashcat mesa-opencl-icd

  5. #5
    Junior Member
    Join Date
    Jan 2013
    Posts
    14
    Hi klaus2008!

    The new install codes you suggested also installed without any issues, & starts, but now there's a new error.
    From the root Terminal, this is now what i get:

    Code:
    root@Microknoppix:/home/knoppix# hashcat -a 0 -d 2 -m 2500 /home/knoppix/Downloads/HASHES/HASH.hccapx /home/knoppix/password.lst
    hashcat (v4.1.0) starting...
    
    
    : CommandLine Error: Option 'limited-coverage-experimental' registered more than once!
    LLVM ERROR: inconsistency in registered CommandLine options
    root@Microknoppix:/home/knoppix#


    I'm not sure if it's because I installed, & uninstalled Hashcat a few times, or if it's due to installing pocl, & messa together without uninstalling pocl, or whatever. I have no idea what to do.


    I'm still on Knoppix 8.1 64bit... haven't set up 8.2 on the USB yet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
LOT 8 HYNIX HMT42GR7AFR4C-RD 16GB 2Rx4 DDR3 PC3-14900R 1866MHZ SERVER MEMORY RAM
$40.0
LOT 8 HYNIX HMT42GR7AFR4C-RD 16GB 2Rx4 DDR3 PC3-14900R 1866MHZ SERVER MEMORY RAM pictureAvocent Avocent MPUIQ-VMCHS Server Interface Module - Video/USB extender
$25.0
Avocent Avocent MPUIQ-VMCHS Server Interface Module - Video/USB extender pictureDELL EMC R940 8 X 2.5 INCH SERVER 4 X PLATINUM 8153 512GB 6 X 300GB 15K 12G H330
$26909.0
DELL EMC R940 8 X 2.5 INCH SERVER 4 X PLATINUM 8153 512GB 6 X 300GB 15K 12G H330 pictureHPE PROLIANT DL360 G9 Gen9 SERVER E5-2683V4 2.1GHZ 8GB 7 X 1.6TB SSD
$8189.0
HPE PROLIANT DL360 G9 Gen9 SERVER E5-2683V4 2.1GHZ 8GB 7 X 1.6TB SSD pictureDELL POWEREDGE R730XD SERVER 12 BAY TWO E5-2609V4 1.7GHZ 256GB 300GB 15K SAS H73
$4949.0
DELL POWEREDGE R730XD SERVER 12 BAY TWO E5-2609V4 1.7GHZ 256GB 300GB 15K SAS H73 picture