Results 1 to 3 of 3

Thread: no3d cheat parameter gets in an endless loop of starting X with Knoppix 8.2

  1. #1
    Member registered user
    Join Date
    Apr 2007
    Posts
    68

    no3d cheat parameter gets in an endless loop of starting X with Knoppix 8.2

    I usually use knoppix with the no3d boot parameter, like "knoppix64 no3d noscreensaver" but I've noticed with 8.2 it will go into a endless cycle of trying to start X, failing and trying again.

    If I don't use no3d, everything is fine.

    I thought no3d would just disable compiz.

  2. #2
    Member registered user
    Join Date
    Dec 2006
    Posts
    44
    Same observation here on laptop with Intel Haswell and desktop with nvidia GT218.

    Funny observation: on VirtualBox virtual machine with 16 MB video memory and no 3D acceleration, booting with cmdline "knoppix64 keyboard=dk" works fine, starting X without compiz. It seems that if Knoppix 8.2 is allowed to detect that the machine has too little graphics resources to run compiz, it starts X with window manager openbox-lxde just fine. However, when I boot the same VM with cmdline "knoppix64 keyboard=dk no3d" it fails to start X and enters the endless cycle of failing.

  3. #3
    Junior Member registered user
    Join Date
    Aug 2004
    Posts
    13
    no3d changes "something" more ...
    fortunately 8.3 has ( undocumented ? ) nocompiz bootparameter
    it gets parsed by /etc/X11/Xsession.d/45knoppix

    however the "no3d" bug making x unstartable should be investigated ...

    the error message with no3d is:
    [ 40.424] vesa: Ignoring device with a bound kernel driver
    Code:
    [    40.404] (II) LoadModule: "vesa"
    [    40.404] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [    40.404] (II) Module vesa: vendor="X.Org Foundation"
    [    40.404]     compiled for 1.19.0, module version = 2.3.4
    [    40.404]     Module class: X.Org Video Driver
    [    40.404]     ABI class: X.Org Video Driver, version 23.0
    [    40.404] (II) VESA: driver for VESA chipsets: vesa
    [    40.424] vesa: Ignoring device with a bound kernel driver
    [    40.424] (WW) Falling back to old probe method for vesa
    [    40.424] (EE) Screen 0 deleted because of no matching config section.
    [    40.424] (II) UnloadModule: "vesa"
    [    40.424] (EE) Device(s) detected, but none match those in the config file.
    the difference in xorg.conf is as follows:

    Code:
    knoppix@Microknoppix:~$ diff xorg.conf-mit-nocompiz  xorg.conf-mit-no3d
    66c66
    <     Option "Composite" "Enable"
    ---
    >     Option "Composite" "Disable"
    99c99,100
    <     # Driver (chipset) autodetect
    ---
    >         # Specified driver (chipset)
    >     Driver      "vesa"
    who knows why the kernel already allocated the device so vesa cancels itself ?
    why at all nod3 writes vesa in the config ?

    the followin scripts are also part of configuring x11 :
    /sbin/hwsetup
    /sbin/mkxorgconfig

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •