Heres my story, heard about knoppix from a pc mag which had the cd with it, tried it, didn't work hung at:
probing scsi acxxx.o
got on to internet got the latest version booted, same prob....,
pressed F2,
expert xserver=XF86_SVGA xmodule=mga xvrefresh=85 screen=1024x768 noddc (thats the last time ill be typing that again)
and then 'n' for the modules

and it did work but the screen was like the first succesful VDU experiment, my computer is dell latitude V10 p111 1000mhz 20g hd 128mb ram bios revision A09, its got intel extreme graphics controller card, I went to the intel website and tried to get the drivers for the card, there seems to be an issue with the card but then the rpm thingy couldn't create directories etc... won't go into the story of the root password, anyway after the paranoid streak which involved partitioning my hd to peices with all possible file sytems and losing all the data in the partition where I kept all my setup files and "registration informations" and booting and rebooting till the bios started to scream, I finally gave up,
reformatted the linux drives from windows, deleted all the partitions using an exception peice of software called bootitng, and well got back to the way it was before I came across this rebel harvesting piece of code called knoppix, except for the lost data oh dont remond me of those wee little videos..
And then finally before putting my new found passion to a cold rest I decided to try a hand at flashing my bios back to an older version, I got two floppies with the oldest and the lastest bios revisions, flashed the bios to the oldest version and LO there it was all up and running like it was always meant to I am 'just a bit' (used in preferance to 'not much') of a computer geek by any means though I am well on the way ... but then mistake is the best teacher and I have learnt from it so I think I am well qualified to send on a note to troubled souls like me:
1) Don't install it on to the hard drive unless the cd is working
2) IF it says:
Cannot find suitable xserver for your card
Try flashing back to older bios versions, visit your computer manufacturers website..................
=============================================== I am finally convinced that it really works,and when it does it makes you HAPPY so hang on there.
So that was that, now although things are great the little trouble thats still hanging around is that after I have installed it on my computer I cannot access my floppy drive.
Initially when clicked the floppy and cd rom icons on the desktop, it said cannot find mnt/floppy or cdrom I found out that the floppy and the cdrom folder were in the root directory and not in the mnt so I moved them in there but now when I click on floppy I just get a blank folder and I can't see anything inside same with all the drives including the one on which knoppix is installed, the strange thing though, is when I put a music cd in the drive and do 'playmusiccd' from the right click menu it works all fine, and when I tried to load a new wall paper (guess which one, now dont be sick its the knoppix one) from the floppy that worked too, but when I click on the floppy icon I cannot see naything just a blank window and from the sound and look of it doesn't bother reading the drive
================================Now thats my little story any advise from the gurus will be highly appreciated........... I gotto go download some new linux software