Results 1 to 3 of 3

Thread: Update Firefox?

  1. #1
    Junior Member registered user
    Join Date
    Nov 2006
    Posts
    27

    Update Firefox?

    Hello,
    Please bear with me, I don't know Linux well.
    I have Knoppix 8.1 on usb. Firefox tells me it is critically out of date.
    I ran apt-get update
    I input to terminal:

    knoppix@Microknoppix:~/Desktop$ sudo apt-get install firefox

    and got:

    The following packages have unmet dependencies: firefox : Depends: zlib1g (>= 1:1.2.11.dfsg) but 1:1.2.8.dfsg-5 is to be installed
    E: Unable to correct problems, you have held broken packages.

    Could anyone suggest what to do?

  2. #2
    I recommend you to download manually Firefox, extract the file and execute the "Firefox" file inside this folder.

  3. #3
    Hi

    Firefox and Iceweasel are more and more somewhat "difficult" to hand with...


    IF the PROCESSOR is "lite" OLD

    So verify first the compatibility of your processor with "relatively new versions.

    On the other side it is not much recommended to "UPDATE" KNOPPIX (or something

    inside)....for "a long stability of the system".

    knp
    Last edited by knp; 02-22-2019 at 09:03 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •