Results 1 to 3 of 3

Thread: Knoppix wlan on Gateway 600

  1. #1
    Junior Member
    Join Date
    Feb 2003
    Location
    South Dakota, USA
    Posts
    6

    Knoppix wlan on Gateway 600

    I'm using a dual-boot Gateway 600 laptop with a Cisco 350. Unfortunately, while the card works fine in Windows, I get no results when booting knoppix (card is recognized on init, then both status lights light up and stay). This happens with all of the Knoppix CDs (various release dates) that I've burned.

    Obviously the kernel is seeing the kernel as lsmod contains the following:
    airo_cs 3492 0 (unused)
    airo 37800 0 [airo_cs]
    ds 6472 2 [airo_cs]
    yenta_socket 8640 2
    pcmcia_core 37568 0 [airo_cs ds yenta_socket]

    hwsetup -n -v confirms that the card is being detected with the following:
    class: NETWORK
    bus: UNKNOWN
    device: eth
    driver: airo_cs
    desc: 350 Series Wireless LAN Adapter

    When I do a wlcardconfig, I get a dialog box telling me that No Wireless card was found.

    There is even a /proc/driver/aironet directory (which should contain status info) but the directory is blank.

    Although it worked in Red Hat 8, I've also been unable to get this card working in Red Hat 9. Could it be a problem with the version of airo_cs compiled with the kernel?

    As a side note, I've also tried an Orinoco Gold card (model 8420-WD) and have the same problem. The card appears to be recognized and initialized, but wlcardconfig tells me it's not there so I never get the option to enter an SSID or WEP key.

    Thanks,
    Steve

  2. #2
    Junior Member
    Join Date
    Feb 2003
    Location
    South Dakota, USA
    Posts
    6

    Bueller? Bueller?? Anyone??

    Still trying to resolve this issue, any assistance would be appreciated. (I'd love to hear from anyone who's been able to use their Aironet 350 in Knoppix.

    I've read that downgrading the firmware on my card may cause it to work, but have not located any instructions on the Cisco site that explain how to accomplish this in Linux. I could possibly downgrade in Windows and reboot, however, the latest ACU for Windows has some kind of firmware-auto-update feature that can't be disabled...

    Regards,
    SideWynder

  3. #3
    Junior Member
    Join Date
    Nov 2003
    Posts
    1

    try iwconfig

    don't know if you're going to look at this again, but I have a 600XL and my internal orinoco mini-pci card works great with linux...

    you might try using iwconfig. It must be run as root, in Knoppix just do sudo iwconfig

    if you want to set a wep key for instance first you need to see which card has wireless extentions... you can figure this out by running iwconfig without any options
    Code:
    #iwconfig
    lo        no wireless extensions.
     
    sit0      no wireless extensions.
     
    eth0      no wireless extensions.
     
    eth1      IEEE 802.11-DS  ESSID:"ambs hall"  Nickname:"HERMES I"
              Mode:Managed  Frequency:2.442GHz  Access Point: 00:90:4B:08:5D:C6
              Bit Rate:5.5Mb/s   Tx-Power=15 dBm   Sensitivity:1/3
              Retry limit:4   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality:0/92  Signal level:107/153  Noise level:166/153
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    so now we see that eth1 has wireless extensions.. so lets say I wanted to set the wep key... i would do
    Code:
    sudo iwconfig eth1 key hexkey
    or
    sudo iwconfig eth1 key "s:alphakey"
    Hope that helps...

Similar Threads

  1. Replies: 1
    Last Post: 01-30-2005, 03:11 AM
  2. knoppix... gateway or router?
    By ghostblaze in forum Networking
    Replies: 6
    Last Post: 10-31-2004, 11:58 PM
  3. Knoppix Router/Gateway?
    By melo in forum The Lounge
    Replies: 4
    Last Post: 11-11-2003, 09:40 PM
  4. Knoppix PC as a gateway problem
    By orcsoul in forum Networking
    Replies: 2
    Last Post: 09-14-2003, 07:57 AM
  5. Gateway and Knoppix
    By djm in forum General Support
    Replies: 2
    Last Post: 01-20-2003, 02:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •