Results 1 to 7 of 7

Thread: SU fails after install

  1. #1

    SU fails after install

    Sorry if this question has been asked before, but I searched and found nothing. I ran the knoppix-installer script from the 2003-07-25 knoppix CD. Unfortunately the user account created durring the install is unable to issue the su command (authentication failed). I added the created user to the adm, root, and staff groups, but no luck. Am I missing the obvious?

  2. #2
    Junior Member registered user
    Join Date
    Jul 2003
    Posts
    12
    You may need to boot up the Knoppix CD, acess the harddrive (be sure it is set as writable) /mnt/hda?/etc/shadow file and delete the root password (between the first two colons). Then logout of the CD and restart and login as root with a blank password. Your can then reset the password typing passwd and giving a new password.

  3. #3
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041
    NONONO, editing the shadow password file directly is definitely NOT recommended. Too many things can go wrong.

    --First of all, are you typing the ROOT password when you try to su? There's a difference in behavior from the ' sudo ' command. With sudo, you type the *USER'S* password, and the userid has to have an entry in /etc/sudoers.

    --If you need to reset the root password for whatever reason, I would boot from CD and ' chroot ' to the root partition, then ' passwd root ' rather than editing the shadow file directly.

    Quote Originally Posted by aaronforjesus
    You may need to boot up the Knoppix CD, acess the harddrive (be sure it is set as writable) /mnt/hda?/etc/shadow file and delete the root password (between the first two colons). Then logout of the CD and restart and login as root with a blank password. Your can then reset the password typing passwd and giving a new password.

  4. #4
    Junior Member registered user
    Join Date
    Jul 2003
    Posts
    12
    Sounds a lot safer. Thanks for the tip!

  5. #5
    Thanks for the help guys, but let me clarify a bit. The root password works just fine when logging in as root, but when, as a normal user, I issue the su command and enter the root password I get an error telling me that authentication failed.

  6. #6
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041
    --Try adding the username to /etc/sudoers; if that doesn't help with the ' su ' command then at least you can still ' sudo bash ' and get to root.

    Code:
    # User privilege specification
    root    ALL=(ALL) ALL
    your-user    ALL=(ALL) ALL
    Quote Originally Posted by cr8dle2grave
    Thanks for the help guys, but let me clarify a bit. The root password works just fine when logging in as root, but when, as a normal user, I issue the su command and enter the root password I get an error telling me that authentication failed.

  7. #7

    Fixed

    I found a fix for my problem:

    • I found my answer by reading through the Linux Pam Administrator Guide
      I edited /etc/pam.d/su and uncommented the following line:
      Code:
      auth       required   pam_wheel.so


    This line sets the configuration so that a user must be a member of the "root" group in order to issue the "su" command. I'm not sure why I had to do this as with the line commented it should allow all users to issue the "su" command. Anyhow, it works now.

Similar Threads

  1. LILO fails on HD install
    By bazfum in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 12-02-2004, 09:04 PM
  2. V3.6 fails to install into root partition
    By markb in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 09-19-2004, 03:37 AM
  3. HDD install 3.4 fails
    By g-joey in forum Hdd Install / Debian / Apt
    Replies: 11
    Last Post: 07-03-2004, 05:38 PM
  4. 3.3 install succeeds, but boot fails
    By zero_divide_1 in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 04-07-2004, 07:06 AM
  5. Lilo install to MBR fails
    By devilotx in forum Hdd Install / Debian / Apt
    Replies: 11
    Last Post: 02-04-2004, 04:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •