Results 1 to 4 of 4

Thread: Discard Knoppix 8.2 and accept 8.6?

  1. #1
    Senior Member registered user
    Join Date
    Dec 2008
    Location
    Mysore, India
    Posts
    272

    Discard Knoppix 8.2 and accept 8.6?

    In the middle the release Repository List has changed.
    Now:
    stretch oldstable
    Buster stable
    bullseye testing
    sid unstable
    experimental

    So should I restructure the repository list?

    I tried to update/Reload Synaptic package Informaiton.

    Report:
    Could not download all repository indexes

    The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.
    The repository 'http://www.deb-multimedia.org squeeze Release' does not have a Release file.Updating from such a repository can't be done securely, and is therefore disabled by default.See apt-secure(8) manpage for repository creation and user configuration details.
    Repository 'http://security.debian.org stable/updates InRelease' changed its 'Version' value from '9' to '10'Repository 'http://security.debian.org stable/updates InRelease' changed its 'Codename' value from 'stretch' to 'buster'This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
    Repository 'http://ftp.de.debian.org/debian stable InRelease' changed its 'Version' value from '9.4' to '10.1'Repository 'http://ftp.de.debian.org/debian stable InRelease' changed its 'Codename' value from 'stretch' to 'buster'This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
    Repository 'http://ftp.de.debian.org/debian stable-updates InRelease' changed its 'Codename' value from 'stretch-updates' to 'buster-updates'This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
    Repository 'http://ftp.de.debian.org/debian testing InRelease' changed its 'Codename' value from 'buster' to 'bullseye'

    Important points to note:
    Repository value 9 to 10 / 9.4 to 10.1

    Shall experiment and post result here.

    The Easy Way: Discard Knoppix 8.2 and accept 8.6?

    The Satisfying Way:
    Re-phrase the Apt repository list with oldstable 9.11.0 as the base.

  2. #2
    Senior Member registered user
    Join Date
    Dec 2008
    Location
    Mysore, India
    Posts
    272

    sources.list for 8.2

    This is the sources.list for 8.2:
    Code:
    # Debian/Squeeze is the stable base for this installation
    deb http://ftp.de.debian.org/debian/ oldstable main contrib non-free  
    deb http://security.debian.org/ oldstable/updates main contrib non-free  
    
    # testing/unstable/experimental contain newer versions, but
    # packages from there are not being installed by default, unless
    # they came from there in the first place.
    deb http://ftp.de.debian.org/debian/ stable main contrib non-free   
    deb http://ftp.de.debian.org/debian/ stable-updates main contrib non-free    
    deb http://security.debian.org/ stable/updates main contrib non-free   
    deb http://ftp.de.debian.org/debian/ testing main contrib non-free   
    deb http://ftp.de.debian.org/debian/ unstable main contrib non-free    
    deb http://ftp.de.debian.org/debian/ experimental main contrib non-free    
    
    # Debian/volatile contains quickly changing data like spam- and virusfilter databases
    # Does not exist anymore
    # deb http://volatile.debian.org/debian-volatile/ stable/volatile main contrib non-free  
    
    # Knoppix repository
    deb http://debian-knoppix.alioth.debian.org/ ./ 
    
    # x2go
    # deb http://x2go.obviously-nice.de/deb/ lenny main 
    # deb http://packages.x2go.org/debian/ squeeze main 
    # deb http://packages.x2go.org/debian/ wheezy main 
    # deb http://packages.x2go.org/debian/ sid main 
    
    # Debian Multimedia, contains non-free software like acrobat reader
    deb http://www.deb-multimedia.org/ squeeze non-free main  
    
    # eviacam
    # deb http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu/ utopic main 
    # deb-src http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu/ utopic main 
    # deb http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu/ vivid main 
    # deb-src http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu/ vivid main 
    # deb http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu/ trusty main 
    # deb-src http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu/ trusty main
    In the coming days, I shall post the modified sources.list.

  3. #3
    Senior Member registered user
    Join Date
    Dec 2008
    Location
    Mysore, India
    Posts
    272
    The above sources.list has not been updated for a long time since squeeze.

    The Chronology of Debian releases are:
    bo/ 1998-12-08 22:17 -
    hamm/ 1999-02-15 19:59 -
    slink/ 2000-03-04 17:24 -
    potato-proposed-updates/ 2003-09-05 16:31 -
    potato/ 2003-09-05 16:31 -
    sarge-proposed-updates/ 2008-10-28 22:59 -
    sarge/ 2008-10-29 08:01 -
    Debian-0.93R6/ 2008-10-31 19:43 -
    rex/ 2008-10-31 19:51 -
    buzz/ 2008-10-31 23:13 -
    hamm-proposed-updates/ 2008-11-01 01:09 -
    slink-proposed-updates/ 2008-11-01 16:46 -
    woody/ 2009-06-12 22:40 -
    etch/ 2010-06-20 20:23 -
    etch-m68k/ 2010-06-20 20:24 -
    lenny/ 2012-03-25 08:48 -
    squeeze/ 2015-08-25 13:02 -
    squeeze-proposed-updates/ 2016-03-08 21:12 -
    squeeze-lts/ 2016-03-08 21:26 -
    jessie-backports/ 2019-02-12 22:44 -
    jessie-backports-sloppy/ 2019-02-13 08:27 -
    wheezy-backports/ 2019-02-15 09:15 -
    wheezy-backports-sloppy/ 2019-02-15 09:15 -
    wheezy/ 2019-02-16 17:20 -
    jessie/ 2019-02-17 02:42 -
    jessie-kfreebsd/ 2019-04-13 08:55 -
    ... and the rest follows ...

    Jessie oldoldstable

  4. #4
    Senior Member registered user
    Join Date
    Dec 2008
    Location
    Mysore, India
    Posts
    272

    Investigations ...

    Code:
    /KNOPPIX/etc/apt/apt.conf.d/00knoppix
    has the correct mention:
    Code:
     // Debian/stretch is the "stable" release in this version of KNOPPIX!

    The following two binaries contain the string:
    (1) srcpkgcache.bin
    Code:
    /var/lib/apt/lists/ftp.de.debian.org_debian_dists_stable_Release....ftp.de.debian.org.....stable....9.4.....Debian....stretch..
    (2) pkgcache.bin
    Code:
    /var/lib/apt/lists/ftp.de.debian.org_debian_dists_stable_Release....ftp.de.debian.org.....stable....9.4.....Debian....stretch...
    So it figures why 9.4 is the base stretch. Now to upgrade to 9.11.0, the final Stretch.

    Need to find if similar binaries have the above string:
    Code:
    ftp.de.debian.org.....stable....9.4.....Debian....stretch
    The directory /var/lib/apt/lists is found to have the following:
    auxfiles
    debian-knoppix.alioth.debian.org_._InRelease
    debian-knoppix.alioth.debian.org_._Packages
    ftp.de.debian.org_debian_dists_experimental_contri b_binary-i386_Packages
    ftp.de.debian.org_debian_dists_experimental_InRele ase
    ftp.de.debian.org_debian_dists_experimental_main_b inary-i386_Packages
    ftp.de.debian.org_debian_dists_experimental_non-free_binary-i386_Packages
    ftp.de.debian.org_debian_dists_stable_contrib_bina ry-i386_Packages
    ftp.de.debian.org_debian_dists_stable_main_binary-i386_Packages
    ftp.de.debian.org_debian_dists_stable_non-free_binary-i386_Packages
    ftp.de.debian.org_debian_dists_stable_Release
    ftp.de.debian.org_debian_dists_stable-updates_InRelease
    ftp.de.debian.org_debian_dists_stable-updates_main_binary-i386_Packages
    ftp.de.debian.org_debian_dists_testing_contrib_bin ary-i386_Packages
    ftp.de.debian.org_debian_dists_testing_InRelease
    ftp.de.debian.org_debian_dists_testing_main_binary-i386_Packages
    ftp.de.debian.org_debian_dists_testing_non-free_binary-i386_Packages
    ftp.de.debian.org_debian_dists_unstable_contrib_bi nary-i386_Packages
    ftp.de.debian.org_debian_dists_unstable_InRelease
    ftp.de.debian.org_debian_dists_unstable_main_binar y-i386_Packages
    ftp.de.debian.org_debian_dists_unstable_non-free_binary-i386_Packages
    lock
    partial
    security.debian.org_dists_stable_updates_contrib_b inary-i386_Packages
    security.debian.org_dists_stable_updates_InRelease
    security.debian.org_dists_stable_updates_main_bina ry-i386_Packages
    security.debian.org_dists_stable_updates_non-free_binary-i386_Packages
    security.debian.org_dists_testing_updates_InReleas e
    *_Sources

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Cisco UCS 5108 Blade Server Chassis Enclosure N20-C6508 4x PSU 8x Fans 2x Fabric picture

Cisco UCS 5108 Blade Server Chassis Enclosure N20-C6508 4x PSU 8x Fans 2x Fabric

$139.99



Cisco UCSB-B420-M3 (4)E5-4640 2.2Ghz 768GB NO HDD NO OS Blade Server picture

Cisco UCSB-B420-M3 (4)E5-4640 2.2Ghz 768GB NO HDD NO OS Blade Server

$300.00



DELL PEM640 POWEREDGE M640 BLADE SERVER picture

DELL PEM640 POWEREDGE M640 BLADE SERVER

$539.95



Dell PowerEdge M620 0F9HJC Blade Server 2*E5-2670 2.60GHz 192GB RAM 2*300GB SAS picture

Dell PowerEdge M620 0F9HJC Blade Server 2*E5-2670 2.60GHz 192GB RAM 2*300GB SAS

$90.99



DELL POWEREDGE FC640 Blade Server  14th Generation For Dell FX2S 2 x CPU NO RAM picture

DELL POWEREDGE FC640 Blade Server 14th Generation For Dell FX2S 2 x CPU NO RAM

$249.99



HP Proliant BL460C Gen8 Blade Server 2x 8C E5-2690 192GB Ram picture

HP Proliant BL460C Gen8 Blade Server 2x 8C E5-2690 192GB Ram

$58.76



CISCO B200 M4 2x E5 2695V3  24x 16gb Cisco 15 102216 01   384GB 2x Caddy No Hdd picture

CISCO B200 M4 2x E5 2695V3 24x 16gb Cisco 15 102216 01 384GB 2x Caddy No Hdd

$350.00



Google Search Appliance - Dell PowerEdge R710 x2 Xeon X5690 192GB Memory 6TB HDD picture

Google Search Appliance - Dell PowerEdge R710 x2 Xeon X5690 192GB Memory 6TB HDD

$529.99



HP ProLiant BL460c Gen9 Blade 2x E5-2660v4 2.0GHz =28 Cores 128GB P246 650FLB picture

HP ProLiant BL460c Gen9 Blade 2x E5-2660v4 2.0GHz =28 Cores 128GB P246 650FLB

$284.00



DELL PowerEdge M630 Blade 2x E5-2683v3 2.0GHz =28 Cores 128GB H330 2x10Gb X520 picture

DELL PowerEdge M630 Blade 2x E5-2683v3 2.0GHz =28 Cores 128GB H330 2x10Gb X520

$288.00