Results 1 to 4 of 4

Thread: My kernel 2.6 experience so far

  1. #1
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041

    My kernel 2.6 experience so far

    --I haven't gone to sleep yet and the kernel is still compiling under VMWARE, so here's my unvarnished 2.6.0-test4 experience. Keeping a changelog can SAVE YOUR ASS.

    --It all started when I read on Linux Weekly News that a new game (beneath-a-steel-sky) had come out for scummvm, and I figured I'd try it out. I also wanted to start testing the new 2.6 kernel.

    (ominous music)

    --Basically things went weird when I installed the game, it removed a LOT of packages. So I sez to Mabel, I sez, we should keep this in da log JIC it comes back to bite me in the ass. So here it is, mostly unedited. (I gotta SLEEP.) Beware of games that only come in unstable... Thank God this all happened on my VMware DVD-ISO install and not on the install I use every day!!

    Code:
    2003.0904 + Attempting to upgrade to kernel 2.6-test4!!
    [
    	! Changed gcc to 2.95 from 3.3, still can't even make config. :(
    	+ Installed pkg module-init-tools (0.9.13-pre-1)
    	+ Installed pkg quotatool (1.3.2-2)
    
    	+ Updated nfs: apt-get -t unstable install nfs-common nfs-kernel-server
    Get:1 http://ftp2.de.debian.org unstable/main nfs-common 1:1.0.5-2 [55.4kB]
    Get:2 http://ftp2.de.debian.org unstable/main nfs-kernel-server 1:1.0.5-2
    Preparing to replace nfs-common 1:1.0.3-2 (using
    .../nfs-common_1%3a1.0.5-2_i386.deb) ...
    Preparing to replace nfs-kernel-server 1:1.0.3-2 (using
    .../nfs-kernel-server_1%3a1.0.5-2_i386.deb) ...
    Setting up nfs-common (1.0.5-2) ...
    Setting up nfs-kernel-server (1.0.5-2) ...
    
    
    ]
    	! OMG, we haven't done pkg-deletion yet!!
    	+ OK, pkg deletion is done.
    
    + Installed beneath-a-steel-sky game:
     (Run scummvm, then select game.  Don't use fullscreen mode.)
    
    [ apt-get install beneath-a-steel-sky \
      scummvm/unstable libc6/unstable libgcc1/unstable libstdc++5/unstable
    
    Reading Package Lists...
    Building Dependency Tree...
    Selected version 0.5.1-2 (Debian:unstable) for scummvm
    Selected version 2.3.2-5 (Debian:unstable) for libc6
    Selected version 1:3.3.2-0pre2 (Debian:unstable) for libgcc1
    Selected version 1:3.3.2-0pre2 (Debian:unstable) for libstdc++5
    The following extra packages will be installed:
      cpp-3.2 gcc-3.2 libc6 libgcc1 libstdc++5 scummvm
    Suggested packages:
      gcc-3.2-doc timidity
    The following packages will be REMOVED:
      build-essential comerr-dev ethereal-dev g++ g++-3.2 g++-3.3 gcj-3.3
      gdk-imlib1-dev j2re1.4 kdelibs4-dev libart-2.0-dev libart-dev libarts1-dev
      libartsc0-dev libasound2-dev libaudiofile-dev libbz2-dev libc6-dev libcln-dev
      libcupsys2-dev libesd0-dev libexpat1-dev libfontconfig1-dev libfreetype6-dev
      libgcj4-dev libgcrypt-dev libgdbmg1-dev libgdk-pixbuf-dev
      libgdk-pixbuf-gnome-dev libginac-dev libglib1.2-dev libglib2.0-dev
      libgnome-dev libgnomeprint-dev libgnorba-dev libgnutls5-dev libgtk1.2-dev
      libjpeg62-dev libmng-dev libncurses5-dev libnewt-dev libogg-dev
      libopencdk-dev liborbit-dev libpam0g-dev libpcap-dev libpcre3-dev
      libpng12-dev libpng3-dev libpopt-dev libqt3-mt-dev libquantlib0-dev
      libreadline4-dev libsasl-dev libsdl-image1.2-dev libsdl-mixer1.2-dev
      libsdl1.2-dev libsmpeg-dev libstdc++5-3.3-dev libstdc++5-dev libtiff3g-dev
      libtool libusb-dev libvorbis-dev libwrap0-dev libxaw7-dev libxft2-dev
      libxml-dev libxml2-dev libxslt1-dev locales slang1-utf8-dev xlibmesa-gl-dev
      xlibmesa-glu-dev xlibs-dev zlib1g-dev
    The following NEW packages will be installed:
      beneath-a-steel-sky scummvm
    5 packages upgraded, 2 newly installed, 76 to remove and 232 not upgraded.
    Need to get 76.4MB of archives.
    After unpacking 139MB disk space will be freed.
    Do you want to continue? [Y/n] Abort.
    ]
    
    	+ Continuing to attempt kernel:
    [ apt-get -t unstable install g++
    The following extra packages will be installed:
      cpp cpp-3.3 g++-3.3 g77-3.3 gcc-3.3 gcc-3.3-base libc6-dev
      libstdc++5-3.3-dev
    Suggested packages:
      gcc-3.3-doc libstdc++5-3.3-doc
    Recommended packages:
      c-compiler
    The following NEW packages will be installed:
      g++ g++-3.3 libc6-dev libstdc++5-3.3-dev
    5 packages upgraded, 4 newly installed, 0 to remove and 728 not upgraded.
    Need to get 9532kB of archives.
    After unpacking 21.6MB of additional disk space will be used.
    Do you want to continue? [Y/n]
    
    
    [ apt-get -t unstable install build-essential
    Get:1 http://ftp2.de.debian.org unstable/main build-essential 9.6 [6274B]
    
    	! Success!  Apparently this now enables make config!
    	? Now on to menuconfig...
    	 + Installed pkg libbz2 0.9.5d-4.1 from unstable
    	 + apt-get -t unstable install libncurses5 (libncurses5 5.3.20030719-2)
    	 + apt-get -t unstable install libncurses5-dev (libncurses5 5.3.20030719-2)
    ]	! YAY! Now we can do make menuconfig again!! :)
    --So right now the kernel is still compiling. When I wake up I'll see if it bootz. However, my GTK+ and QT install is completely b0rked now, so no chance to see if make xconfig or make gconfig works. But AAMOF it's not that much loss, I always used menuconfig anyway.

    ...mumble,mumble, needsleepgottagoseeyaz.

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041

    Wait, it gets worse!

    Wait, it gets worse!
    Code:
    ]	! YAY! Now we can do make menuconfig again!! :)
    
    	+ Installed pkg mkinitrd-tools (+ dash)
    
    	+ Fixed /etc/hostname, etc/hosts for squid, fqdn nds be 1st!)
    
    	! Nd to recompile 2.6.0-test4 for SCSI Buslogic not-module!
    	 - Took out Flashpoint support for driver
    
    	+ Fixed inittab for mingetty 2-4
    
    	! Boot process stops with:
    	INIT: PANIC: segmentation violation blah (code)! Sleeping 30 seconds.
    
    [ apt-get install sysvinit/unstable
    Selected version 2.85-7 (Debian:unstable) for sysvinit
    The following extra packages will be installed:
      initscripts mount sysv-rc sysvinit
    The following packages will be REMOVED:
      mount-aes
    The following NEW packages will be installed:
      initscripts mount sysv-rc
    The following packages will be DOWNGRADED
      sysvinit
    WARNING: The following essential packages will be removed
    This should NOT be done unless you know exactly what you are doing!
      mount-aes
    0 packages upgraded, 3 newly installed, 1 downgraded, 1 to remove and 231
    not upgraded.
    Need to get 235kB of archives.
    After unpacking 123kB of additional disk space will be used.
    You are about to do something potentially harmful
    To continue type in the phrase 'Yes, do as I say!'
    ]
    
    	- For 2.6 - took out:
    	/etc/init.d/checkroot.sh - /sbin/update
    	Still panicking, but now the panic is the LAST msg.
    
    	! sysvinit unstable had some unpacking errs, not installed. :(
    	+ Ok, now we'll try the sysvinit that's in testing.
    
    [ apt-get install sysvinit/testing
    Selected version 2.85-4.1 (Debian:testing) for sysvinit
    The following extra packages will be installed:
      initscripts mount sysv-rc sysvinit
    The following packages will be REMOVED:
      mount-aes
    The following NEW packages will be installed:
      initscripts mount sysv-rc
    The following packages will be DOWNGRADED
      sysvinit
    WARNING: The following essential packages will be removed
    This should NOT be done unless you know exactly what you are doing!
      mount-aes
    0 packages upgraded, 3 newly installed, 1 downgraded, 1 to remove and 231
    not upgraded.
    Need to get 80.9kB/229kB of archives.
    After unpacking 106kB of additional disk space will be used.
    You are about to do something potentially harmful
    To continue type in the phrase 'Yes, do as I say!'
     ?] Yes, do as I say!
    ]
    
    
    [ dpkg --force-overwrite --unpack /var/cache/apt/archives/sysv-rc_2.85-4.1_all.deb
    (Reading database ... 178158 files and directories currently installed.)
    Unpacking sysv-rc (from .../sysv-rc_2.85-4.1_all.deb) ...
    dpkg - warning, overriding problem because --force enabled:
     trying to overwrite `/etc/init.d/rc', which is also in package sysvinit
    dpkg - warning, overriding problem because --force enabled:
     trying to overwrite `/etc/init.d/rcS', which is also in package sysvinit
    dpkg - warning, overriding problem because --force enabled:
     trying to overwrite `/etc/init.d/README', which is also in package sysvinit
    dpkg - warning, overriding problem because --force enabled:
     trying to overwrite `/etc/rcS.d/README', which is also in package sysvinit
    dpkg - warning, overriding problem because --force enabled:
     trying to overwrite `/usr/share/man/man5/rc.boot.5.gz', which is also in
    package sysvinit
    dpkg - warning, overriding problem because --force enabled:
     trying to overwrite `/usr/sbin/invoke-rc.d', which is also in package
    sysvinit
    dpkg - warning, overriding problem because --force enabled:
     trying to overwrite `/usr/sbin/update-rc.d', which is also in package
    sysvinit
    
    	( Also did dpkg force overwrite same for initscripts )
    	Then did the apt-get install again.  Replied Y to updated files.
    
    	+ Updated vmware-linux-tools in usrlocalbin.
    	- Removed cdrecord -scanbus in boot.local due to vmware panic
    
    	!!! YAY!  2.6 bootz now!!
    
    	+ Installed pkg discover
    --To sum up: It works now, for the most part, but I had to jump thru HOOPS:

    o If I hadn't installed the game 1st, there would have been less problems with compiling.

    o I ended up recompiling several times due to my modularizing critical things that needed to be there for VMware / booting to work right. You know, LITTLE things like the BusLogic SCSI driver.

    o The INIT PANIC really stumped me, I was gonna quit right there. I googled for it and found that it related to the sysvinit pkg version, so gave it one more try. Then I had to FORCE apt-get / dpkg to downgrade things.

    o I had to replace my sysvinit packages. This is a serious thing.

    o ' cdrecord -scanbus ' will cause VMware to crash hard, so it doesn't work.

    o Still have to investigate sound. (I boot into console mode - non-X - and use sawfish instead of KDE, so it's amazing how many problems I avoid with arts and the like.) But I compiled both alsa and OSS soundblaster in as modules, so there's either a conflict or a naming-scheme change.

    --Trust me people, I've been using various Linux distros since ~1997, and 2.6 kernel is probably NOT for you (yet.)

  3. #3
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041
    Important note about sound:

    --After running alsa_snddevices, sound was broken even after rebooting into 2.4.21. I just figured out what it was today, after trying to /dev/MAKEDEV dsp and getting nowhere. Then I did an ' ls -l /dev/dsp* ' and figured out what happened:

    lrwxrwxrwx 1 root root 9 Sep 4 20:56 /dev/dsp -> /dev/dsp0
    crw-rw---- 1 root audio 14, 3 Sep 4 20:56 /dev/dsp0
    crw-rw---- 1 root audio 14, 19 Sep 4 20:56 /dev/dsp1
    crw-rw---- 1 root audio 14, 35 Sep 4 20:56 /dev/dsp2
    crw-rw---- 1 root audio 14, 51 Sep 4 20:56 /dev/dsp3

    --Notice the permissions:
    o User=root=rw
    o Group=audio=rw
    o Other = NO PERMISSIONS!!

    --So to solve this I added my non-root userid to group "audio" in /etc/group, and now sound works in 2.6.0-test4!!

  4. #4
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041
    --Pretty much everything works in 2.6 now AFAICan tell, except cdrecord -scanbus. X server crashes every so often when changing to ctrl-alt-f1 (console mode.)

    --X windows interactivity is greatly increased. I didn't believe it when I saw other ppl posting about this, but it's true. It *feels* faster.

    --Will keep y'all informed if anything changes.

Similar Threads

  1. Replies: 3
    Last Post: 05-09-2005, 10:08 AM
  2. Replies: 0
    Last Post: 10-27-2004, 05:04 AM
  3. Replies: 2
    Last Post: 11-07-2003, 10:28 PM
  4. Modified kernel results in Kernel Panic - No init found.
    By tji in forum Customising & Remastering
    Replies: 4
    Last Post: 06-12-2003, 06:40 PM
  5. Hard Drive Install Experience
    By gabbman in forum The Lounge
    Replies: 2
    Last Post: 12-13-2002, 02:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •