Results 1 to 2 of 2

Thread: No CD burner after kernel upgrade

  1. #1

    No CD burner after kernel upgrade

    Hello,

    I did a hdd install of Knoppix 3.1 and the cd burner (liteon 52x24x52x) worked fine using the 2.4.20-xfs kernel. The burner was scd0 under /dev.

    But when I upgraded my kernel to 2.4.21, the burner doesn't work, I cannot even read from it or write to it. I have tried to read lots of different cds, ones which used to work.

    root@box:/# mount /dev/scd0 /cdrom
    mount: /dev/scd0 is not a valid block device

    root@box:/# mount /dev/hdd /cdrom
    mount: /dev/hdd: can't read superblock

    root@box:/# ls -al /dev/cdrom
    lrwxrwxrwx 1 root root 3 Aug 16 23:54 /dev/cdrom -> sr0

    root@box:/# ls -al /dev/hdd
    brw-rw---- 1 root disk 22, 64 Apr 15 2001 /dev/hdd

    root@box:/# ls -al /dev/scd0
    brw-rw---- 1 root cdrom 11, 0 May 31 2001 /dev/scd0



    root@box:/# dmesg
    Linux version 2.4.21 (root@box) (gcc version 3.2.1 20020924 (Debian prerelease)) #1 Sun Aug 24 14:13:28 WST 2003
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 0000000000080000 (usable)
    BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 000000001dfec000 (usable)
    BIOS-e820: 000000001dfec000 - 000000001dfef000 (ACPI data)
    BIOS-e820: 000000001dfef000 - 000000001dfff000 (reserved)
    BIOS-e820: 000000001dfff000 - 000000001e000000 (ACPI NVS)
    BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
    BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
    BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
    479MB LOWMEM available.
    On node 0 totalpages: 122860
    zone(0): 4096 pages.
    zone(1): 118764 pages.
    zone(2): 0 pages.
    Kernel command line: BOOT_IMAGE=Linux ro root=302 hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi apm=power-off nomce
    ide_setup: hda=scsi
    ide_setup: hdb=scsi
    ide_setup: hdc=scsi
    ide_setup: hdd=scsi
    ide_setup: hde=scsi
    ide_setup: hdf=scsi
    ide_setup: hdg=scsi
    ide_setup: hdh=scsi
    Found and enabled local APIC!
    Initializing CPU#0
    Detected 1595.891 MHz processor.
    Console: colour VGA+ 80x25
    Calibrating delay loop... 3185.04 BogoMIPS
    Memory: 483208k/491440k available (1505k kernel code, 7720k reserved, 559k data, 112k init, 0k highmem)
    Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
    Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer-cache hash table entries: 32768 (order: 5, 131072 bytes)
    Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
    CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
    CPU: L2 Cache: 256K (64 bytes/line)
    CPU: After generic, caps: 0383fbff c1cbfbff 00000000 00000000
    CPU: Common caps: 0383fbff c1cbfbff 00000000 00000000
    CPU: AMD Athlon(TM) XP 1900+ stepping 02
    Enabling fast FPU save and restore... done.
    Enabling unmasked SIMD FPU exception support... done.
    Checking 'hlt' instruction... OK.
    POSIX conformance testing by UNIFIX
    enabled ExtINT on CPU#0
    ESR value before enabling vector: 00000000
    ESR value after enabling vector: 00000000
    Using local APIC timer interrupts.
    calibrating APIC timer ...
    ..... CPU clock speed is 1595.9056 MHz.
    ..... host bus clock speed is 265.9843 MHz.
    cpu: 0, clocks: 2659843, slice: 1329921
    CPU0<T0:2659840,T1:1329904,D:15,S:1329921,C:265984 3>
    PCI: PCI BIOS revision 2.10 entry at 0xf1b20, last bus=2
    PCI: Using configuration type 1
    PCI: Probing PCI hardware
    PCI: Using IRQ router default [10de/01b2] at 00:01.0
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
    Starting kswapd
    Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
    pty: 256 Unix98 ptys configured
    Serial driver version 5.05c (2001-07-0 with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
    ttyS00 at 0x03f8 (irq = 4) is a 16550A
    ttyS01 at 0x02f8 (irq = 3) is a 16550A
    Floppy drive(s): fd0 is 1.44M
    FDC 0 is a post-1991 82077
    PPP generic driver version 2.4.2
    Linux agpgart interface v0.99 (c) Jeff Hartmann
    agpgart: Maximum main memory to use for agp memory: 409M
    agpgart: unsupported bridge
    agpgart: no supported devices found.
    Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    hda: ST315320A, ATA DISK drive
    hdd: LITE-ON LTR-52246S, ATAPI CD/DVD-ROM drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: attached ide-disk driver.
    hda: 29888820 sectors (15303 MB) w/2048KiB Cache, CHS=1860/255/63
    ide-cd: passing drive hdd to ide-scsi emulation.
    Partition check:
    hda: hda1 hda2 hda3
    ide-cd: passing drive hdd to ide-scsi emulation.
    SCSI subsystem driver Revision: 1.00
    kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
    es1371: version v0.32 time 14:14:58 Aug 24 2003
    usb.c: registered new driver hub
    host/uhci.c: USB Universal Host Controller Interface driver v1.1
    usb.c: registered new driver hid
    hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
    hid-core.c: USB HID support drivers
    Initializing USB Mass Storage driver...
    usb.c: registered new driver usb-storage
    USB Mass Storage support registered.
    mice: PS/2 mouse device common for all mice
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP, IGMP
    IP: routing cache hash table of 4096 buckets, 32Kbytes
    TCP: Hash tables configured (established 32768 bind 65536)
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    VFS: Mounted root (ext2 filesystem) readonly.
    Freeing unused kernel memory: 112k freed
    Adding Swap: 489972k swap-space (priority -1)
    PCI: Setting latency timer of device 00:04.0 to 64
    Nvidia + AC97 Audio, version 0.24, 17:30:24 Aug 24 2003
    Nvaudio: in Funcction Nvaudio_init_module
    PCI: Enabling device 00:06.0 (0005 -> 0007)
    PCI: Setting latency timer of device 00:06.0 to 64
    Nvaudio: NVIDIA nForce1 Audio found at IO 0xe000 and 0xe100, IRQ 11
    Nvaudio: Audio Controller supports 6 channels.
    NVaudio: Defaulting to base 2 channel mode.
    ac97_codec: AC97 Audio codec, id: ALG32 (ALC650)
    Nvaudio: only 48Khz playback available.
    Nvaudio: AC'97 codec 0 supports AMAP, total channels = 6
    spurious 8259A interrupt: IRQ7.
    /dev/vmmon: Module vmmon: registered with major=10 minor=165
    /dev/vmmon: Module vmmon: initialized
    /dev/vmnet: open called by PID 246 (vmnet-bridge)
    /dev/vmnet: hub 0 does not exist, allocating memory.
    /dev/vmnet: port on hub 0 successfully opened
    bridge-eth0: up
    bridge-eth0: attached
    /dev/vmnet: open called by PID 270 (vmnet-netifup)
    /dev/vmnet: hub 1 does not exist, allocating memory.
    /dev/vmnet: port on hub 1 successfully opened
    /dev/vmnet: open called by PID 269 (vmnet-natd)
    /dev/vmnet: hub 8 does not exist, allocating memory.
    /dev/vmnet: port on hub 8 successfully opened
    /dev/vmnet: open called by PID 288 (vmnet-dhcpd)
    /dev/vmnet: port on hub 1 successfully opened
    ttyS: 1 input overrun(s)
    ide-cd: passing drive hdd to ide-scsi emulation.
    ide-cd: passing drive hdd to ide-scsi emulation.
    ide-cd: passing drive hdd to ide-scsi emulation.
    ide-cd: passing drive hdd to ide-scsi emulation.


    I think i have to re-run some program which will fix this, but I don't know what. I have never set up a burner under linux before.

    Thanks
    Balaclava BoB

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    Try editing /etc/lilo.conf and changing the append line so that hdd=scsi is hdd=ide-scsi then run /sbin/lilo and reboot and see if this helps.

Similar Threads

  1. Kernel upgrade 2.4 -> 2.6
    By eris_pluvia in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 04-19-2005, 06:52 PM
  2. Kernel upgrade problem.
    By massai in forum General Support
    Replies: 32
    Last Post: 01-25-2004, 09:08 AM
  3. kernel upgrade
    By ferreter in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 08-19-2003, 10:23 PM
  4. Kernel Upgrade question
    By bongski55 in forum The Lounge
    Replies: 4
    Last Post: 05-14-2003, 08:32 AM
  5. kernel upgrade/rebuilt WTF
    By fingers99 in forum Hdd Install / Debian / Apt
    Replies: 8
    Last Post: 05-05-2003, 08:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •