Results 1 to 5 of 5

Thread: Knoppix 3.2 on notebook compaq evo (ps/2 problem)

  1. #1
    Junior Member
    Join Date
    Sep 2003
    Posts
    3

    Knoppix 3.2 on notebook compaq evo (ps/2 problem)

    Hi!

    I have a problem with Knoppix on my notebook. It is knoppix 3.2, installed on the hard drive (via knx-hdinstall). It boots, works, but not with a mouse. I have attached PS/2 Compaq mouse with wheel, but it does not work with or without the mouse. The notebook has a touchpad and a "stick", and I've even disabled touchpad, to no avail.

    Any ideas?

    Thanks,
    Miha.

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    Germany
    Posts
    297

    Re: Knoppix 3.2 on notebook compaq evo (ps/2 problem)

    Quote Originally Posted by mihaval
    Hi!

    I have a problem with Knoppix on my notebook. It is knoppix 3.2, installed on the hard drive (via knx-hdinstall). It boots, works, but not with a mouse. I have attached PS/2 Compaq mouse with wheel, but it does not work with or without the mouse. The notebook has a touchpad and a "stick", and I've even disabled touchpad, to no avail.

    Any ideas?

    Thanks,
    Miha.
    But it does work from CD ?

    Please reinstall the new 3.3-ISO to HD with "knoppix-installer" having both mice attached, while booting knoppix. (if you want to use debian-mode)

    cu

    Fabian

  3. #3
    Junior Member
    Join Date
    Sep 2003
    Posts
    3

    Mouse still not working

    So, it is compaq evo n600c, and the mouse is not working.

    If I do a cat /dev/psaux I see the garbage characters, so it is definitely getting something. And /dev/mouse is linked to that. But in X, it is not working.

    Ideas, suggestions?

    Thanks,
    Miha.

  4. #4
    Junior Member
    Join Date
    Sep 2003
    Posts
    3
    Tried the pci=irqmask=0x0e98 cheat code. Same thing. Message at boot time is that it discovers Generic PS/2 mouse. I then tried nowheel option and the mouse jumps to the top right part of the screen and if I move it, I get left and right clikcs (erratic behaviour -- worst than when it was not wokring at all ).

    Help, please!

    BTW, on slackware9, the mouse was working perfectly, even the touch pad and the stick on the notebook.

    Regards,
    Miha.

  5. #5
    Junior Member
    Join Date
    Nov 2003
    Location
    Sevilla-Spain
    Posts
    3
    May be you have a duplicated mouse signal fron console.

    Try this:
    modify your "/etc/gpm.conf" as follows
    --
    device=/dev/psaux
    responsiveness=
    repeat_type=raw <---------- importat line (type raw)
    type=ps2
    append=""
    --

    Good luck

Similar Threads

  1. ACPI problem on HP nx9005 notebook
    By yshadow in forum Laptops
    Replies: 0
    Last Post: 01-07-2005, 09:17 AM
  2. Mouse Not Working - Compaq Notebook
    By spootnicks in forum Laptops
    Replies: 3
    Last Post: 04-04-2004, 01:22 AM
  3. Problem booting from compaq armadam700
    By chouicha in forum Laptops
    Replies: 6
    Last Post: 03-25-2004, 07:50 AM
  4. RAM Problem on Compaq Proliant 5000 Server
    By maguu in forum Hardware & Booting
    Replies: 3
    Last Post: 11-10-2003, 04:53 PM
  5. Replies: 1
    Last Post: 07-23-2003, 11:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •