Results 1 to 4 of 4

Thread: Diskless Install Error "block-major-2 not found"

  1. #1
    Junior Member registered user
    Join Date
    Sep 2003
    Posts
    17

    Diskless Install Error "block-major-2 not found"

    Help! V3.3 Modprobe dies on boot with block-major-2 error, since my Desknote has no traditional floppy drive (uses a usb floppy - and it works).

    Google indicates solution is "alias block-major-2 off" in modules.conf, so I installed to hard drive with Knoppix option so I could modify config files. Went to /etc/modutils/aliases as directed in modules.conf and inserted the above suggested entry. Makes no difference though. Same problem. Does Knopiix ignore the aliases configuration file, or set an otion elsewhere re modprobe instructions?

  2. #2
    Junior Member registered user
    Join Date
    Sep 2003
    Posts
    17
    Dumb newbie error. Didn't run update-modules. That resolved the block-major-2 problem. But when I ran it I got a kernel error message:

    "unresolved symbols in /lib/modules/2.4.22-xfs/kernel/drivers/char/drm/gamma.o"

    Is this totally unrelated, or what?

  3. #3
    Junior Member registered user
    Join Date
    Sep 2003
    Posts
    17
    After running update-modules as indicated above and getting the kernel error message, I now find after rebooting and running dmesg that I am getting the following errors:

    Warning: Remapping obsolete /dev/fb* minor 32 to 1
    Warning: Remapping obsolete /dev/fb* minor 64 to 2
    Warning: Remapping obsolete /dev/fb* minor 96 to 3
    Warning: Remapping obsolete /dev/fb* minor 128 to 4
    Warning: Remapping obsolete /dev/fb* minor 160 to 5
    Warning: Remapping obsolete /dev/fb* minor 192 to 6
    Warning: Remapping obsolete /dev/fb* minor 224 to 7

    Also cannot get my WUSB12 wireless adapter to work on ver 3.3. Set it up exactly as I did on 3.2, but no go.

    I've noticed quite a few messages about problems with ver 3.3 being entered here. I think I'm going back to ver 3.2. There's too much happening here for me to fix with my current limited knowledge of Linux. Maybe they'll get this stuff all fixed by the next release.

    I might try installing to hard drive in Debian mode instead of Knoppix mode. 3.2 knoppix-installer only did Debian mode, and things seemed to work fine.

  4. #4
    Junior Member registered user
    Join Date
    Sep 2003
    Posts
    17
    Tried the Debian option on knoppix-installer. Ended up with the following error messages when script ended. That's it for me. Back to ver 3.2.

    16+0 records in
    16+0 records out
    16384 bytes transferred in 0.004642 seconds (3529478 bytes/sec)
    tar: Removing leading `/' from member names
    tar: etc/pnm2ppa.conf: time stamp 2003-09-26 22:23:02 is 6102 s in the future
    update-rc.d: /etc/init.d/autofs exists during rc.d purge (continuing)
    cp: cannot stat `/etc/alternatives/soffice.*': No such file or directory
    2500+0 records in
    2500+0 records out
    2560000 bytes transferred in 0.045854 seconds (55829321 bytes/sec)
    1+0 records in
    1+0 records out
    512 bytes transferred in 0.020993 seconds (24389 bytes/sec)
    part: /dev/hda1, typ: 12
    part: /dev/hda5, typ: 130
    shell-init: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    Warning: '/proc/partitions' does not exist, disk scan bypassed

Similar Threads

  1. USR 56k PCI modem "busy"/"not found",rec
    By oman in forum General Support
    Replies: 0
    Last Post: 08-03-2004, 06:44 PM
  2. "Error: only one CPU found" (in German) @ boot...
    By softbomber in forum General Support
    Replies: 2
    Last Post: 04-30-2004, 12:20 PM
  3. Linksys WUSB12 / "block-major-2" err terminates au
    By phillfri in forum Hardware & Booting
    Replies: 3
    Last Post: 09-19-2003, 03:33 AM
  4. "Error: No Wireless Network Card Found"
    By akira28 in forum Networking
    Replies: 0
    Last Post: 08-02-2003, 11:52 PM
  5. "Error: No suitable X-Server found for your card"
    By iss in forum General Support
    Replies: 7
    Last Post: 06-16-2003, 02:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •