Results 1 to 2 of 2

Thread: X server crash: "Fatal server error: Active ring not fl

  1. #1
    Junior Member
    Join Date
    Oct 2003
    Posts
    2

    X server crash: "Fatal server error: Active ring not fl

    Hi,

    I've been happily using Knoppix 3.2 (hd install) for the past couple of months (after a number of years running SuSE and Red Hat). In the last week I've had problems with the X Server crashing, although I have made no changes to my configuration nor have I installed any new packages.

    Typically what happens is that, in KDE, I switch to Konqueror (connected to google) and start to enter some text in the search field. Then the screen hangs and moments later is replaced by garbage. Ctrl+Alt+Backspace, Ctrl+alt+f1 do not have any effect. However, the keyboard does respond to a ctrl+alt+del which reboots the machine.

    It has also happened while starting to type an email address into Kmail - one letter and it hangs.

    The XFree86 log shows the following:

    (II) I810(0): Adding 768 scanlines for pixmap caching
    (II) I810(0): Allocated Scratch Memory
    (II) I810(0): [dri] Buffer map : 57d000
    (II) I810(0): [drm] added 256 4096 byte DMA buffers
    (II) I810(0): [drm] dma control initialized, using IRQ 9
    (II) I810(0): [dri] visual configs initialized.
    (==) I810(0): Write-combining range (0xf8000000,0x4000000)
    (II) I810(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
    pgetbl_ctl: 0x179a0001 pgetbl_err: 0x0
    ipeir: 0 iphdr: 50c00004
    LP ring tail: 79f0 head: 7870 len: f001 start 300000
    eir: 0 esr: 0 emr: 3d
    instdone: ff3a instpm: 0
    memmode: 4 instps: 810
    hwstam: 9ac7 ier: 0 imr: 9ac7 iir: 0

    I understand that this type of error is usually encountered with multiple x servers; I am only running one.

    I've spent the morning trawling the web looking for a solution. One suggestion is to comment out the 'Load "dri"' line in XF86Config.

    Has anyone else encountered and solved this problem?

    Thanks in advance,
    Cormac.

  2. #2
    Junior Member
    Join Date
    Oct 2003
    Posts
    2

    "Fatal server error: Active ring not flushed"

    Hi,

    I left out the end of the XFree log, which is the crucial bit, sorry!

    Fatal server error:
    Active ring not flushed

    Regards,
    Cormac.

Similar Threads

  1. Linux server crash
    By Freksen in forum General Support
    Replies: 1
    Last Post: 10-24-2004, 06:49 PM
  2. trouble remastering: "No suitable X-Server"
    By oded in forum Customising & Remastering
    Replies: 4
    Last Post: 06-23-2004, 03:40 PM
  3. Xlib: connection to ":0.0" refused by server
    By LeManu in forum General Support
    Replies: 9
    Last Post: 05-20-2004, 10:19 PM
  4. My "Nearly Noiseless Knoppix Server" using a CF dr
    By seadawg in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 09-20-2003, 05:58 PM
  5. "Error: No suitable X-Server found for your card"
    By iss in forum General Support
    Replies: 7
    Last Post: 06-16-2003, 02:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •