Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: Knoppix: XFree86 DRI Support

  1. #11
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    Quote Originally Posted by Lunik3
    i have compiled my Kernel again and now it is possible to start Kano's Script. But it ends up in a Message who means that the sources are unavailable?!

    I try it later again. maybe it's just a short disturbance on her driver-servers?! hope so...

    Gtx, Pat*
    Did you compile the kernel headers and install them when you installled the kernel image? How did you compile Debian method with make-kpkg or standard method? You most likely need the kernel headers what I always do when using make-kpkg in /usr/src/linux:

    make menuconfig
    fakeroot make-kpkg clean
    fakeroot make-kpkg --append-to-version=.date_of_compile kernel_image modules_image kernel_headers
    cd ..
    dpkg -i kernel-image-2.4.??.date_of_compile-custom.deb kernel-headers-2.4.??.date_of_compile-custom.deb

    When compiling and installing the modules image is usually not built unless you have additional third party modules being compiled.

  2. #12
    Junior Member registered user
    Join Date
    Oct 2003
    Location
    Frankfurt - Germany
    Posts
    14
    I have compiled the Kernel in classic way (take a look above), i try it and try it again...

    But this time with ATI's brand new 3.2.8 Drivers :P

  3. #13
    Junior Member registered user
    Join Date
    Sep 2003
    Posts
    22

    it doesn't work

    Hi,
    the install-raedon.sh by kano doesn't work because of missing files. Is there a updated version available today?

    I have installed DRI von my knoppixV3.3 with "modprobe radeon". And installed the newstest ATI driver with --force-overwrite, but the system don't use it (I think):

    fglrxinfo:
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.3 Mesa 4.0.4

    Thanks for any help,

    Best regards,
    Nils, Germany

  4. #14
    Junior Member registered user
    Join Date
    Oct 2003
    Location
    Frankfurt - Germany
    Posts
    14
    type glxinfo instead of fglxinfo and search for the row: Direct Rendering

    if "Direct Rendering" say's "No", then you have no hardware acceleration active.

    and now a question from my side....
    how did you install the drivers and what for a radeon model do you own?

    Greetings from Frankfurt,
    Patrick, Germany

  5. #15
    Junior Member registered user
    Join Date
    Sep 2003
    Posts
    22

    re

    Hi Patrik,
    ich schreib trotzdem mal weiter in Englisch, damit andere es auch lesen können (auch wenn's kein supi Englisch ist *G*).

    You wrote:
    if "Direct Rendering" say's "No", then you have no hardware acceleration active. and now a question from my side....
    how did you install the drivers and what for a radeon model do you own?

    --------

    Direct Rendering is "NO".
    I have a ATI Radeon 9500.

    I downloaded the driver from schneider... (like the link in install-radeon.sh) and one from ati.de for XFree 4.3
    I installed both (firstly one - doesn't work and then the next)

    I converted it with alien to a dep-package an installed it with --force-overwrite. After this, I entered "modprobe radeon" - /proc/DRI was now available, so I thought, that it works ... but it doesn't - I coundn't compile fglrx.

    /lib/modules/fglrx/build_mod# ./make.sh

    compiling 'firegl_public.c'...
    In file included from /lib/modules/2.4.22-xfs/build/drivers/char/drm/drm_proc.h:37,
    from firegl_public.c:278:
    /lib/modules/2.4.22-xfs/build/drivers/char/drm/drmP.h:932: redefinition of `__cmpxchg'
    /lib/modules/2.4.22-xfs/build/include/asm/system.h:244: `__cmpxchg' previously defined here
    compiling failed - object file was not generated

    ---

    I don't really understand it - why was it priviously defined? Error in Script?

    Thanke for help / Danke für deien Hilfe.

    Gruss
    Nils

    P.S. Gibts von diesem install-radeon.sh Script nirgends ne aktuelle Version mit aktuellen Links? Als Linux-Newbie ist das echt schwer zu installieren... *G*

  6. #16
    Junior Member registered user
    Join Date
    Oct 2003
    Location
    Frankfurt - Germany
    Posts
    14
    Hi Nils,

    sorry für die lange Funkstille, habe die letzten Tage verzweifelt versucht die Radeon Treiber zu installieren... natürlich ohne Erfolg.

    Im prinzip hängst du genau da, wo ich auch hänge *g*



    back to english...

    i have the same problem like you. I can't compile the kernel modules. I've downloaded and installed the kernel- sources and headers for the latest knoppix from this link: http://developer.linuxtag.net/knoppix/

    I've tried ATI's 3.2.5 and 3.2.8 driver without any luck. ATI's Module-Generator still says that i need a newer Kernel Version, from 2.4.8 up. I can't believe. My Kernel has already DRI and SSE Support compiled.

    When i type lsmod in the console, i can see that AGPGART is working well. But the Radeon Module is unused. Should it work for ATI's Binary Driver installation?

    Well... i try it again! If something changes to my luck, i will post it soon as possible!

    Greetings, Pat*

  7. #17
    Junior Member registered user
    Join Date
    Sep 2003
    Posts
    22

    reply

    The same.

    At the moment I have given up because of my test (Ger: IT-Systemkaufmann / IHK Prüfung)

    Maybe I'll try it again in some weeks or if s.th. can help us *G*

    Good luck!

    Gruss
    Nils

  8. #18
    Junior Member registered user
    Join Date
    Oct 2003
    Location
    Frankfurt - Germany
    Posts
    14
    Finaly it works!!!!

    I found a description, that helped me to goal:

    http://xoomer.virgilio.it/flavio.sta...installer.html

    Greetz'n good luck!
    Lunik3

  9. #19
    Senior Member registered user
    Join Date
    Aug 2003
    Location
    Dublin, Ireland
    Posts
    164

    Kano's scripts

    There seems to be a couple of problems with Kano's script "install-radeon.sh". First is tries to download the dri snapshot from dri.sourceforge.net, but the script has a hardcoded date (just after it has worked out the date) of 20030731 but the sourceforge snapshots only holds up to one weeks worth. Secondly, it wants to download from schneider-digital to get the glx1-linux driver, but instead of trying to get glx1_linux_x4.3.zip it tries to get glx1_linux_X4.3.zip (note the capital X). Fixing those at least looks like it will get you going, I'm running this from CD on someone elses machine which I was testing so I can't follow through with the script to verify it completely (dpkg won't work as I'm on a read-only fs).

  10. #20
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Long Island, NY, USA
    Posts
    1,256
    I'm trying to resurrect an old Gateway PC with the ATI Mach64 3D Rage II AGP graphics card. I can't get XFree86-DRI support on here. Any ideas? I'd like to get accelerated graphics running on here if possible. BTW, glxgears only returns 100 fps....

    Also, does anyone know the kano website address? I seem to remember scripts on there for installing scripts on the fly when using the KNOPPIX CD. I'd like to see how this is done.

    TIA,

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Xfree86 version?
    By beige_matchbox in forum MS Windows & New to Linux
    Replies: 2
    Last Post: 04-15-2005, 05:45 PM
  2. ddcprobe and XFree86
    By a.cloete in forum Hardware & Booting
    Replies: 0
    Last Post: 07-17-2004, 10:38 PM
  3. XFree86 AND X11
    By RE Dude in forum The Lounge
    Replies: 1
    Last Post: 11-01-2003, 04:10 PM
  4. Xfree86 4.3.x
    By Viro in forum Ideas
    Replies: 5
    Last Post: 05-03-2003, 07:02 PM
  5. xfree86 4.3
    By good_karma69 in forum General Support
    Replies: 0
    Last Post: 03-09-2003, 01:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •