Results 1 to 5 of 5

Thread: turn on hard drive dma at boot

  1. #1
    Senior Member registered user
    Join Date
    Jul 2003
    Posts
    130

    turn on hard drive dma at boot

    During bootup, I get a warning from fsck saying hard drive dma is turned off and fsck will be very slow. The "bootmisc.sh" script turns on DMA, but apparently this is done after the "checkfs.sh" script that runs the fsck check. I haven't had to run fsck yet, but I'd like to correct the problem. Does anyone know how to turn on dma BEFORE fsck is run during boot up?

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479

    Re: turn on hard drive dma at boot

    Quote Originally Posted by m_yates
    During bootup, I get a warning from fsck saying hard drive dma is turned off and fsck will be very slow. The "bootmisc.sh" script turns on DMA, but apparently this is done after the "checkfs.sh" script that runs the fsck check. I haven't had to run fsck yet, but I'd like to correct the problem. Does anyone know how to turn on dma BEFORE fsck is run during boot up?
    That's a useless error warning if you are really concerned you can install hwtools IIRC and then edit the /etc/init.d/hwtools file that will be created and the dma will get started earlier.

  3. #3
    Senior Member registered user
    Join Date
    Jul 2003
    Posts
    130
    Thank you for the answer. I guess I won't worry about it, but now I know what to do to change things.

  4. #4
    Junior Member
    Join Date
    Sep 2003
    Location
    Australia
    Posts
    6
    so how do you fix this error?

    I have hdparm in bootmisc.sh
    but it loads after like you said.

  5. #5
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    Quote Originally Posted by buneyha
    so how do you fix this error?

    I have hdparm in bootmisc.sh
    but it loads after like you said.
    I've already said in the post above to be perfectly clear.

    apt-get install hwtools next you would vi /etc/init.d/hwtools then uncomment the appropriate lines and comment out the lines in the bootmisc.sh then it gets started a little earlier.

Similar Threads

  1. Can't boot from new hard drive
    By Kowood in forum Hardware & Booting
    Replies: 1
    Last Post: 06-02-2005, 02:44 AM
  2. Losing data on hard disk when turn off computer
    By Mr.Jack in forum General Support
    Replies: 8
    Last Post: 02-21-2005, 12:53 PM
  3. How to have a hard drive automounted at boot?
    By DimGR in forum Hardware & Booting
    Replies: 1
    Last Post: 06-11-2004, 05:53 AM
  4. can't boot from hard drive but only from floppy
    By hnash53 in forum General Support
    Replies: 4
    Last Post: 11-24-2003, 03:29 AM
  5. Is is possible to boot Knoppix from a USB hard drive?
    By pkobos in forum General Support
    Replies: 1
    Last Post: 04-24-2003, 09:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •