Results 1 to 3 of 3

Thread: Belgian keyboard: backslash problem

  1. #1
    Junior Member
    Join Date
    Oct 2003
    Location
    Brussels, Belgium
    Posts
    2

    Belgian keyboard: backslash problem

    Hello,

    I've installed Knoppix on my laptop, changed some things with the help of a good friend, but still, I have a problem with the keyboard when using XFree (console tty are fine).

    It's a Belgian one, here is a picture: http://sunsolve.sun.com/handbook_pub...n_keyboard.gif
    (my laptop doesn't have a numeric pad of course).

    The problem is that to get a backslash ("\" character), I should type AltGr + "<" (which is the key on the right of the left Shift key, see the picture). When I do that, I get a pipe symbol ("|").
    Backslash is available with AltGr + ")" (which is the key on the right of the "0" key).
    Other special characters (like @, , , |, etc.) are fine.

    I haven't noticed this problem with Debian which I am used to.

    For reference, here is the keyboard section of the XF96Config-4 file:

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "CoreKeyboard"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "be"

    EndSection

    Thanks in advance.

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    Ok. In Knoppix the keyboard is determined by a script.

    /etc/init.d/keymap.sh

    as root, edit the line:

    loadkeys /usr/share/keymaps/i386/qwerty/us.kmap.gz (or whatever)

    to reflect the keyboard you want

    and run

    /etc/init.d/keymap.sh reload

  3. #3
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    555
    Yep, problem known, solution too:
    http://article.gmane.org/gmane.linux...n.knoppix/2063
    Are you using a recent Knoppix version? I posted this on the mailing
    list a good while ago, but I don't think anybody cared or took notice.
    That's about my only complaint: the perpetual &beta; status of knoppix.

Similar Threads

  1. Keyboard Problem at GUI Login
    By kaplan71 in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 02-28-2005, 08:07 PM
  2. keyboard problem
    By bugsy in forum General Support
    Replies: 2
    Last Post: 01-06-2005, 09:38 PM
  3. Wrong Belgian azerty keyboard
    By Hugo Coolens in forum General Support
    Replies: 1
    Last Post: 02-21-2004, 02:23 PM
  4. keyboard problem
    By mahony15 in forum General Support
    Replies: 2
    Last Post: 09-14-2003, 04:22 PM
  5. Wierd Problem With USB Keyboard, Maybe Motherboard Problem
    By Triple Six in forum Hardware & Booting
    Replies: 2
    Last Post: 04-15-2003, 04:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
NEW Dell PowerEdge R230 Xeon Quad Core 1TB HDD 8GB RAM AND Server 2012 R2 (OEM)
$1799.99
NEW Dell PowerEdge R230 Xeon Quad Core 1TB HDD 8GB RAM AND Server 2012 R2 (OEM) pictureNEW Dell PowerEdge R230 Xeon Quad Core 1TB HDD 8GB RAM AND Server 2008 R2 (VOL)
$1599.99
NEW Dell PowerEdge R230 Xeon Quad Core 1TB HDD 8GB RAM AND Server 2008 R2 (VOL) pictureNEW Dell PowerEdge R230 Xeon Quad Core 1TB HDD 8GB RAM AND Server 2008 R2 (OEM)
$1799.99
NEW Dell PowerEdge R230 Xeon Quad Core 1TB HDD 8GB RAM AND Server 2008 R2 (OEM) pictureNEW Dell PowerEdge R230 Xeon Quad Core 1TB HDD 8GB RAM AND Server 2012 R2 (VOL)
$1599.99
NEW Dell PowerEdge R230 Xeon Quad Core 1TB HDD 8GB RAM AND Server 2012 R2 (VOL) pictureHP ProLiant DL380 G7 2x X5660 2.8GHz 6 Core 32GB 8x 300GB 15K SAS P410i 512MB
$3487.0
HP ProLiant DL380 G7 2x X5660 2.8GHz 6 Core 32GB 8x 300GB 15K SAS P410i 512MB picture