Results 1 to 5 of 5

Thread: Can't find Knoppix filesystem

  1. #1
    Junior Member
    Join Date
    Oct 2003

    Can't find Knoppix filesystem

    I have a functioning Knoppix CD which I frequently use in my (relatively) new P4 system.

    However, I recently made a boot floppy to use this same CD in my ten year old Pentium MMX system (which can't boot from CD).

    Everything seems to work fine, as Knoppix finds my SCSI Plextor CD-ROM and uses fdomain.o, but it then scans multiple directories and gives me the error "Can't find Knoppix filesystem..." and something about a "(very limited) shell".

    Any thoughts?

    BTW, I'm new to Linux and Knoppix...

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    I know that you say you have a functioning knoppix cd, but you ought nevertheless to check the integrity of the disk. Try booting from the computer that works, but boot with the following cheat code: knoppix testcd

    The only other thing I can think of is if your mmx machine as a really small amount of ram.

  3. #3
    Junior Member
    Join Date
    Oct 2003
    Used testcd cheat code, and everything checked out ok.

    The MMX machine has 96Mb of RAM...

  4. #4
    Junior Member
    Join Date
    Oct 2003
    Being new... does the lack of replies indicated that:

    (1) I've posted this in the wrong place

    (2) This is a silly question that's been rehashed dozens of times, or

    (3) Nobody has any insight as to what's wrong with my system...

  5. #5
    Junior Member
    Join Date
    Nov 2003

    Knoppix 3.3 and KnoppMyth

    I also have this error. I tried Knoppix 3.3 on a machine at work, and got this error. A week later, I tried to install KnoppMyth on a computer at home and got the same error. I don't know what version Knoppix KnoppMyth is based on, but the only similarity I found between the two installs was both computers are Dells. One a Dimension 4400 & the other a Precision 450.

    I did some research:
    and found this:
    I get the error “Can't find Knoppix filesystem.” then it drops me to a “limited shell”. What the hell?
    This means you are not using a SCSI or IDE CDROM drive. After Syslinux starts up the first thing Knoppix wants to do is find and uncompress the filesystem (that big KNOPPIX file on the CD). Knoppix only probes for the CD on all SCSI and IDE buses. If it can't find it you'll get the error above.

    For Transmeta laptops and some Sonys with PCMCIA cd drives try:

    knoppix ide2=0x180 nopcmcia
    Now I'm a bit confused, because both of my machines have the standard CDROM on the IDE bus. So, I don't get it. Maybe a problem with dells?

    Hope that helps.

Similar Threads

  1. Can't find KNOPPIX filesystem, sorry.
    By boomer777 in forum Hardware & Booting
    Replies: 0
    Last Post: 06-11-2005, 10:26 PM
  2. Can't find KNOPPIX filesystem 3.7 vs 3.4
    By mariuss in forum Hardware & Booting
    Replies: 2
    Last Post: 02-23-2005, 02:48 AM
  3. can't find Knoppix filesystem
    By colonius in forum Customising & Remastering
    Replies: 1
    Last Post: 11-20-2004, 06:09 PM
  4. Can't find KNOPPIX filesystem
    By pskipw in forum General Support
    Replies: 0
    Last Post: 05-07-2004, 06:16 AM
  5. can't find KNOPPIX filesystem
    By sfit in forum Customising & Remastering
    Replies: 1
    Last Post: 03-18-2004, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts