Results 1 to 5 of 5

Thread: Knoppix, MD 9.2 and XP - Lilo Probs

  1. #1
    Junior Member
    Join Date
    Mar 2003
    Posts
    9

    Knoppix, MD 9.2 and XP - Lilo Probs

    Hi

    I had my machine up and running with xp and md 9.2. Lilo was working fine.

    I used the knx-hdinstall and didn't write lilo as it was already there with md 9.2. Problem i'm having is, i logged back into md 9.2 to add knoppix to lilo.conf

    just below the main linux i added the following.

    image=/boot/vmlinuz
    label="knoppix"
    root=/hdb5
    intrid=intrid.gz
    append="can't remember what i put here"

    when i ran lilo after this i get an error saying can't find intrid.gz

    can anyone help me out here. I tried following the config from the boot disk but i assume this is slightly different, as it didnt' work

    setup is two harddrives.

    hda1 windows 30gig
    hda5(ithink) md 9.2
    hdb1 fat32 60 gig
    hdb5 knoppix 5gig

    lilo is in the master boot record on hda. hdb5 is also mounted in mandrake when trying to run lilo.

    Do i have to install lilo in knoppix to the hdb5 partition and point the lilo in md to that?

    I'm in work atm hence lack of exact error messages. If these are required I'll post them later when i get home.

    TIA

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    555
    Hello, when running lilo from Mandrake, assuming your knoppix filesystem is mounted on /hdb5 and does not have a separate boot partition, the relevant lilo.conf section should be something like:
    Code:
       image=/hdb5/boot/vmlinuz
       intrid=/hdb5/boot/intrid.gz
       label="knoppix"
       root=/dev/hdb5
       append="can't remember what i put here"
    Pay attention to the image+initrd entries, make sure these files exist, run "lilo -v" and watch out for possible error messages. But this should work, I think.

  3. #3
    Junior Member
    Join Date
    Mar 2003
    Posts
    9
    thanks for the quick response. I'll give that a go when i get home, and post how i get on

    Cheers

  4. #4
    Junior Member
    Join Date
    Mar 2003
    Posts
    9
    still can't get it. Maybe someone can help me out again

    here is my lilo.conf(remember its a md 9.2)
    Code:
    boot=/dev/hda
    map=/boot/map
    install=menu
    vga=normal
    default="windows"
    keytable=/boot/uk.klt
    prompt
    nowarn
    timeout=100
    message=/boot/message
    menu-scheme=wb:bw:wb:bw
    image=/boot/vmlinuz
    	label="linux"
    	root=/dev/hda5
    	initrd=/boot/initrd.img
    	append="devfs=mount hdd=ide-scsi acpi=ht splash=silent"
    	vga=788
    	read-only
    image=/dev/hdb5/vmlinuz
    	label="knoppix"
      	root=/dev/hdb5
      	initrd=/dev/hdb5/boot/initrd.gz
      	append="apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi nomce"
    	vga=791
    image=/boot/vmlinuz
    	label="linux-nonfb"
    	root=/dev/hda5
    	initrd=/boot/initrd.img
    	append="devfs=mount hdd=ide-scsi acpi=ht"
    	read-only
    image=/boot/vmlinuz
    	label="failsafe"
    	root=/dev/hda5
    	initrd=/boot/initrd.img
    	append="failsafe devfs=nomount hdd=ide-scsi acpi=ht"
    	read-only
    other=/dev/hda1
    	label="windows"
    	table=/dev/hda
    other=/dev/fd0
    	label="floppy"
    	unsafe
    
    image=/boot/vmlinuz-2.4.22-21mdk
    	label=2422-21
    	root=/dev/hda5
    	read-only
    	optional
    	vga=normal
    	append=" devfs=mount hdd=ide-scsi acpi=ht splash=silent"
    	initrd=/boot/initrd-2.4.22-21mdk.img
    Then i run lilo -v and get this
    Code:
    [root@localhost brian]# lilo -v
    LILO version 22.5.7.2, Copyright (C) 1992-1998 Werner Almesberger
    Development beyond version 21 Copyright (C) 1999-2003 John Coffman
    Released 20-Aug-2003, and compiled at 16:45:54 on Sep 18 2003
    
    Reading boot sector from /dev/hda
    Using MENU secondary loader
    Calling map_insert_data
    Mapping message file /boot/message -> message-text
    Calling map_insert_file
    
    Boot image: /boot/vmlinuz -> vmlinuz-2.4.22-21mdk
    Mapping RAM disk /boot/initrd.img -> initrd-2.4.22-21mdk.img
    Added linux
    
    Boot image: /dev/hdb5/vmlinuz
    Fatal: open /dev/hdb5/vmlinuz: Not a directory
    and lastly just for detail files for / and /boot (but not doubt someone already knows these
    Code:
    [root@localhost brian]# ls /mnt/hdb5
    bin/      cdrom/   dvd/     home/    linboot.img  none/  root/  usr/
    boot/     cdrom1/  etc/     initrd/  lost+found/  opt/   sbin/  var/
    cdaudio/  dev/     floppy/  lib/     mnt/         proc/  tmp/   vmlinuz@
    
    [root@localhost brian]# ls /mnt/hdb5/boot
    boot.0345          debianlilo.bmp@  sarge.bmp@   System.map-2.4.22-xfs
    config-2.4.22-xfs  initrd.gz        sid.bmp@     vmlinuz@
    debian.bmp@        map              System.map@  vmlinuz-2.4.22-xfs
    again thanks

  5. #5
    Junior Member
    Join Date
    Mar 2003
    Posts
    9
    managed to get it, forgot to set the paths according to where they were mounted in mandrake

    eg. /mnt/hdb5/vmlinuz

    cheers

Similar Threads

  1. probs w/ lilo, "no OS"
    By purpleturnip in forum Hdd Install / Debian / Apt
    Replies: 3
    Last Post: 04-18-2005, 01:17 AM
  2. Reinstall lilo to hda, using hda lilo.conf and knoppix live
    By tomjermy in forum Hardware & Booting
    Replies: 1
    Last Post: 03-17-2005, 01:07 AM
  3. probs with SB Live!
    By beetlebz in forum Hardware & Booting
    Replies: 1
    Last Post: 06-16-2003, 01:41 AM
  4. (La)TeX-probs
    By jochen in forum General Support
    Replies: 0
    Last Post: 04-16-2003, 01:04 PM
  5. some serious probs with knoppix!
    By knoppers in forum General Support
    Replies: 4
    Last Post: 01-31-2003, 05:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •