Results 1 to 3 of 3

Thread: smbmount and Windows 2000 network

  1. #1
    Junior Member
    Join Date
    Jun 2003
    Posts
    8

    smbmount and Windows 2000 network

    Hi All,

    Until recently, I could mount a share on our Windows NT file server with

    smbmount //fileserver/myshare$ /mymountpoint -o username=gdb,fmask666

    Now everything is moved to a new server with Windows 2000, and also a new group concept. I tried all possible variations of above, but it just does not work. Mostly, it complains about a 'bad username/password pair', however under my Windows NT workstation it still works perfectly. A few variations I tried:

    smbmount //fileserver/myshare$ /mymountpoint -o username=gdb,fmask666

    smbmount //fileserver/myshare$ /mymountpoint -o username=group/gdb,fmask666

    smbmount //fileserver/myshare$ /mymountpoint -o username=group\gdb,fmask666

    smbmount //fileserver/myshare$ /mymountpoint -o username=gdb@group,fmask666

    etc.

    And also variations where I try to escape the '/' and the '\'. It just does not work. My network administrator assisted me, but could not work it out too (he is an incognito Linux fan administrating a Windows Network...)

    Anybody any idea? Problems with active directory? Version incompatiblities?

    GdB

  2. #2
    Senior Member
    Join Date
    Oct 2003
    Location
    Sydney, Australia
    Posts
    157
    Hi GdB

    These are really just guesses, but....

    Check the logs for error messages. I was trying to get samba working recently, and found tons of errors being generated by samba. It seems there was a bug in the version that came with Knoppix - 3.0.0beta2-1. I apt-get'ed a later version (I have installed Knoppix onto hard disk) and it started working.

    Does the move from NT to W2K have anything to do with the encryption of passwords? I seem to recall that earlier versions of Windows used unencrypted passwords, and later versions used encrypted ones. Maybe you are mixing encrypted with unencrypted?

    Also, a quick flick through the smbmount man page mentioned an option 'krb Use kerberos (Active Directory)'. Maybe you need to use this?

    THO

  3. #3
    Junior Member
    Join Date
    Jun 2003
    Posts
    8


    Shame on me...

    RTFM:
    man smbmount shows how to use one's group account : username=gdb/groupX
    (Am I really so stupid that I overlooked this combination?)

    It works now....



Similar Threads

  1. Network Windows 2000 login
    By Mo281282 in forum Networking
    Replies: 0
    Last Post: 02-19-2005, 10:36 PM
  2. Networking on Windows 2000 - help!
    By JLocke in forum Networking
    Replies: 0
    Last Post: 03-01-2004, 12:06 AM
  3. How to install WINDOWS 2000 besides LINUX and WINDOWS 98
    By legal in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 01-15-2004, 04:33 PM
  4. Using Windows 2000 boot manager?
    By Termina in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 01-09-2004, 08:15 AM
  5. windows 2000 Pro & qtpated
    By mailman42 in forum General Support
    Replies: 3
    Last Post: 08-20-2003, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •