Results 1 to 2 of 2

Thread: Major screwed up kernel recompile

  1. #1
    Junior Member registered user
    Join Date
    Jan 2004

    Major screwed up kernel recompile


    I must have really screwed something up because I attempted to compile the latest 2.4 kernel so I could get XFree 4.3 working in hardware 3D mode with my S3 Savage card. I tried to compile the 2.4-22-xfs kernel that comes with Knoppix, but I get an error about __cmpchg being defined twice. A user on the DRI mailing list suggested I use the latest 2.4 from because he thought the error was caused by a Knoppix customization. In any case, the 2.4-24 compiles fine on my computer using the Debian way of 'make-kpkg'. I then install it into lilo and reboot. I choose the new selection Linux2.4-24 and it starts to boot. Everything is proceeding normally but eventually, the screen is flooded with error messages that all say something about fork.c (line 139 I think). I get thrown to a login prompt and logging in as root works, but bash is so badly broken any command I type gives me the same fork.c error message. I notice my computer name is none instead of what it should be so it looks like the boot process breaks down somewhere in the networking part.

    I have / on /dev/sdf8 and it is formatted as reiserfs. I have recompiled numerous times trying to compile things into the kernel instead of modules, but I always get the same problem. I have an all SCSI system using two SYmbios 8xx based cards so I compiled this into the kernel. My network is the builtin SIS900 chip on my K7S5A motherboard so I compiled this into the kernel. I know I am missing something stupid, but what is it?

    I have no messages to help in /var/log because I assume the system kernel is broken so badly that logging is not operational yet.

    Can anyone help me out of my stupidity?

  2. #2
    Junior Member registered user
    Join Date
    Jan 2004

    followup on compile problem

    I tried some more things tonight. I compiled without an initrd to have the kernel boot off my reiserfs / partition since I read some people say they had more success this way. This is when I get the jillion error messages about fork.c. They start right after the
    INIT version 2.78-knoppix booting message. I am wondering if this is due to not recompiling ash against my new kernel. So I set out to compile ash from Klaus's sources and it will not compile on my machine. It gets stuck trying to compile insmod.c.

    So I reran make xconfig and reenabled initrd and then did another make-kpkg clean and make-kpkg --initrd kernel-image modules_image and then installed them with dpkg. I modified lilo.conf to get a second selection kernel 2.4.24 using the new vmlinuz and initrd.2.4.24. Now when the computer boots, it gets past the INIT line and starts to boot but gets hung with this message
    Kernel BUG buffer.c2571
    invalid operand

    I cannot find any reference to this error message anywhere. I found a few references to this type of error but it always pointed to a different line number of buffer.c. So, I am stuck and cannot get either kernel compile method to work. Anyone have any ideas about either getting ash to compile or what might be wrong with the kernel panic during boot?

    Thank goodness I have not totally hosed up the original 2.4.22-xfs kernel and I can still boot the machine choosing that in lilo.

Similar Threads

  1. Remastering --- how to recompile kernel ?
    By chris-ukl in forum Customising & Remastering
    Replies: 0
    Last Post: 03-30-2005, 11:04 AM
  2. installed 3.4/recompile kernel problems
    By keyvisuals in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 05-17-2004, 04:38 PM
  3. I can't recompile kernel 2.4.22-xfs
    By tmp001 in forum General Support
    Replies: 0
    Last Post: 04-28-2004, 11:48 AM
  4. recompile kernel
    By BoopaMagal in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 03-24-2004, 12:03 PM
  5. How to recompile Knoppix 3.2 kernel for MPPE support
    By Vermyndax in forum General Support
    Replies: 5
    Last Post: 12-05-2003, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Lenovo ThinkPad 11e Chromebook 1st Gen 11.6

Lenovo ThinkPad 11e Chromebook 1st Gen 11.6" Laptop | 16GB SSD | Chrome OS


Lenovo Yoga 11e 11.6

Lenovo Yoga 11e 11.6" Touch Laptop Intel 1.83GHz 4GB RAM 128GB SSD Windows 10


Lenovo - Ideapad 3 15 15.6

Lenovo - Ideapad 3 15 15.6" Touch-Screen Laptop - Intel Core i3 - 8GB Memory ...


Lenovo - Chromebook 3 11

Lenovo - Chromebook 3 11" Chromebook - AMD A6 - 4GB Memory - 32GB eMMC Flash ...


Lenovo ThinkPad Laptop Computer 11.6

Lenovo ThinkPad Laptop Computer 11.6" 4GB RAM 320GB HDD Windows 10 HDMI Webcam


Lenovo - IdeaPad Gaming 3 15

Lenovo - IdeaPad Gaming 3 15" Laptop - AMD Ryzen 5 5600H - NVIDIA GeForce GTX...


Lenovo IdeaPad 5 15.6

Lenovo IdeaPad 5 15.6" Notebook AMD Ryzen 7-4700U 8GB RAM 1TB HDD 128GB SSD Grey


Lenovo IdeaPad 5 Intel Laptop, 15.6

Lenovo IdeaPad 5 Intel Laptop, 15.6" FHD IPS Touch 300 nits, i7-1165G7


Lenovo ThinkPad x131e Chromebook 11.6

Lenovo ThinkPad x131e Chromebook 11.6" 1.5GHz 4GB RAM 16GB SSD WEBCAM FAST


Lenovo ThinkPad E530 15.6

Lenovo ThinkPad E530 15.6" Laptop Intel Core i3 2.3GHz 4GB 250GB Windows 10