Results 1 to 8 of 8

Thread: Turning Xserver on and off?

  1. #1
    Junior Member
    Join Date
    Feb 2004
    Posts
    8

    Turning Xserver on and off?

    I'm trying to install nvidia drivers on a Hdd Insatllation so i can run games with 3d graphics. I'm running version 3.3 2003-11-14. I get an error message that goes like this:

    You appear to be running an X server: please exit X before installing.

    So my question for you guys is how do you exit X and then 'enter' X after installation. I'm hoping this is simple enough for some one to explain to me in baby talk(very new to all this).

    Thank you.

  2. #2
    Senior Member registered user
    Join Date
    Jan 2004
    Location
    Paris, France
    Posts
    203

    X server off

    Knoppix is a bit idiosyncratic in this due to its liveCd origin.

    When linux boots it goes through different levels ... usually the graphical interface starts (if at all) in RL 5 ...
    However for reasons of boot speed and quite a few other good reasons on the live CD it starts at RL2 in knoppix.

    To quickly disable it you need to stop the process which is restarting it.
    This is /etc/init.d/gdm (or dm)
    you can stop a service with
    <servicename> stop (and while were at it start and restart work too)

    However this is more a longer term thing than just installing nvidia.
    The Cd is designed so when you quit X it executes a shutdown, but this is undesirable on an installed system....

    I think if you do the dm stop and then CTRL+ALT+BKSPC it should just dump you at a login prompt.
    However you might want to make it so it defaults to only starting X when you want!
    To do this you can delete or rename the files in the rc.d directories.
    (renaming is usually better)
    so in rc2.d is a file called dm (of gdm)
    Actually its not a file its a link to the ../init.d/dm
    these start off with a S (for service) and a number. the number is the order in which they execute.
    For your purpose anything BUT an S or K at the front is ignored so
    if you mv /etc/rc2.d/Sxxdm to /etc/rc2.d/_Sxxdm it will be ignored.
    You can do the same in rc3 and rc4 directories then it will only start in RL5.

    Then you can just change runlevel to stop X. (telinit 3)

  3. #3
    Senior Member registered user
    Join Date
    Nov 2003
    Posts
    361

    Re: X server off

    Quote Originally Posted by gowator
    To quickly disable it you need to stop the process which is restarting it.
    This is /etc/init.d/gdm (or dm)
    you can stop a service with
    <servicename> stop (and while were at it start and restart work too)
    Knoppix uses kdm by default so that would be:
    Code:
    /etc/init.d/kdm stop

  4. #4
    Junior Member
    Join Date
    Feb 2004
    Posts
    8
    First i'd like to say i appreciate your efforts in helping me. I tried running both of your scripts in Konsole and shell without any results.

    I am the dirtiest of noobs, so no wonder i got no where. Is it possible to dumb these instructions down several shades? Or will i need to put some time in raising my I.Q?

    To give you an idea where i am: i can locate the the kdm files you speak of and i can access the etc directory in konsole, but i can go no further.

  5. #5
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    Quote Originally Posted by Juggerboo
    First i'd like to say i appreciate your efforts in helping me. I tried running both of your scripts in Konsole and shell without any results.

    I am the dirtiest of noobs, so no wonder i got no where. Is it possible to dumb these instructions down several shades? Or will i need to put some time in raising my I.Q?

    To give you an idea where i am: i can locate the the kdm files you speak of and i can access the etc directory in konsole, but i can go no further.
    Ok really easy steps.

    Code:
    1. From the KDE login screen choose console login from the Menu option.
    2. Login as normal user then type in su then enter key type in root password and enter key once again.
    3. Type in /etc/init.d/kdm stop and then enter key to stop the X server.
    Then you can change to the directory you have the Nvidia installer and run it then make the required change to the necessary files and use /etc/init.d/kdm restart to get a new login screen using the new driver. Or you can follow these steps from the same console as root if you have internet access and do all that automatically.
    Code:
    wget http://www.kano.mipooh.net/install-n...5336-debian.sh
    chmod +x install-nvidia-5336-debian.sh
    ./install-nvidia-5336-debian.sh
    Change the 5336 in the lines for 4496 or 4620 if you want to use those drivers instead of the newest version.

  6. #6
    Junior Member
    Join Date
    Feb 2004
    Posts
    8
    The scripting for stopping the Xserver did and didn't work. It stopped K desktop, but i still couldn't install the nVidia drivers.

    So i moved on to the kano website scripting, and fumbled my way through till i decided to install it all by pressing alt-ctrl-F1...........and WHOOOHOOO!!

    Worked like a charm my man! I was playing Enemy Territory in seconds!

    Thank you very much for your patience. I appreciate it very much!

  7. #7
    Junior Member registered user
    Join Date
    Nov 2003
    Posts
    25
    Stephen,
    Could you please look at the problem explained at http://www.knoppix.net/forum/viewtopic.php?t=8382 and give us the benefit of your expert opinion. Any assistance you can give us will be greatly appreciated.

  8. #8
    Junior Member
    Join Date
    Mar 2004
    Posts
    3
    oh wow, i could shutdown xserver

    as root:
    /etc/init.d/kdm stop
    telinit 3


    rest didnt work (so easy), but this did well

    thx

    [edit] p.s. i used telinit 5 to start xserver again [/edit]

Similar Threads

  1. Turning off hardwaredetection in hd-installation of 3.7
    By kuki69 in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 01-07-2005, 08:45 PM
  2. Infomation Technology turning into business...
    By chris-harry in forum The Lounge
    Replies: 9
    Last Post: 12-22-2004, 11:17 AM
  3. turning up the volume
    By stedy in forum Hardware & Booting
    Replies: 6
    Last Post: 05-07-2004, 02:40 PM
  4. Turning apache on during CD boot
    By jmassengill in forum Customising & Remastering
    Replies: 5
    Last Post: 04-14-2004, 03:38 AM
  5. Turning My Machine Off
    By beforewisdom in forum General Support
    Replies: 6
    Last Post: 06-11-2003, 12:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •