Results 1 to 7 of 7

Thread: Knoppix V3.3-2004-02-16 disapointed after install.

  1. #1
    Junior Member
    Join Date
    Mar 2004
    Posts
    7

    Knoppix V3.3-2004-02-16 disapointed after install.

    Last week after had been very impressed by this distro that is knoppix, I decided to install it on my hard drive. What was my surprise (after an install with the help of a tutorial) when I saw that al the good features where gone.

    Where is the southing voice saying "Now initializing..." during the boot ?
    Where is the sound when I log-on as a user?
    Where is the beautifull screen that shows during all the loading process?
    Where is the wallpaper from the cd install ?
    Where is the auto detection of my USB key on hot plug?
    The fstab is just messy after the install, it mounts so many drives in my /mnt folder.
    And most of all where is my wireless connection which was ready to use with the cd?

    All of these features seem like poudre through the eyes but, it was one of the reason I gave up with my Suse 9.0. I thought it was pretty cool to have them and don't understand why they were kicked out on the HD install.

    Beside these reclaims, so far I enjoy this distro very rich of features and painless to operate especially since i'm able to use Kdevelop.
    The only big remark i have is WHY there is no firewall easy to use embeded with the distro?

    So, a big thank you to the Knoppix people and guys behind the scene who had made possible this distro.

    (If somebody has clues to restore on my HD all the above features, the boot stuffs and sounds, my harms are wide open).

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    For the usb stuff, open /etc/fstab

    and remove any hashes # in front of any drives you want to be mountable.

    My usb entry looks like:

    /dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000 0 0


    For the sound, try clicking on Kmix in the Kmenu, right clicking on the icon which appears in the taskbar and selecting "Show Mixer Window" and crank the volumes up.

  3. #3
    Junior Member
    Join Date
    Mar 2004
    Posts
    7
    Quote Originally Posted by fingers99
    For the usb stuff, open /etc/fstab

    and remove any hashes # in front of any drives you want to be mountable.

    My usb entry looks like:

    /dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000 0 0


    For the sound, try clicking on Kmix in the Kmenu, right clicking on the icon which appears in the taskbar and selecting "Show Mixer Window" and crank the volumes up.

    Thanks, but I allready deal with my fstab file, and for the sound I did that but still no sound on start up when KDE initialized.

  4. #4
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    Where is the auto detection of my USB key on hot plug?
    Are you sure it's not being detected? If you insert a card and do

    mount -t vfat /dev/sda1 /mnt

    and cd to mnt are your files there? If so, you just need to add your user to the relevant group (you can use the user knoppix as an example).

    For the other, try (as root) /etc/init.d/alsa-autoconfig

  5. #5
    Junior Member
    Join Date
    Mar 2004
    Posts
    7
    I tried your code for the sound without any result.
    For the USB key what I meant was it not automount when hot plugged-in.

    Thanks anyway.

  6. #6
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    I tried your code for the sound without any result.
    And without error messages?

    Try editing the line in /etc/fstab to read:

    /dev/sda1 /mnt/sda1 vfat auto,users,exec,umask=000 0 0

    You may need to do

    mount -a

    to get it to work without a reboot.

    (Never tried it -- I don't generally like things being automounted ) but there's a lot of stuff on this you can find by doing

    man mount

    or

    man fstab

    make sure you're a member of the disk and usb group.

  7. #7
    Junior Member
    Join Date
    Mar 2004
    Posts
    7
    Quote Originally Posted by fingers99
    Try editing the line in /etc/fstab to read:

    /dev/sda1 /mnt/sda1 vfat auto,users,exec,umask=000 0 0
    I think by doing that it will automount each time I boot weither or not I have the USB key plugged.

Similar Threads

  1. Knoppix v 3.6-2004-08-16 Bug #4
    By Calvi Risorta in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 09-27-2004, 08:02 PM
  2. Knoppix 3.4 17/5/2004 Run from CD Install onto hard drive??
    By snakerbat in forum General Support
    Replies: 7
    Last Post: 09-04-2004, 12:26 AM
  3. Knoppix 3.3 on cover CD of APC May 2004
    By JeniSkunk in forum General Support
    Replies: 2
    Last Post: 05-08-2004, 12:50 AM
  4. 02/09/2004 HD Install and captive-NTFS working?
    By Durand Hicks in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 02-22-2004, 11:32 PM
  5. Knoppix 3.3-2004.02.09 and clock setting
    By lmd in forum General Support
    Replies: 0
    Last Post: 02-13-2004, 12:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •