Results 1 to 10 of 10

Thread: help Initializing DMA for faster DVD playback

  1. #1
    Junior Member registered user
    Join Date
    Feb 2003
    Posts
    17

    help Initializing DMA for faster DVD playback

    I found on http://www.knoppix.net/docs/index.php/FaqUsing

    how to turn on the DMA so that the DVD could playback faster.
    it works incredibly pretty smooth.

    However I dont want to have to type in

    /sbin/hdparm -d 1 /dev/hdc

    as root every time I want to watch a DVD.

    the article mentions putting the command into a startup

    /etc/initab

    ....I don't have /etc/initab on my system

    Can someone walk me through the steps.

    1. Exactly which start up script should I put this command into

    2. What command should I put in? ( the article says to use /sbin/hdparm -d 1
    but that doesn't seem right, wouldnt using /sbin/hdparm -d 1 /dev/hdc
    in the script be correct?

    please help.
    Luis

    PS Ive found this forum to be definitly one of the better ones for help. Keep up the great work!!![/b]

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353
    I'm really sorry. I wrote the dvd howto and I made a spelling error. You should make the additions not to /etc/initab but to /etc/inittab.

    I've fixed the howto. Hopefully this should work. Thanks for finding the mistake!

  3. #3
    Junior Member registered user
    Join Date
    Feb 2003
    Posts
    17
    Thank you for the update,

    what about the actual command?

    should it be

    /sbin/hdparm -d 1 /dev/hdc

    or

    /sbin/hdparm -d 1

  4. #4
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353
    It should be the first one:

    /sbin/hdparm -d 1 /dev/hdc

    When you reboot use /sbin/hdparm -d /dev/hdc to check make sure it enabled dma.

    This should work. Please post back results.

    Thanks

  5. #5
    Junior Member registered user
    Join Date
    Feb 2003
    Posts
    17
    Nope it didnt work

    here are the first lines of my /etc/inittab
    -----------------------------------------------------------------------
    # /etc/inittab: init(8) configuration.
    # $Id: inittab,v 1.9 2001/05/31 10:37:50 knopper Exp $

    # The default runlevel.
    id:5:initdefault:

    /sbin/hdparm -d 1 /dev/hdc

    # Boot-time system configuration/initialization script.
    # This is run first except when booting in emergency (-b) mode.
    si::sysinit:/etc/init.d/rcS
    -----------------------------------------------------------------------

    Also on boot up I notice there is a message saying something that
    line 7 in etc/inittab is too long only 4 characters are allowed.

    Line 7 is the /sbin/hdparm -d 1 /dev/hdc command.

    After I logged in I did /sbin/hdparm -d /dev/hdc

    here are the results

    luis@Sphinux:~$ /sbin/hdparm -d /dev/hdc

    /dev/hdc:
    using_dma = 0 (off)


    but if I type in the command in root it makes the changes

    any other ideas?

  6. #6
    Junior Member registered user
    Join Date
    Feb 2003
    Posts
    17
    I found this on a page about debian on thinkpads

    In order to get decent playback performance out of the DVD drive, I ran: hdparm -d 1
    /dev/hdc and also put this in a startup script:

    #!/bin/sh
    #
    # dmadvd - enable dma transfer on cd/dvd
    #
    # 2002-12-30,jtk

    case $1 in

    start)
    echo "Enabling DMA on CD/DVD drive..."
    hdparm -d 1 /dev/hdc
    ;;

    stop)
    echo "Disabling DMA on CD/DVD drive..."
    hdparm -d 0 /dev/hdc
    ;;

    *)
    echo "Usage: $0 {start|stop}"
    exit 1
    ;;

    esac
    exit 0


    any idea which startup script I should put this into?
    luis

  7. #7
    Senior Member registered user
    Join Date
    Jan 2003
    Location
    Podunk, Idaho, USA
    Posts
    470
    I take it you're running a hd install. Save the DVD startup script in /etc/init.d as DVD.sh (or ???) then chmod it executable, then make a startup link in rc5.d to the DVD script in /etc/init.d:

    ln -s /etc/init.d/DVD.sh /etc/rc5.d/S99DVD

    then the DVD hdparm script will be loaded when you start in runlevel 5 near the end of the startup.

    (Make sure to use the proper device, that your DVD is /dev/hdc)

    HTH

    rock

  8. #8
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    The settings for turning on DMA are at the bottom of the /etc/init.d/bootmisc.sh script at least on my system just uncomment the line for the DVD device or add a new one if is not there. BTW the proper syntax is hdparm -d1 no space between.

  9. #9
    Junior Member registered user
    Join Date
    Feb 2003
    Posts
    17
    Thank you so much,

    your suggestion about /etc/init.d/bootmisc.sh worked perfectly!!!

    dma is autoloaded now.

    thanks again
    Luis

  10. #10
    Senior Member registered user
    Join Date
    Nov 2002
    Posts
    1,353
    Thanks for the feedback. I've changed the howto and given /etc/init.d/bootmisc.sh as an example of where to enable dma for one's dvd.

Similar Threads

  1. DVD playback with Knoppix
    By Honkeychops in forum Hardware & Booting
    Replies: 0
    Last Post: 02-13-2005, 05:04 AM
  2. Knoppix 3.4 Freezes during initializing peripherals
    By Aldago in forum General Support
    Replies: 3
    Last Post: 10-01-2004, 07:11 PM
  3. DVD playback howto
    By mzilikazi in forum General Support
    Replies: 0
    Last Post: 07-28-2004, 08:36 PM
  4. Poor DVD Playback
    By javahyper7 in forum General Support
    Replies: 0
    Last Post: 06-22-2004, 03:52 AM
  5. Initializing periferals halt...
    By Myth in forum General Support
    Replies: 5
    Last Post: 05-14-2004, 04:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •