Results 1 to 5 of 5

Thread: Normal Users can't access windows partitions

  1. #1
    Junior Member
    Join Date
    Mar 2004
    Posts
    1

    Normal Users can't access windows partitions

    Hello,

    I installed Knoppix on my harddisk.
    Now I have the problem, that only the Admin (/root) can access the windows-partitions.
    I've modified the fstab and mtab, but my changes have no effects. (i added the mount-option
    users for example)
    Is the problem the autoconfig-routine?

    Had anyone a solution for my problem?

    Thanks
    Mario

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    Please post /etc/fstab. But a more likely issue is the permissions for the directory on which the partition is mounted. User, Group and Others need permission to Show Entries and to Enter.

  3. #3
    Junior Member registered user
    Join Date
    Mar 2004
    Posts
    13
    Changing the mountpoint's permissions doesn't help for vfat. You have to change the fstab. vfat knows the options uid,gid and umask.

    The easiest way to get user-access would be to add umask=777. However, that's quite unsafe, everybody can browse/read/write everything. If you have important data on that partition, you should

    - create a new user-group
    - add all users that are allowed to access the partition to that group
    - mount the partition with "defaults,gid=x,umask=007". You have to replace x with the gid of the group you have created (--> cat /etc/group|less).

  4. #4
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    Disagree. Given that you want only one user to have access, the easiest solution is to have the mountpoint in that user's home directory!

  5. #5
    Junior Member registered user
    Join Date
    Mar 2004
    Posts
    13
    I'm not quite sure what you mean. Changing the mountpoint (it's location) won't help. By default, only root has r/w access to vfat-partitions, no matter where it is mounted. You have to give users r/w access by using those options in the fstab. I know changing the mountpoint's permissions (the directory when not mounted) helps for native Linux-partitions (ext2/reiserfs ...), but not for vfat. That's because vfat doesn't handle permissions, so every file get's the same permissions, no matter what. That's set by the umask=... options in the fstab.

    At least that's what worked for me.

Similar Threads

  1. Limit Users Access to Folders?
    By GoP-Demon in forum General Support
    Replies: 1
    Last Post: 06-01-2005, 02:22 AM
  2. Users can't access secondary hd
    By Degman in forum General Support
    Replies: 3
    Last Post: 08-10-2004, 07:06 PM
  3. creating remote access CD for roaming users
    By mikesb in forum Customising & Remastering
    Replies: 3
    Last Post: 12-27-2003, 07:48 AM
  4. help Give users root access
    By warpedmind in forum General Support
    Replies: 12
    Last Post: 11-19-2003, 12:10 AM
  5. Granting ordinary users access to another partition?
    By athlonthunder in forum General Support
    Replies: 2
    Last Post: 04-06-2003, 06:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •