Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: ATMEL based wireless cards

  1. #1
    Junior Member
    Join Date
    Feb 2003
    Posts
    4

    ATMEL based wireless cards

    I got the 01-01-2003 release of Knoppix. I have got an "EpoX EWL-C100" (ATMEL/RFMD based Wireless Network PC-Card) and remastered Knoppix with the newest drivers. Everything works quite fine, but if I plug in the card the modules don't load, because it says:
    module was built for kernel 2.4.19 this kernel is 2.4.20-xfs: can't load

    I also got the sources for kernel 2.4.20 and patched it with xfs-support and the knoppix-patch.

    I compiled the drivers again, but the problem is still the same.

    Does anybody know how to solve it?

    Thanks, seyring

  2. #2
    Junior Member
    Join Date
    Feb 2003
    Posts
    4

    ATMEL based wireless cards

    The drivers and information for atmel based wireless cards (pci, pcmcia & usb) can be found here http://atmelwlandriver.sourceforge.net

  3. #3
    Junior Member
    Join Date
    Mar 2003
    Posts
    8
    Hi there,

    I am also hoping that Atmel-cards are supported in 3.2 !!!! Just a few days (I hope)..........

    Patrick

  4. #4
    Junior Member
    Join Date
    Mar 2003
    Posts
    6
    Quote Originally Posted by patmad
    Hi there,

    I am also hoping that Atmel-cards are supported in 3.2 !!!! Just a few days (I hope)..........

    Patrick


    same here, need wireless support and the update with the config save ability to multiple devices

  5. #5
    Junior Member
    Join Date
    Mar 2003
    Posts
    4

    dlink dwl-120

    bad luck,

    the dlink dwl-120 is still not supported in KNOPPIX_V3.2-2003-03-21b-EN.

    ATMEL AT76C503A based usb devices:
    15 DLink DWL-120 MXF-WL280 0x03eb 0x7603 AT76C503A 3861 Yes Yes yes.

    the card is not recognized yet

  6. #6
    Junior Member
    Join Date
    Mar 2003
    Posts
    6

    Re: dlink dwl-120

    Quote Originally Posted by sjoerd
    bad luck,

    the dlink dwl-120 is still not supported in KNOPPIX_V3.2-2003-03-21b-EN.

    ATMEL AT76C503A based usb devices:
    15 DLink DWL-120 MXF-WL280 0x03eb 0x7603 AT76C503A 3861 Yes Yes yes.

    the card is not recognized yet

    NEW UPDATE!

    CROSSING MY FINGERS THIS ONE HAS ATMEL!!

    * V3.2-2003-03-23 (small updates)
    - new PCMCIA wireless card entries
    - wavelan-ng-modules is back (forgot that in the previous release)
    - removed some older/unneeded gnome libraries
    - kdevelop seems to create KDE applications again after updating
    some KDE-packages from unstable.

    If someone is able to download and check this before I do, please reply here and let me and others know if it has ATMEL one way or the other.

  7. #7
    Junior Member
    Join Date
    Mar 2003
    Posts
    8


    Alas, my pcmcia-Atmel card (502A-D) is not supported in KNOPPIX_V3.2-2003-03-30-EN....

    Has anyone yet succeeded in getting these wlan-cards working?

    patrick

  8. #8
    Junior Member
    Join Date
    Mar 2003
    Posts
    8
    Hi, I'm still trying to get my ATMEL AT76C502AR_D wireless card working.

    I got it so far that it is recognized when plugged in


    root@knoppix-box:~# dump_cis
    Socket 0:
    attr_dev_info
    fn_specific 250ns, 2kb
    manfid 0x0000, 0x0000
    funcid network_adapter
    vers_1 5.0, "ATMEL", "AT76C502AR_D"
    config base 0x0800 mask 0x0001 last_index 0x02
    cftable_entry 0x01 [default]
    [mwait] [pwrdown]
    Vcc Vnom 3300mV Iavg 250mA Ipeak 250mA Idown 25mA
    timing wait 12us
    io 0x0000-0x001f [lines=5] [16bit]
    irq mask 0xffb8
    root@knoppix-box:~#


    but when installing it I get these messages


    Code:
    root@knoppix-box:~/atmelwlandriver# make config
    Build all (y/n) : n
    Kernel Version Running 2.4.20-xfs
    Found Kernel Source Directory ()
    Build Debug version (y/n) : y
    Set extra module version information (y/n) : y
    Build USB Drivers (y/n) : n
    Build PCMCIA Drivers (y/n) : y
    Build PCMCIA rfmd Driver (y/n) : y
    Build PCMCIA 3COM Driver (y/n) : n
    Build PCMCIA rfmd revision d Driver (y/n) : y
    Build PCMCIA rfmd revision e Driver (y/n) : n
    Build PCMCIA 504 Driver (y/n) : n
    Build miniPCI Driver (y/n) : n
    Build applications (y/n) : y
    Build command line application (y/n) : y
    You have to install the xforms library in order to use the xvnet application
    Finished. Now run make clean, all, install
    root@knoppix-box:~/atmelwlandriver# make clean
    find -name '*.o' -o -name '*.map' |xargs rm -f
    root@knoppix-box:~/atmelwlandriver# make all
    Building src/Pcmcia_Pci src/apps/cmd_line
    make[1]: Entering directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    PCMCIA yes : rfmdD revdD
    for i in  rfmdD revdD; do make $i; done
    make[2]: Entering directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    make clean
    make[3]: Entering directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    find -name '*.o'|xargs rm -f
    make[3]: Leaving directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    DEBUGORNO=debug.o
    make final CFLAGS:='-I/pcmcia/include -DLINUX_OS -D__KERNEL__ -pipe -O3 -fomit-frame-pointer -fno-strict-aliasing -I/include -I/root/atmelwlandriver/src/includes -I/root/atmelwlandriver/src/includes/pcmcia -Wall -DMODULE -DMODVERSIONS -include /include/linux/modversions.h -DRFMD -DINT_ROAM -DRX_CRC -DPCMCIA_DEBUG=1' MODULE:='pcmf502r.o' LIB:=-RFMD- DEBUGORNO:=debug.o
    make[3]: Entering directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    gcc -I/pcmcia/include -DLINUX_OS -D__KERNEL__ -pipe -O3 -fomit-frame-pointer -fno-strict-aliasing -I/include -I/root/atmelwlandriver/src/includes -I/root/atmelwlandriver/src/includes/pcmcia -Wall -DMODULE -DMODVERSIONS -include /include/linux/modversions.h -DRFMD -DINT_ROAM -DRX_CRC -DPCMCIA_DEBUG=1   -c -o card.o card.c
    card.c: /include/linux/modversions.h: No such file or directory
    In file included from /root/atmelwlandriver/src/includes/pcmcia/vnet.h:28,
                     from card.c:23:
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:56:28: pcmcia/version.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:57:29: pcmcia/cs_types.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:58:23: pcmcia/cs.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:59:27: pcmcia/cistpl.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:60:27: pcmcia/cisreg.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:61:23: pcmcia/ds.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:86:31: linux/modversions.h: No such file or directory
    make[3]: *** [card.o] Error 1
    make[3]: Leaving directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    make[2]: *** [rfmdD] Error 2
    make[2]: Leaving directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    make[2]: Entering directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    make clean
    make[3]: Entering directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    find -name '*.o'|xargs rm -f
    make[3]: Leaving directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    make final CFLAGS:='-I/pcmcia/include -DLINUX_OS -D__KERNEL__ -pipe -O3 -fomit-frame-pointer -fno-strict-aliasing -I/include -I/root/atmelwlandriver/src/includes -I/root/atmelwlandriver/src/includes/pcmcia -Wall -DMODULE -DMODVERSIONS -include /include/linux/modversions.h -DPCMCIA_DEBUG=1 -DRFMD -DINT_ROAM -DRX_CRC -DREV_D' RF:='0' DBG:='1' MODULE:='pcmf502rd.o' LIB:=-REVD- DEBUGORNO:=debug.o
    make[3]: Entering directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    gcc -I/pcmcia/include -DLINUX_OS -D__KERNEL__ -pipe -O3 -fomit-frame-pointer -fno-strict-aliasing -I/include -I/root/atmelwlandriver/src/includes -I/root/atmelwlandriver/src/includes/pcmcia -Wall -DMODULE -DMODVERSIONS -include /include/linux/modversions.h -DPCMCIA_DEBUG=1 -DRFMD -DINT_ROAM -DRX_CRC -DREV_D   -c -o card.o card.c
    card.c: /include/linux/modversions.h: No such file or directory
    In file included from /root/atmelwlandriver/src/includes/pcmcia/vnet.h:28,
                     from card.c:23:
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:56:28: pcmcia/version.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:57:29: pcmcia/cs_types.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:58:23: pcmcia/cs.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:59:27: pcmcia/cistpl.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:60:27: pcmcia/cisreg.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:61:23: pcmcia/ds.h: No such file or directory
    /root/atmelwlandriver/src/includes/pcmcia/vnet_linux.h:86:31: linux/modversions.h: No such file or directory
    make[3]: *** [card.o] Error 1
    make[3]: Leaving directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    make[2]: *** [revdD] Error 2
    make[2]: Leaving directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/root/atmelwlandriver/src/Pcmcia_Pci'
    make[1]: Entering directory `/root/atmelwlandriver/src/apps/cmd_line'
    gcc -DATMEL -O2 -g -I/root/atmelwlandriver/src/includes -o lvnet -lncurses cofvnet.c sets.c bootcnf.c
    make[1]: Leaving directory `/root/atmelwlandriver/src/apps/cmd_line'
    root@knoppix-box:~/atmelwlandriver# make install
    set -x
    depmod -aq
    OK
    
    root@knoppix-box:~/atmelwlandriver# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:50:EB:02:20:94
              inet addr:192.168.0.8  Bcast:192.168.0.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:104240 errors:0 dropped:0 overruns:0 frame:0
              TX packets:75258 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:100
              RX bytes:152516226 (145.4 MiB)  TX bytes:5326221 (5.0 MiB)
              Interrupt:10 Base address:0x4800
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:64 errors:0 dropped:0 overruns:0 frame:0
              TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:4112 (4.0 KiB)  TX bytes:4112 (4.0 KiB)
    As you can see it is not working...


    Has anyone any idea how to fix it? I'm quite a newbie on this, but I'd really like to have it working!

    Thanx

    Patrick

  9. #9
    Junior Member registered user
    Join Date
    May 2003
    Posts
    10
    Quote Originally Posted by patmad
    Hi, I'm still trying to get my ATMEL AT76C502AR_D wireless card working.
    Quote Originally Posted by patmad
    but when installing it I get these messages


    Code:
    root@knoppix-box:~/atmelwlandriver# make config
    Build all (y/n) : n
    Kernel Version Running 2.4.20-xfs
    Found Kernel Source Directory ()
    This is where it goes wrong. You really need to have the kernel sources available with the Atmel driver stuff. Otherwise, it gets confused and can't find any of the headers. I think that the configuration scripts look in /usr/src/linux by default, and when I've done the build on various other distributions, it has successfully located kernel sources in that location.

    Quote Originally Posted by patmad
    Has anyone any idea how to fix it? I'm quite a newbie on this, but I'd really like to have it working!
    It really would be nice if it worked "out of the box" with Knoppix, yes.

  10. #10
    Junior Member
    Join Date
    Mar 2003
    Posts
    8
    Thanks for replying!
    I already thought this could be the problem, so I downloaded the kernel-source-2.4.20-xfs and put it in /usr/src/
    Then I edited .config and pointed the KERNEL_SRC to this map.
    But when I do make install it still shows

    Build all (y/n) : n
    Kernel Version Running 2.4.20-xfs
    Found Kernel Source Directory ()

    and later on I still can see some errors during make all that some file or folder is nowhere to be found.......

    How can I make these sources to be recognized? Do I have to compile the kernel?

    Thanks for helping me making this card work properly!!!

Page 1 of 3 123 LastLast

Similar Threads

  1. Renastered knoppix34 with Atmel USB wireless drivers?
    By dave52355 in forum General Support
    Replies: 2
    Last Post: 06-09-2004, 10:50 PM
  2. Please help, Atmel VNet Wireless USB 802.11
    By dave52355 in forum Networking
    Replies: 0
    Last Post: 05-11-2004, 04:17 PM
  3. wireless cards
    By Philly_Blunt in forum Laptops
    Replies: 6
    Last Post: 01-23-2004, 03:22 PM
  4. Problem with wireless USB adapter Zonet ZEW2000 (Atmel chip)
    By deerwood in forum Hardware & Booting
    Replies: 5
    Last Post: 11-19-2003, 07:31 PM
  5. Replies: 0
    Last Post: 11-19-2003, 07:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •