Results 1 to 2 of 2

Thread: Shutdown: /usr not mounted, illegal seek

  1. #1
    Junior Member
    Join Date
    Apr 2004
    Posts
    1

    Shutdown: /usr not mounted, illegal seek

    I know everyone has probably heard this one but it hasn't been posted in a while so I thought I'd bring the topic back up again to see if anyone has any new answers on it. Using the knx-installer, I install Knoppix to the hard drive (all in the root partition initially since it won't let you install it on individual partitions.) Make sure all the partitions I need have been partitioned and corresponding file systems created. Mount them, copy all of the information using cp -Rp from each directory in / to the actual file system created, rename everything, delete the old directories and edit /etc/fstab to reflect the changes. Reboot the system, everything works great! Now, during the shutdown /usr won't unmount cleanly, I get the above reported error. During boot up of course that file systems journal needs to be recovered every time making for a longer boot time and very annoying problem.

    Knoppix 3.3 using Ext3 file system.

    Anybody have any ideas on how to fix it?

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Location
    colorado springs, colorado
    Posts
    1,933
    I had the same experience and while I don't know how you can fix your current problem it is possible to install to multiple partitions during the install.

    Make your own partitions
    Format the partitions
    sudo knoppix-installer
    Configure installation. (You will have to let the installer choose a large partition until you edit .knofig)
    Quit the installer
    Save your configuration
    sudo mcedit .knofig
    *NOTE* .knofig will be found in the directory it was launched from. Use updatedb and locate .knofig if you can't find it.
    Edit the "HD_MAP=" line and add your preformatted partitions for example:

    HD_MAP="/dev/hda3:/home /dev/hda6:/tmp /dev/hda7:/var /dev/hda14:/usr"

    *DO NOT try to move /boot to its own partition. It won't work.

    HD_IGNORECHECK="yes"
    *Setting HD_IGNORECHECK allows us to install / to a smaller partition.

    HD_CHOICE="/dev/hda1"
    *HD_CHOICE to select a different partition for /

    Save it and relaunch the installer. You DO NOT need to "Load saved configuration" as it will automatically find .knofig. After starting the installation, open another terminal window and issue mount and you should see your partitions mounted for installation.

    This has worked for me many many times. If it doesn't work please retrace your steps. It's easy to have a small error in the steps.

    HTH

Similar Threads

  1. seek Swedish soccer cheers
    By tbg in forum The Lounge
    Replies: 1
    Last Post: 11-02-2004, 02:39 AM
  2. CD Unit not available; cannot be mounted
    By arthur in forum Hardware & Booting
    Replies: 1
    Last Post: 12-04-2003, 01:54 PM
  3. shutdown: not mounted illegal seek
    By zottel in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 08-07-2003, 12:21 AM
  4. Problems with x - Boot-shutdown... Boot-shutdown...Boot-shut
    By _CaLeB_ in forum Hardware & Booting
    Replies: 5
    Last Post: 03-31-2003, 06:20 PM
  5. HDD isn't mounted when using floppyconf :(
    By Plip in forum General Support
    Replies: 2
    Last Post: 03-25-2003, 03:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •