Results 1 to 5 of 5

Thread: Germany keyboard layout without german language?

  1. #1
    Junior Member
    Join Date
    Apr 2004
    Posts
    3

    Germany keyboard layout without german language?

    how do i do this?

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479

    Re: Germany keyboard layout without german language?

    Quote Originally Posted by CSY
    how do i do this?
    It should already be available unless you have changed the defaults by using the flag icon in the lower right corner on the taskbar you should be able to switch on the fly in KDE. If you have changed the defaults then in the KDE Control Center -> Regional & Accessibility -> Keyboard Layout and select the German keyboard to add to the list with the Enable keyboard layouts.

  3. #3
    Junior Member
    Join Date
    Apr 2004
    Posts
    3
    is there a generic way as im using fluxbox for example?

  4. #4
    Senior Member registered user
    Join Date
    Feb 2003
    Posts
    929
    The keyboard is determined by a script.

    /etc/init.d/keymap.sh

    as root, edit the line:

    loadkeys /usr/share/keymaps/i386/qwerty/us.kmap.gz

    (to whatever kmap you want)

    and run

    /etc/init.d/keymap.sh reload

    There's a script (somewhere) which enables you to do this, but I don't know where it is!

  5. #5
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    Quote Originally Posted by CSY
    is there a generic way as im using fluxbox for example?
    Open the file /etc/X11/XF86Config-4 and change layout from the "us" to "de" in the keyboard section then you will have to restart the X server for it to take effect.

    Code:
    Section "InputDevice"
            Identifier  "Keyboard0"
            Driver      "keyboard"
            Option      "CoreKeyboard"
            Option      "XkbRules"      "xfree86"
            Option      "XkbModel"      "pc101"
            Option      "XkbLayout"     "us"
            Option      "XkbOptions"     "crtl:nocaps"
    EndSection

Similar Threads

  1. Change the keyboard language to swiss german?
    By Josh83 in forum General Support
    Replies: 3
    Last Post: 03-04-2005, 01:00 PM
  2. keyboard layout toggle in knoppix 3.6?
    By ocean in forum General Support
    Replies: 0
    Last Post: 11-15-2004, 10:50 PM
  3. Err with KDE Keyboard layout
    By mzruya in forum General Support
    Replies: 0
    Last Post: 05-11-2004, 07:34 PM
  4. Keyboard layout
    By tonyleake in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 03-28-2004, 08:50 PM
  5. default keyboard layout for KDE
    By GuineaPig in forum Customising & Remastering
    Replies: 0
    Last Post: 05-06-2003, 09:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •