Results 1 to 4 of 4

Thread: Can't login to Debian login screen

  1. #1
    Member registered user
    Join Date
    Apr 2004
    Posts
    45

    Can't login to Debian login screen

    I installed Knoppix to my hard drive along with Win XP. I installed LILO to the MBR and it seems to boot to either properly. When Linux completes the boot I get a Debian login screen asking for my user name and password. I enter "root" (without quotes) for the user name and then when I put the root password in I get a login failure message. When I try to login as "koppix" and use the user password the screen blinks for a moment and returns to the login window. What am I missingt?

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479

    Re: Can't login to Debian login screen

    Quote Originally Posted by turbines
    I installed Knoppix to my hard drive along with Win XP. I installed LILO to the MBR and it seems to boot to either properly. When Linux completes the boot I get a Debian login screen asking for my user name and password. I enter "root" (without quotes) for the user name and then when I put the root password in I get a login failure message. When I try to login as "koppix" and use the user password the screen blinks for a moment and returns to the login window. What am I missingt?
    In the menu option at the login screen choose KDE instead of default that is preselected for the session type. BTW you should not be logging in as root if you need root access while running graphically then open a console window (the monitor with a shell on it in the taskbar) and use the su command then enter the root password and you can now do whatever you needed to do as root.

  3. #3
    Senior Member registered user
    Join Date
    Mar 2004
    Posts
    1,516
    or even better
    Code:
    su -c "comand"
    actually the " MUST be there, so for runing vi on /etc/fstab i would do
    su -c "vi /etc/fstab"
    I will then be asked for rootpass.
    the comand and ONLY that will run as root, if i shut it down, it crashes... privileges are lost. so slightly less risk of accidentaly do something bad as root.
    OErjan

  4. #4
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    555
    Perhaps you're not using an English keyboard, and the proper driver hasn't been activated? Check under /etc/console and the XKbLayout entry in your /etc/X11/XF86Config-4 file.

Similar Threads

  1. turning off screen saver / blanking at login screen
    By metavoid in forum General Support
    Replies: 4
    Last Post: 03-12-2005, 01:39 PM
  2. How do you get the login screen?`
    By rrfish72 in forum General Support
    Replies: 2
    Last Post: 08-06-2004, 08:58 AM
  3. Invoking Login Screen ?
    By bhavin in forum General Support
    Replies: 1
    Last Post: 04-16-2004, 12:04 PM
  4. How can I get a Login screen ?
    By anonjoe in forum Networking
    Replies: 0
    Last Post: 10-07-2003, 02:31 PM
  5. KDE Login Screen
    By evermore in forum Customising & Remastering
    Replies: 5
    Last Post: 06-20-2003, 08:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •