Results 1 to 6 of 6

Thread: Goofed kpackage install of something

  1. #1
    Junior Member
    Join Date
    May 2004
    Posts
    7

    Goofed kpackage install of something

    Tried to upgrade some packages with kpackage. It failed part way through . Now KDE does funny things on startup. Missing most of my applications menu on launcher. Shell console and kpackage start up automaticaly on KDE startup; anyway to stop this?. Kpackage is stuck doing something. Have to use xkill to kill it. Have looked up some other posts for similiar problems but havn't been able to figure out how other fixed it. My .kde directory seems to be there still with most of it's contents intact. Couldn't figure out how to keep kpackage or console from starting up on KDE startup. Here is my list of packages showing up as 3.1.***

    ugly list follows:
    COLUMNS=125 dpkg -l | grep 3.1.[345] |less

    ii amor 3.1.5-2 a KDE creature for your desktop
    ii ark 3.1.5-1 KDE archiving tool
    ii atlantik 3.1.5-1 KDE client for Monopoly-like network games
    rc emacs21 21.3+1-4 The GNU Emacs editor
    rc emacs21-common 21.3+1-4 The GNU Emacs editor's common infrastructure.
    ii gawk 3.1.3-2 GNU awk, a pattern scanning and processing language
    ii kaddressbook 3.1.5-1.1 KDE NG addressbook application
    ii kalarm 3.1.5-1.1 KDE alarm message and command scheduler
    ii kamera 3.1.5-1 digital camera io_slave for Konquerer
    ii kandy 3.1.5-1.1 KDE mobile phone utility
    ii kappfinder 3.1.5-2 KDE Application Finder
    ii karm 3.1.5-1.1 KDE time tracker tool
    ii kasteroids 3.1.5-1 Asteroids for KDE
    ii kate 3.1.5-2 KDE Advanced Text Editor
    ii kate-plugins 3.1.5-2 plugins for Kate, the KDE Advanced Text Editor
    ii katomic 3.1.5-1 Atomic Entertainment game for KDE
    ii kbattleship 3.1.5-1 Battleship game for KDE
    ii kbounce 3.1.5-1 Jezzball clone for the K Desktop Environment
    ii kcalc 3.1.5-1 KDE calculator
    ii kcharselect 3.1.5-1 KDE character selector
    ii kcmlinuz 3.1.5-1 KDE Frontend for the Linux kernel configuration
    ii kcontrol 3.1.5-2 KDE Control Center
    ii kcron 3.1.5-1 KDE Crontab editor
    ii kdat 3.1.5-1 KDE tape backup tool
    ii kdeaddons-kfile-plugins 3.1.5-2 KDE file dialog plugins for text files and folders
    ii kdeadmin-kfile-plugins 3.1.5-1 KDE File dialog plugins for deb and rpm files
    ii kdebase-bin 3.1.5-2 KDE Base (binaries)
    ii kdebase-data 3.1.5-2 KDE Base (shared data)
    ii kdebase-kio-plugins 3.1.5-2 KDE I/O Slaves
    ii kdegraphics-kfile-plugins 3.1.5-1 provide meta information for graphic files
    ii kdelibs-data 3.1.5-1 KDE core shared data
    ii kdemultimedia-kfile-plugi 3.1.5-1 au/avi/m3u/mp3/ogg/wav plugins for kfile
    ii kdenetwork-kfile-plugins 3.1.5-1 KFile Email Plugin
    ii kdepasswd 3.1.5-1 KDE password changer
    ii kdepim 3.1.5-1.1 KDE Personal Information Management metapackage
    ii kdepim-kfile-plugins 3.1.5-1.1 KDE File dialog plugins for vcf files.
    ii kdepim-libs 3.1.5-1.1 KDE PIM libraries
    ii kdeprint 3.1.5-2 KDE Print
    ii kdesktop 3.1.5-2 KDE Desktop
    ii kdessh 3.1.5-1 KDE ssh frontend
    ii kdm 3.1.5-2 KDE Display Manager
    ii kdvi 3.1.5-1 KDE dvi viewer
    ii kernel-patch-xfs 1.3.1-3 XFS Filesystem support for Linux 2.4.22, 2.4.23 and 2.4.24
    ii kfax 3.1.5-1 KDE G3/G4 Fax Viewer
    ii kfind 3.1.5-2 KDE File Find Utility
    ii kfloppy 3.1.5-1 KDE floppy formatter
    ii kgeo 3.1.5-2 interactive geometry program for KDE
    ii kget 3.1.5-1 KDE Download Manager
    ii kghostview 3.1.5-1 PostScript viewer for KDE
    ii kgpgcertmanager 3.1.5-1 KDE Certificate Manager
    ii khelpcenter 3.1.5-2 KDE Help Center
    ii khexedit 3.1.5-1 KDE hex editor
    ii kicker 3.1.5-2 KDE Desktop Panel
    ii kiconedit 3.1.5-1 An icon editor for creating KDE icons
    ii klaptopdaemon 3.1.5-1 KDE battery monitoring and management for laptops
    ii klipper 3.1.5-2 KDE Clipboard
    ii kmahjongg 3.1.5-1 the classic mahjongg game for KDE project
    ii kmail 3.1.5-1 KDE Email client
    ii kmailcvt 3.1.5-1 KDE KMail addressbook converter
    ii kmenuedit 3.1.5-2 KDE Menu Editor
    ii kmix 3.1.5-1 KDE based mixer app
    ii knotes 3.1.5-1.1 KDE Notes
    ii kompare 3.1.5-1 a KDE GUI for viewing differences between files
    ii konq-plugins 3.1.5-2 plugins for Konqueror, the KDE file/web/doc browser
    ii konqueror 3.1.5-2 KDE's advanced File Manager, Web Browser and Document Viewer
    ii konqueror-nsplugins 3.1.5-2 Netscape plugin support for Konqueror
    ii konsole 3.1.5-2 KDE X terminal emulator
    ii kooka 3.1.5-1 Scanner program for KDE
    ii korganizer 3.1.5-1.1 KDE personal organizer
    ii kpackage 3.1.5-1 KDE Software package tool
    ii kpager 3.1.5-2 KDE Desktop Pager
    ii kpaint 3.1.5-1 A Simple Paint Program for KDE
    ii kpersonalizer 3.1.5-2 KDE Personalizer
    ii kpf 3.1.5-1 KDE public fileserver
    ii kpilot 3.1.5-1.1 KDE Palm Pilot hot-sync tool
    ii kppp 3.1.5-1 KDE dialer and frontend to pppd
    ii krdc 3.1.5-1 KDE Remote Desktop Client
    ii kreversi 3.1.5-1 Reversi for KDE
    ii krfb 3.1.5-1 KDE Remote Screen Server
    ii kscd 3.1.5-1 KDE based cd player
    ii ksmserver 3.1.5-2 KDE Session Manager
    ii ksnapshot 3.1.5-1 Screenshot application for KDE
    ii ksokoban 3.1.5-1 Sokoban game for KDE
    ii ksplash 3.1.5-2 KDE Splash Screen
    ii kstars 3.1.5-2 desktop planetarium for KDE
    ii ksync 3.1.5-1.1 KDE Sync
    ii ksysv 3.1.5-1 KDE SysV-style init configuration editor
    ii krfb 3.1.5-1 KDE Remote Screen Server
    ii kscd 3.1.5-1 KDE based cd player
    ii ksmserver 3.1.5-2 KDE Session Manager
    ii ksnapshot 3.1.5-1 Screenshot application for KDE
    ii ksokoban 3.1.5-1 Sokoban game for KDE
    ii ksplash 3.1.5-2 KDE Splash Screen
    ii kstars 3.1.5-2 desktop planetarium for KDE
    ii ksync 3.1.5-1.1 KDE Sync
    ii ksysv 3.1.5-1 KDE SysV-style init configuration editor
    ii kteatime 3.1.5-2 KDE utility for making a fine cup of tea
    ii ktimer 3.1.5-1 KDE timer
    ii ktip 3.1.5-2 Kandalf's Useful Tips
    ii kuickshow 3.1.5-1 KDE image/slideshow viewer
    ii kuser 3.1.5-1 KDE user/group administration tool
    ii kview 3.1.5-1 KDE simple image viewer/converter
    ii kviewshell 3.1.5-1 KDE generic framework for viewer applications
    ii kwin 3.1.5-2 KDE Window Manager
    ii kxconfig 3.1.5-1 KDE display configuration tool
    ii less 381-3 Pager program similar to more
    ii libkdegames1 3.1.5-1 KDE games library and common files
    ii libkdenetwork2 3.1.5-1 KDE Network (common libraries)
    ii libkonq4 3.1.5-2 Core libraries for KDE's file manager
    ii libkscan1 3.1.5-1 Scanner library for KDE
    ii libmimelib1 3.1.5-1 KDE network mime library
    ii lisa 3.1.5-1 LAN Information Server
    ii quanta 3.1.5-2 Web Development Environment for KDE
    ii secpolicy 3.1.5-1 KDE PAM security policy configuration tool
    ii vegastrike 0.3.1-5.1 A 3d space combat game
    ii xfonts-konsole 3.1.5-2 Fonts used by the KDE Konsole


    Sorry about that. Here's what maybe the newer packages.
    COLUMNS=125 dpkg -l | grep 3.2.[123456789] |less


    ii 3270-common 3.2.20-2 Common files for IBM 3270 emulators {x,c,s,tcl}3270, and pr32
    87
    ii apmd 3.2.1-4 Utilities for Advanced Power Management (APM)
    ii cpp 3.3.2-2 The GNU C preprocessor (cpp)
    ii cpp-3.2 3.2.3-9 The GNU C preprocessor
    ii dialog 0.9b-20031207-1 Displays user-friendly dialog boxes from shell scripts
    ii g++ 3.3.2-2 The GNU C++ compiler
    ii gcc 3.3.2-2 The GNU C compiler
    ii gcc-3.2-base 3.2.3-9 The GNU Compiler Collection (base package)
    ii hermes1 1.3.3+really1.3.2-2 The Hermes pixel-format library
    iU kdelibs-bin 3.2.2-2 KDE core binaries
    iU kdelibs4 3.2.2-2 KDE core libraries
    iU kdelibs4-dev 3.2.2-2 KDE core libraries (development files)
    ii libapm1 3.2.1-2 Library for interacting with APM driver in kernel
    ii libdb3 3.2.9-19 Berkeley v3 Database Libraries [runtime]
    ii libopenal0 0.2003020200-1.2 OpenAL is a portable library for 3D spatialized audio.
    ii libqt3-compat-headers 3.2.3-2 Qt 1.x and 2.x compatibility includes
    ii libqt3-headers 3.2.3-2 Qt3 header files
    ii libqt3-mt-dev 3.2.3-2 Qt development files (Threaded)
    ii libqt3c102-mt 3.2.3-2 Qt GUI Library (Threaded runtime version)
    ii librplay3 3.3.2-8 Shared libraries for the rplay network audio system.
    ii lyx 1.3.2-1 High Level Word Processor
    ii lyx-common 1.3.2-1 High Level Word Processor - common files
    ii lyx-qt 1.3.2-1 High Level Word Processor - Qt frontend
    ii mikmod 3.2.1-1 Portable tracked music player
    ii pcmcia-cs 3.2.5-2.3 PCMCIA Card Services for Linux
    ii qt3-designer 3.2.3-2 Qt3 Designer
    ii qt3-dev-tools 3.2.3-2 Qt3 development tools
    ii rplay-client 3.3.2-8 The basic rplay clients.
    ii dialog 0.9b-20031207-1 Displays user-friendly dialog boxes from shell scripts
    ii g++ 3.3.2-2 The GNU C++ compiler
    ii gcc 3.3.2-2 The GNU C compiler
    ii gcc-3.2-base 3.2.3-9 The GNU Compiler Collection (base package)
    ii hermes1 1.3.3+really1.3.2-2 The Hermes pixel-format library
    iU kdelibs-bin 3.2.2-2 KDE core binaries
    iU kdelibs4 3.2.2-2 KDE core libraries
    iU kdelibs4-dev 3.2.2-2 KDE core libraries (development files)
    ii libapm1 3.2.1-2 Library for interacting with APM driver in kernel
    ii libdb3 3.2.9-19 Berkeley v3 Database Libraries [runtime]
    ii libopenal0 0.2003020200-1.2 OpenAL is a portable library for 3D spatialized audio.
    ii libqt3-compat-headers 3.2.3-2 Qt 1.x and 2.x compatibility includes
    ii libqt3-headers 3.2.3-2 Qt3 header files
    ii libqt3-mt-dev 3.2.3-2 Qt development files (Threaded)
    ii libqt3c102-mt 3.2.3-2 Qt GUI Library (Threaded runtime version)
    ii librplay3 3.3.2-8 Shared libraries for the rplay network audio system.
    ii lyx 1.3.2-1 High Level Word Processor
    ii lyx-common 1.3.2-1 High Level Word Processor - common files
    ii lyx-qt 1.3.2-1 High Level Word Processor - Qt frontend
    ii mikmod 3.2.1-1 Portable tracked music player
    ii pcmcia-cs 3.2.5-2.3 PCMCIA Card Services for Linux
    ii qt3-designer 3.2.3-2 Qt3 Designer
    ii qt3-dev-tools 3.2.3-2 Qt3 development tools
    ii rplay-client 3.3.2-8 The basic rplay clients.
    ii transfig 3.2.5-alpha4-1 Utilities for converting XFig figure files
    ii wavtools 1.3.2-8 WAV play, record, and compression
    ii x3270 3.2.20-2 X11 program for telnet sessions to IBM mainframes
    ii xfig 3.2.5-alpha4-1 Facility for Interactive Generation of figures under X11
    ii xfonts-x3270-misc 3.2.20-2 Font files for the x3270(1) IBM 3270 emulator

    I'm not sure which files are KDE related directly. Anyway any suggestions on which way I should go to fix this? Would it be easier to remove kde and install it from scratch again. Would it be easier to remove the KDE 3.2 stuff and reinstall the KDE 3.1 packages? If so which packages should I remove and reinstall to the 3.1 packages? Should I go the other way and try to upgrade all packages to KDE 3.2? If so which packages are neccesary to update to the 3.2 versions?

    By the way here is my source list:
    # Security updates for "stable"
    deb http://security.debian.org stable/updates main contrib non-free
    deb http://security.debian.org testing/updates main contrib non-free

    # Stable
    deb http://ftp2.de.debian.org/pub/debian stable main contrib non-free
    deb http://ftp2.de.debian.org/pub/debian-non-US stable/non-US main contrib non-f
    ree

    # Sources
    deb-src http://ftp2.de.debian.org/pub/debian stable main contrib non-free
    deb-src http://ftp2.de.debian.org/pub/debian-non-US stable/non-US main contrib n
    on-free

    # Testing
    deb http://ftp2.de.debian.org/pub/debian testing main contrib non-free
    deb http://ftp2.de.debian.org/pub/debian-non-US testing/non-US main contrib non-
    free
    # Sources
    deb-src http://ftp2.de.debian.org/pub/debian testing main contrib non-free
    deb-src http://ftp2.de.debian.org/pub/debian-non-US testing/non-US main contrib
    non-free

    # Unstable
    deb http://ftp2.de.debian.org/debian unstable main contrib non-free
    deb http://ftp2.de.debian.org/debian-non-US unstable/non-US main contrib non-fre
    e

    # Sources
    deb-src http://ftp2.de.debian.org/debian unstable main contrib non-free
    deb-src http://ftp2.de.debian.org/debian-non-US unstable/non-US main contrib non
    -free

    # Experimental
    deb http://ftp2.de.debian.org/debian ../project/experimental main contrib non-fr
    ee
    deb-src http://ftp2.de.debian.org/debian ../project/experimental main contrib no
    n-free

    # KDE 3
    # deb http://ktown.kde.org/~nolden/kde stable main
    # deb-src http://ktown.kde.org/~nolden/kde stable main
    # We get packages from testing/unstable for now

    # Java
    deb ftp://ftp.gwdg.de/pub/languages/java/linux/debian woody main non-free
    deb-src ftp://ftp.gwdg.de/pub/languages/java/linux/debian woody main non-free
    deb ftp://ftp.gwdg.de/pub/languages/java/linux/debian unstable main non-free
    deb-src ftp://ftp.gwdg.de/pub/languages/java/linux/debian unstable main non-free
    # deb http://people.debian.org/~sgybas/jdk13

    # deb cdrom:[Debian GNU/Linux 2.2 r3 _Potato_ - Official i386 Binary-1 (20010427
    )]/ unstable contrib main non-US/contrib non-US/main


    # deb cdrom:[Debian GNU/Linux 2.2 r3 _Potato_ - Official i386 Binary-1 (20010427
    )]/ unstable contrib main non-US/contrib non-US/main

    #Unofficial Debian packages
    #woody
    deb ftp://ftp.nerim.net/debian-marillat/ stable main
    #sarge
    deb ftp://ftp.nerim.net/debian-marillat/ testing main
    #sid
    deb ftp://ftp.nerim.net/debian-marillat/ unstable main
    #source
    deb-src http://perso.wanadoo.fr/debian/ unstable main


    Sorry for this ugly long post.

    Basicaly just need to know which packages to remove, install, or upgrade to get KDE back again. If they are any shortcuts or predefined scripts to do this that would be cool to. Right now KDE half works but is a pain in the butt. Any help would be apreciated.

    Thanks

    ps was using hdinstall of 3.3 knoppix on dell inspiron 8600 laptop.
    If this doesn't work, may wipe knoppix and try gentoo next.

  2. #2
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    ugly list follows:
    COLUMNS=125 dpkg -l | grep 3.1.[345] |less
    ii kdepim 3.1.5-1.1 KDE Personal Information Management metapackage
    ii kdepim-kfile-plugins 3.1.5-1.1 KDE File dialog plugins for vcf files.
    ii kdepim-libs 3.1.5-1.1 KDE PIM libraries
    ii kernel-patch-xfs 1.3.1-3 XFS Filesystem support for Linux 2.4.22, 2.4.23 and 2.4.24
    ii less 381-3 Pager program similar to more
    ii vegastrike 0.3.1-5.1 A 3d space combat game
    You want to use apt-get -s -t unstable all the other packages in the output of the command I have snipped above on the one command line if the simulated output looks good then remove the -s to actually install. If it starts to complain about missing packages add them to the end of the line. If you want to get back to the 3.1.5 packages then change to the /var/cache/apt/archives directory and use dpkg -i package_needed_version-3.1.5.???.deb ..... , you would put every package that you need installed at the old version on the same command line.

  3. #3
    Junior Member
    Join Date
    May 2004
    Posts
    7

    Hmm could you elaborate a little?

    Do you mean
    apt-get -s -t unstable PACKAGENAMES from the list generated by the dpkg -i command? Could you give me one example.

    Meanwhile I'm using fluxbox till I can get KDE going again. By the way I just got a dvd with debian sarge release. Debating whether or not to just upgrade all packages. Is there a way just to force an upgrade of all packages whether it likes it or not. Anyone try this? from knoppix 3.3?

    Thanks again for any advice.

  4. #4
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479

    Re: Hmm could you elaborate a little?

    Quote Originally Posted by samwhich
    Do you mean
    apt-get -s -t unstable PACKAGENAMES from the list generated by the dpkg -i command? Could you give me one example.

    Meanwhile I'm using fluxbox till I can get KDE going again. By the way I just got a dvd with debian sarge release. Debating whether or not to just upgrade all packages. Is there a way just to force an upgrade of all packages whether it likes it or not. Anyone try this? from knoppix 3.3?

    Thanks again for any advice.
    I mean use the command ( COLUMNS=125 dpkg -l | grep 3.1.[345]) to get the list then exclude all the packages I listed in my post from the apt-get -s -t unstable install package1 package2 ... package 25 ..... command to upgrade the rest of KDE to the 3.2 packages. If you want to try to upgrade everything to unstable then apt-get -s -t unstable dist-upgrade may work but you are better off just upgrading the KDE packages. Or you can find the KDE packages that are at the 3.2 level (COLUMNS=125 dpkg -l | grep 3.2.[012]) then you change to the apt archives directory and install those packages at the old version with dpkg -i to get back to where you were.

  5. #5
    Junior Member
    Join Date
    May 2004
    Posts
    7
    Hi, I tried your suggestion. I typed in :
    apt-get -s -t unstable install amor

    I got this in response:
    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    k3b: Depends: k3blibs (>= 0.11.9) but it is not going to be installed
    kdelibs4: Depends: kdelibs-data (>= 4:3.2.1) but 4:3.1.5-1 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    I tried installing seperatly k3blibs then data etc. Same error. Seems to ultimately revolve around k3b: Depends: k3blibs (>= 0.11.9) but it is not going to be installed

    Is there a specific order to install deb packages that will get you around this? Or am I doing something incorrectly. amor was the first package listed when I typed
    ( COLUMNS=125 dpkg -l | grep 3.1.[345])
    .

    Thanks again.

  6. #6
    Senior Member registered user
    Join Date
    Feb 2003
    Location
    Nova Scotia, Canada
    Posts
    2,479
    Quote Originally Posted by samwhich
    Hi, I tried your suggestion. I typed in :
    apt-get -s -t unstable install amor

    I got this in response:
    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    k3b: Depends: k3blibs (>= 0.11.9) but it is not going to be installed
    kdelibs4: Depends: kdelibs-data (>= 4:3.2.1) but 4:3.1.5-1 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    I tried installing seperatly k3blibs then data etc. Same error. Seems to ultimately revolve around k3b: Depends: k3blibs (>= 0.11.9) but it is not going to be installed

    Is there a specific order to install deb packages that will get you around this? Or am I doing something incorrectly. amor was the first package listed when I typed
    ( COLUMNS=125 dpkg -l | grep 3.1.[345])
    .

    Thanks again.
    You take them all and put them on the same line in this case apt-get -s -t unstable install amor k3blibs kdelibs-data .... do this with all the packages in the list except the ones I told you to skip if it complains about a package(s) missing after this then just keep adding them to the end of the line when you get to the point where it will just install then remove the -s from the line and let it go. You are going to end up with errors telling you that certain packages would not install when this happens then use dpkg -i --force-overwrite /var/cache/apt/archives/package.deb .... there probably will be several just put them on the same command line then force the overwrite and use dpkg --configure -a to configure any missed packages and you may want to remove and reinstall some small program just to make sure everything works properly after this.

Similar Threads

  1. Install Pinugs with KPackage
    By s-m-n in forum Games
    Replies: 4
    Last Post: 08-16-2005, 09:08 AM
  2. goofed with apt-get update booting takes more than 10 minute
    By ramaswamyps in forum Customising & Remastering
    Replies: 7
    Last Post: 08-05-2005, 02:42 AM
  3. goofed again with fdisk and scandisk win98
    By ramaswamyps in forum Customising & Remastering
    Replies: 0
    Last Post: 03-03-2005, 04:58 PM
  4. I goofed installing Knode!
    By Bob_Ullet in forum General Support
    Replies: 0
    Last Post: 11-01-2003, 03:06 AM
  5. Kpackage
    By Madcatz in forum General Support
    Replies: 2
    Last Post: 06-08-2003, 07:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •