Results 1 to 8 of 8

Thread: winxp, gentoo, knoppix, grub, and a boot error message

  1. #1
    Junior Member registered user
    Join Date
    Apr 2004
    Posts
    12

    winxp, gentoo, knoppix, grub, and a boot error message

    Ok, here's the history: a while back, I got my work laptop (Dell latitude C640) dual booting with winXP and gentoo. I was using grub as the bootloader, and after a little bit of tweaking, it's been working great since last september. I hardly ever really used the linux side of things though, until lately, when I've been using clusterknoppix 3.3 at home a lot. So, I figured that I'd wipe the gentoo side, and load clusterknoppix instead.

    There are 4 partitions on the drive, hda1=windows; hda2= /boot; hda3= swap; hda4=/ . This was how it was set up when I was running gentoo.

    So, i cranked up clusterknoppix, and created a persistent home directory on hda2.

    Then, I rebooted (to use the persistent home directory) and ran knoppix-installer through the config part, then saved the config to my persistent /home/knoppix.

    Then, I went in and edited the config file, making a couple minor changes: I set hda4 to be a reiserfs file system (like it was with Gentoo) and I also used the 'experimental' bit about mapping drives, to map /boot to my former /boot partition, hda2. then, i cranked knoppix-install up again, loaded the config file, and away I went.

    Here is where things started to get funky. I didn't want to blow away my Grub install in the mbr, so in the config i selected lilo to install on the root partition (hda4). That way i figured that since the MBR would look at Grub, all I'd have to do was change a couple lines in grub, it wouldn't be a problem. The installer finished up, so i took a look at my new /boot partition, and all my old files were there, with the new ones from Knoppix. initrd, map, vmlinuz, the usual.

    So, i re-wrote grub.conf to use the correct filenames with the new setup:

    my grub.conf file:
    Code:
    original (with gentoo):
    default saved
    timeout 15
    splashimage=(hd0,1)/boot/grub/splash.xpm.gz
    title=Gentoo Linux
    root (hd0,1)
    kernel (hd0,1)/boot/kernel-2.4.20-gentoo-r6
    initrd (hd0,1)/boot/initrd-2.4.20-gentoo-r6
    savedefault
    
    title=Gentoo Linux kernel rebuild
    root (hd0,1)
    kernel (hd0,1)/boot/firstbuild
    savedefault
    
    title=Windows XP
    root (hd0,0)
    chainloader +1
    savedefault
    Code:
    the newest one, with clusterknoppix:
    default saved
    timeout 15
    splashimage=(hd0,1)/boot/grub/splash.xpm.gz
    title=ClusterKnoppix-Debian
    root (hd0,1)
    kernel (hd0,1)/boot/vmlinuz-2.4.24-openmosix-1
    initrd (hd0,1)/boot/initrd.gz
    savedefault
    
    title=Windows XP
    root (hd0,0)
    chainloader +1
    savedefault
    Now, when I try booting from the HD, grub opens fine, and when i select my Knoppix, the last few lines before Kernel Panic are:

    Code:
    RAMDISK: Compressed image found at block 0
    Freeing initrd memory: 98k freed
    VFS: Mounted root (ext2 filesystem).
    kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno=2
    VFS: Cannot open rood device "" or 08:01
    Please append a correct "root=" boot option
    Kernel Panic: VFS: unable to mount rootfs on 08:01
    I'm not exactly sure what do to at this point, I tried all sorts of "root=" options in grub, and i just can't get it to work. Is the problem something with the modprobe error? is it something with the reiserfs filesystem? Should I re-do the whole thing using ext3 instead of reiserfs?

    Anyway, what are your thoughts?

    --sarge

  2. #2
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    872
    block device major 8 is sda. Why does you system want to access it is beyond me though as there is an initrd involved, you need to look into the linuxrc file in it to get a clue.

  3. #3
    Junior Member registered user
    Join Date
    Apr 2004
    Posts
    12

    linuxrc file

    well, i finally (after a while) managed to get to what I think is the linuxrc file:

    linuxrc:
    Code:
    #!/static/sh
    insmod /modules/reiserfs.o
    there is also a modules folder inside the initrd image, with suprise suprise, reiserfs.o.

    but that's it for the initrd file.


    any ideas?

    --sarge

  4. #4
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    872
    no, it is not about that. there is some modprobe thing going on trying to access 8,1 which is /dev/sda1. Either it is embedded in the kernel when it is compiled or it is specified some where in the linuxrc.

  5. #5
    Junior Member registered user
    Join Date
    Apr 2004
    Posts
    12
    so basically, I'll need to rebuild the kernel to NOT look for the sda device (that's a SCSI device isn't it?) If I were to specify 'no scsi' in the bootup of the CD, then do a reinstall, do you think it would knock that bit out? I'm not sure if when you do an hd install if it recompiles the kernel for you or not.

    Thanks, by the way, even though this isn't solved yet, it's at least massaging my brain a little bit.


    --Jorden

  6. #6
    Junior Member registered user
    Join Date
    Apr 2004
    Posts
    12

    still fumbling around

    well, I'm still fumbling around trying to find the actual linuxrc that's being used, so I can check it out.

    Where is it, and how do I open that file up for editing? or even for viewing, at the least?


    --sarge

  7. #7
    Senior Member registered user
    Join Date
    Mar 2003
    Posts
    872
    you cannot edit those files in initrd, usually. Assuming it is a compressed ext2 file system, you need to first gzip -d to decompressed it then loop mount that and after that you can edit the file. Reverse the above when done.

    However, I am just curious of why a root=/dev/hdaX didn't work. It should usually.

  8. #8
    Junior Member registered user
    Join Date
    Apr 2004
    Posts
    12

    hmm....

    thats what I thought too. but I always get an 'unexpected end of file' error when trying to gunzip the initrd file.

    i messed around with grub on the command line for a bit, and when I do
    Code:
    root (hd0,1)
    kernel (hd0,1)/boot/vmlinuz-2.2.24-openmosix-1
    boot
    I get the VFS error.

    but, when I do:
    Code:
    root (hd0,1)
    kernel (hd0,1)/boot/vmlinuz-2.2.24-openmosix-1
    initrd (hd0,1)/boot/initrd-2.2.24
    boot
    I now get a RAMDISK: compressed image found at block 0 error instead.

    I wonder if it isn't something to do with the fact that this is a laptop, maybe the autodetect stuff works fine from the CD, but when moved to an HD install, it's broken.. so it thinks that I've got something thats a SCSI device, but it's not?

    I'm going to try the 3.4 release of Knoppix, and see if that changes things, and if not, then a 3.3 release of Knoppix. maybe it's the clusterKnoppix distro that's a little funky.

    At least I'm halfway enjoying this experience.

    -sarge

Similar Threads

  1. Error message on boot up
    By jkwash in forum Hardware & Booting
    Replies: 1
    Last Post: 05-21-2005, 12:18 PM
  2. configs.tbz/knoppix.sh related error message on boot
    By gadgerama in forum Hardware & Booting
    Replies: 3
    Last Post: 05-18-2005, 12:11 PM
  3. Installing KNOPPIX.V3.6 Boot error message
    By sala94 in forum General Support
    Replies: 2
    Last Post: 12-21-2004, 04:20 PM
  4. Dual boot problem winxp/knoppix (GRUB)
    By hukdonfonix in forum Hdd Install / Debian / Apt
    Replies: 8
    Last Post: 12-04-2004, 06:39 PM
  5. HD install, LILO to GRUB conversion, boot error message.
    By ocean in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 10-01-2004, 01:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •