Have tried different approaches...
Hi,
I've tried Knoppix 3.2 version 5/21/03. Thank you. The QTParted program has been enhanced with new features. It does resize partition really great, however, it didn't work on bare drive. I've wiped it clean, dumped Windoze, and experimented with reiserFS and ext3. I've discovered running MicroScope that the hard drive has an error in the "system sector." Whatever that may be. The drive is temperamental, it sounds really bad, like an old LP record when the needle finished playing all the tracks, some a rocker arm is hitting an aperture while its trying to do some kind of write operation beyond where the sector ends. I thought this might be a virus. After low level format, I used fdisk to create win-32 partition, because when I launched QTparted, it just crashed not sure what I wanted it to do, I guess. I also bought a new 40 gig drive. Then using CFSK I changed the single partition to Linux swap 500 MB and remainder /home using reiser. I could not boot, I got 'kernel panic' message. I'm planning to try out also copying iso image onto 1.2 gig drive and using it as if it were a CD-ROM. Will let you know how it turns out. Unfortunately, "ars longa vita brevis" and there is so many options yet to try.
Regards,
Joseph Schiller
Re: Have tried different approaches...
Quote:
Originally Posted by Joseph Schiller
Hi,
I've tried Knoppix 3.2 version 5/21/03. Then using CFSK I changed the single partition to Linux swap 500 MB and remainder /home using reiser. I could not boot, I got 'kernel panic' message.
Did you make the file systems on the drive. eg sudo mkswap /dev/hd?? for the /swap or sudo mkreiserfs /dev/hd?? for the reiser filesystem for the /home before you re-booted?
reinstalled all over again
Hi,
Thanks. BTW, I couldn't have done it without you.
I could'nt tell what was missing in the install, at 40% in the script I was getting input/output errors, but the script recovered and completed. I like the auto recovery feature. So if something was corrupted, the install did not live long enough for me to discover what that was.
I reinstalled again, this time I've set up hda1 as 500 MB swap, hda2 4500 MB reiser, and hda3 1500 MB reiser, but running CFDISK, I noticed that hda2 is not reiserFS at all, it went in as ext2. This time I did not have to edit of configure LILO, it did write itself to MBR during script install. But I am dumbfounded that hda2 is not reiserFS. I opted for that specifically because the hd is defective. I'm not sure how that happened, but I used console and the commands that I learned "mkreiserfs /hda2" and "mkreiserfs /hda3", but I must have goofed running cfdisk when seperating out 1500 MB partition. At the moment everything works great, save a minor glitch with /etc/resolv.conf which I don't understand yet. I've never had to edit it manually before, and I've discovered it had a sym link to /etc/dhcpc/resolv.conf, and I followed exactly the same steps.
Regards,
Joseph Schiller
Re: reinstalled all over again
Quote:
Originally Posted by Joseph Schiller
Hi,
Thanks. BTW, I couldn't have done it without you.
I could'nt tell what was missing in the install, at 40% in the script I was getting input/output errors, but the script recovered and completed. I like the auto recovery feature. So if something was corrupted, the install did not live long enough for me to discover what that was.
I reinstalled again, this time I've set up hda1 as 500 MB swap, hda2 4500 MB reiser, and hda3 1500 MB reiser, but running CFDISK, I noticed that hda2 is not reiserFS at all, it went in as ext2. This time I did not have to edit of configure LILO, it did write itself to MBR during script install. But I am dumbfounded that hda2 is not reiserFS. I opted for that specifically because the hd is defective. I'm not sure how that happened, but I used console and the commands that I learned "mkreiserfs /hda2" and "mkreiserfs /hda3", but I must have goofed running cfdisk when seperating out 1500 MB partition. At the moment everything works great, save a minor glitch with /etc/resolv.conf which I don't understand yet. I've never had to edit it manually before, and I've discovered it had a sym link to /etc/dhcpc/resolv.conf, and I followed exactly the same steps.
Regards,
Joseph Schiller
cfdisk set the partition as a linux partition which IIRC is set by default to ext2 you just had to use the type option to set it as reiser. Any time I have installed I usually use cfdisk and format the partitions before I run the script and just quit from cfdisk when it comes up and continue with the script.
I think your resolv.conf problems have something to do with the groups your user belongs too I have responded to your other post although it could be one of those annoying things that get changed when you install and you have to configure the settings manually.